Fedora Linux Support Community & Resources Center
  #1  
Old 2nd April 2007, 06:03 AM
yinglcs Offline
Registered User
 
Join Date: Mar 2006
Posts: 176
Fedora can't boot up after I install kernel-smp

Hi,

I have installed Fedora 5 on an external hard drive. It (2.6.15) works fine.
But after I installed 'kernel-smp' via yum, I can't boot up with the new kernel (2.6.20).

I get error message like this:

Unable to access resume device (LABEL=SWAP-sda4)
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

I read this thread, but I am not sure how to resolve my problem:
http://www.fedoraforum.org/forum/sho...d.php?t=114724

Any idea is appreciated.
Reply With Quote
  #2  
Old 2nd April 2007, 06:33 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,772
So the 2.6.15 works but the 2.6.20 doesn't. I haven't kept up with FC5, but there have been changes to udevd that *may* impact your problem.

First take a look in /boot/grub/grub.conf and make sure the arguments on the "kernel" lines
match for the working & nonworking. If that's not it then I'd verify that the /boot/initrd... for the new kernel was built when you installed the kernel. If not you may need to run mkinitrd again ,but check the /etc/modprobe.conf file first.
Reply With Quote
  #3  
Old 2nd April 2007, 07:58 AM
DamianS Offline
Registered User
 
Join Date: Feb 2007
Posts: 94
I think the problem is the transition to the new hd/sd renaming.
This post may shed some light on what is happening:
http://kernelslacker.livejournal.com/66702.html
__________________
This is Linux country. On a quiet day, you can hear the sound of windows' machines rebooting :p
Reply With Quote
  #4  
Old 2nd April 2007, 03:10 PM
yinglcs Offline
Registered User
 
Join Date: Mar 2006
Posts: 176
Thansk. I look at /boot/grub/grub.conf

They look the same:
title Fedora Core (2.6.20-1.2300.fc5smp)
root (hd0,0)
kernel /vmlinuz-2.6.20-1.2300.fc5smp ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.20-1.2300.fc5smp.img
title Fedora Core (2.6.15-1.2054_FC5)
root (hd0,0)
kernel /vmlinuz-2.6.15-1.2054_FC5 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.15-1.2054_FC5.img
Reply With Quote
  #5  
Old 2nd April 2007, 03:52 PM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hello:
When you installed the new kernel did you have the USB attached to the same machine as when you installed the 2.6.15 kernel ?
Or was the USB attached to a different machine when you installed the new kernel ?

Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #6  
Old 2nd April 2007, 06:12 PM
yinglcs Offline
Registered User
 
Join Date: Mar 2006
Posts: 176
I did have the external machine hookup to the same machine.
Reply With Quote
  #7  
Old 4th April 2007, 02:36 AM
yinglcs Offline
Registered User
 
Join Date: Mar 2006
Posts: 176
Any idea please, I am still not able to resolve my problem. I would like to take advantage of the dual core machine that I have.
thanks.
Reply With Quote
Reply

Tags
boot, fedora, install, kernelsmp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot after install gives kernel panic failure eldiener Using Fedora 3 22nd August 2009 04:13 AM
cloned F11 install refuses to boot (kernel hang) whitehat2009 Installation, Upgrades and Live Media 2 24th June 2009 09:59 PM
Fedora 9: latest kernel update (kernel-2.6.25.10-86) won't boot anymore alwin Using Fedora 8 2nd November 2008 02:11 PM
FC4 fresh install, no SMP kernel boot, UP kernel boots OK tigerplish EOL (End Of Life) Versions 4 15th August 2005 10:19 PM


Current GMT-time: 23:36 (Friday, 22-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat