Fedora Linux Support Community & Resources Center
  #1  
Old 2nd April 2007, 09:22 AM
lancedance Offline
Registered User
 
Join Date: Jan 2007
Location: Beijing, China
Age: 28
Posts: 131
libglut.so.3 is needed by FlightGear-0.9.10-0.FC.i386

hi,
I have got some problem when I install something.

[root@localhost game]# rpm -i FlightGear-0.9.10-0.FC.i386.rpm
error: Failed dependencies:
libglut.so.3 is needed by FlightGear-0.9.10-0.FC.i386
openal >= 20050209 is needed by FlightGear-0.9.10-0.FC.i386

Which package I am lack of to install the libglut.so.3?
And I am sure I have the latest version of openal install, why it said openal >= 20050209 is needed by FlightGear-0.9.10-0.FC.i386?

thanks
Reply With Quote
  #2  
Old 2nd April 2007, 03:27 PM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,620
You need to install freeglut (and possibly freeglut-devel). Fedora Extras has that.
Which version of openal do you have? To find out, do this: rpm -q openal
The latest one available on Fedora Extras is openal-0.9.20060204cvs.fc6.i386.rpm.
Reply With Quote
  #3  
Old 29th May 2010, 04:26 AM
rajeesh Offline
Registered User
 
Join Date: May 2010
Posts: 1
linuxfedorafirefox
Re: libglut.so.3 is needed by FlightGear-0.9.10-0.FC.i386

I've some problem when I try to install FlightGear-0.9.10-0.FC.i386.rpm . I'm using fedora 12. It ask some dependencies like
libopenal.so.0 and openal >= 20050209.
Reply With Quote
  #4  
Old 29th May 2010, 04:47 AM
BugRocks1 Offline
Registered User
 
Join Date: Jan 2010
Posts: 894
linuxfedorafirefox
Re: libglut.so.3 is needed by FlightGear-0.9.10-0.FC.i386

To see what packages those dependencies are in one can use the "yum provides" command.

yum provides *libglut.so.3

e.g.:
Quote:
$ yum provides *libglut.so.3
Loaded plugins: presto, refresh-packagekit
freeglut-2.6.0-3.fc13.i686 : A freely licensed alternative to the GLUT library
Repo : fedora
Matched from:
Other : libglut.so.3
Filename : /usr/lib/libglut.so.3
Reply With Quote
Reply

Tags
flightgear0fci386, libglutso3, needed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Needed: advansys.o i386 compiled driver shopping_harves Hardware & Laptops 2 24th May 2011 12:15 PM
qt is needed by (installed) qt-x11-4.3.4-11.fc9.i386 mafc Installation, Upgrades and Live Media 6 10th July 2008 01:47 AM
libglut + beryl = problem!!! drhilbert Using Fedora 4 26th June 2007 01:10 PM
libXp.so.6 is needed by XnView-1.70-1.i386 ramaswamyps Installation, Upgrades and Live Media 17 10th September 2005 11:21 AM
liblinc.so.1 is needed by mysql-query-browser-1.1.5-1.rh9.i386 nuaing Using Fedora 2 1st March 2005 04:41 AM


Current GMT-time: 03:33 (Saturday, 23-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat