Fedora Linux Support Community & Resources Center
  #1  
Old 22nd May 2007, 09:13 PM
syrex Offline
Registered User
 
Join Date: May 2007
Posts: 6
Unable to file share using Samba

Hi,

I am pretty new to Linux, trying to make a share server run on Fedora Core 6. I have all the latest updates applied. I initially could not log in to the server from my XP SP2 box (192.168.1.5), but I could reach the shared folder on the XP client from my Linux box. After reading so many posts, and trying different things, Fedora can no longer even see the Windows workgroup anymore, although I can ping the XP box and browse the Net.

From XP, trying to get into the server, I get the standard not accessible error.

Here are some things I captured to try to see if someone can spot what I have wrong:

[root@Drake ~]# testparm /etc/samba/smb.conf
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[Shared]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
server string = Drake
interfaces = etho, eth1, lo
log file = /var/log/samba/%m.log
max log size = 50
dns proxy = No
hosts allow = 192.168.1.0/24, 127.
hosts deny = all
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /usr/spool/samba
printable = Yes
browseable = No

[Shared]
comment = Shared files
path = /mnt/G-Drive/shared
read only = No
guest ok = Yes



smbd.log:

[2007/05/21 11:24:29, 0] smbd/server.c:main(847)
smbd version 3.0.24-5.fc6 started.
Copyright Andrew Tridgell and the Samba Team 1992-2006


nmbd.log:

[2007/05/21 11:24:29, 0] nmbd/nmbd.c:main(700)
Netbios nameserver version 3.0.24-5.fc6 started.
Copyright Andrew Tridgell and the Samba Team 1992-2006


192.168.1.5.log:

empty


main.log:

[2007/05/21 11:24:57, 0] smbd/service.c:make_connection_snum(920)
'/mnt/G-Drive/shared' does not exist or permission denied when connecting to [Shared] Error was Permission denied
[2007/05/21 11:24:58, 0] smbd/service.c:make_connection_snum(920)
'/mnt/G-Drive/shared' does not exist or permission denied when connecting to [Shared] Error was Permission denied
[2007/05/21 11:24:58, 0] smbd/service.c:make_connection_snum(920)
'/mnt/G-Drive/shared' does not exist or permission denied when connecting to [Shared] Error was Permission denied
[2007/05/21 11:25:03, 0] smbd/service.c:make_connection_snum(920)
'/mnt/G-Drive/shared' does not exist or permission denied when connecting to [Shared] Error was Permission denied

I double checked my capitalization, and /mnt/G-Drive/shared is the correct spelling of my shared area. I should also note that the shared area exists on a ntfs formatted drive that is being accessed through ntfs-3g. I also have a server 2003 partition on this machine also using this drive, and I hope to eventually store large files on the drive, so need a fs that can handle 4gig+ files that Windows can read.

Can anyone help? Thanks!
Reply With Quote
  #2  
Old 22nd May 2007, 11:04 PM
TexasMo Offline
Registered User
 
Join Date: Jan 2007
Posts: 22
maybe make check your firewall to allow smb ports to be open and accessible..
also,, make sure you have a user added with smbpasswd -a user.. then enable the user with smbpasswd -e user

It took me while to remember to do that part.. and every time.. doink.. no smb share would be found..lol

good luck..
__________________
mherringjr.com
Reply With Quote
  #3  
Old 23rd May 2007, 10:41 AM
barf Offline
Registered User
 
Join Date: Dec 2004
Location: UK
Age: 59
Posts: 274
FYI SWAT is a Samba configuration tool which will make managing Sambe simpler.
__________________
Stop making excuses, start making progress.
Reply With Quote
  #4  
Old 23rd May 2007, 12:15 PM
jhetrick62 Offline
Registered User
 
Join Date: Feb 2005
Location: Buffalo, Ny
Posts: 875
Swat can be both a blessing and at times confusing. You are missing the first rule of thumb with samba, start very small and simple and after it works, add features one by one so that you can see their effect.

IMHO, take out the host allow and host deny lines. Unless you are truly attempting to restrict someone form within your LAN, these are unnecessary if your router is setup properly and your server is the only box that is accessible to the WAN. As I said before, after it is working, you can experiment with that stuff.

Take a look at this thread for a basic howto on getting samba running. http://www.fedoraforum.org/forum/showthread.php?t=94257
Honestly, I haven't used the stock samba conf file in 3 years as after I got mine the way I wanted, I have copied it over to my next install and every time it has worked with minor tweaks.

I can say that my family accesses my server off of a mixed environment, and one thing that I always use is the netbios name for the server. I also run the wins server on my samba box. It seems to make the windows machines like it a little better. But try that AFTER you get a working system.

I also didn't see a line in your post indicating that security was set to user.
__________________
Registered Linux User #411071

If at first you don't suceed, read the man page again!
Reply With Quote
  #5  
Old 24th May 2007, 06:11 AM
brad_c6 Offline
Registered User
 
Join Date: Feb 2007
Posts: 41
It may help by changeing SELINUX to Permissive (Then it worked for me)
Reply With Quote
  #6  
Old 24th May 2007, 06:45 PM
syrex Offline
Registered User
 
Join Date: May 2007
Posts: 6
Quote:
Originally Posted by jhetrick62
IMHO, take out the host allow and host deny lines. Unless you are truly attempting to restrict someone form within your LAN, these are unnecessary if your router is setup properly and your server is the only box that is accessible to the WAN. As I said before, after it is working, you can experiment with that stuff.
Long story short, I completely rebuilt my FC6 box from scratch. I left out the hosts deny and allow this time.

Quote:
Originally Posted by jhetrick62
Take a look at this thread for a basic howto on getting samba running. http://www.fedoraforum.org/forum/showthread.php?t=94257
Followed this almost to the letter. The only thing I did not mess with was groups, but did EVERYTHING else.

Quote:
Originally Posted by jhetrick62
I also didn't see a line in your post indicating that security was set to user.
For some reason it doesn't show up in the testparm results but it is in there.

So, still not able to access. Verified that the service is running. From windows, I can browse the workgroup and see the "shared" and "Mike" (me) folders showing up on server Drake. However, it does not like to open them:

"\\Drake\shared is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The network path was not found."

Access for this share is wide open, 777.

When I tried mapping a drive to the share, which shows up just fine under the windows workgroup, I get the error "The network path was not found." I also tried this using the IP instead of the server name, same result.

For grins and giggles, I tried using username "root" and the root password for authentication, and never got the error, it just kept prompting for a new username/password combo.

Any ideas? (Thanks for everything so far!)
Reply With Quote
  #7  
Old 25th May 2007, 07:40 PM
syrex Offline
Registered User
 
Join Date: May 2007
Posts: 6
OK, it's working, but...

I was playing around to see if it was the firewall, so I disabled it and it was not. I then went to the SELinux tab of the "Security Level and Firewall" wizard, and changed SELinux from 'Enforcing' to 'Permissive'. It was at this point that I could access the share.

So, the question now, is, what exactly did I do, and should I undo it?
Reply With Quote
  #8  
Old 25th May 2007, 08:53 PM
rclark Offline
Registered User
 
Join Date: Nov 2004
Location: MT USA
Posts: 678
Naw, Personally, if you are running in a home network, selinux just gets in your way. I just disabled mine. Unix/Linux has run just fine without it for years. I do the same to my servers at work that are in the corporate network (which are not exposed to the WWW) as again it is just that much more to keep track of for security I really don't need. But that is my opinion only .
Reply With Quote
  #9  
Old 25th May 2007, 09:29 PM
syrex Offline
Registered User
 
Join Date: May 2007
Posts: 6
Quote:
Originally Posted by rclark
Naw, Personally, if you are running in a home network, selinux just gets in your way.
Ah, but my ultimate goal will have this exposed to the web. Will the firewall permissions be enough to leave SELinux off as well, if I'm running a LAMP server, and email?
Reply With Quote
  #10  
Old 26th May 2007, 01:29 AM
marcrblevins Offline
Registered User
 
Join Date: Jun 2006
Location: Texas
Age: 43
Posts: 4,168
Selinux is our Big Brother's stuff(NSA). Its your preference to disable or enable.

I currently have it running. Just have to tinker with Selinux/Firewall program some more.
Reply With Quote
  #11  
Old 2nd June 2007, 09:43 AM
crolma4 Offline
Registered User
 
Join Date: May 2007
Location: Cleveland, spiritual center of the rust belt
Posts: 34
The only parts of SELinux that need to back off are protections for nmbd and smbd, which you can change by going
system-config-securitylevel
in bash, which brings up a GUI. Navigate to the samba list on teh SELinux tab and hit the check boxes.
Reply With Quote
  #12  
Old 14th June 2007, 12:14 PM
barf Offline
Registered User
 
Join Date: Dec 2004
Location: UK
Age: 59
Posts: 274
SE linux But not if you install setroubleshoot. If SE is blocking something it tells you so and even comes up with (mostly useful) instructions on how to fix the problem. My 2 cents
__________________
Stop making excuses, start making progress.
Reply With Quote
Reply

Tags
file, samba, share, unable

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab: Unable to mount Samba share BradW Using Fedora 11 4th July 2006 10:47 PM
Unable to write to windows samba file linearfish Servers & Networking 1 20th February 2006 10:11 PM
Samba File Share drewsmith Servers & Networking 10 2nd May 2005 01:40 AM
cannot share file using samba apit Servers & Networking 7 8th November 2004 06:22 AM


Current GMT-time: 17:43 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat