Fedora Linux Support Community & Resources Center
  #1  
Old 1st June 2007, 07:15 AM
emnahirn1 Offline
Registered User
 
Join Date: Jun 2007
Posts: 2
Question via_pata IDE driver

I am trying to load Fedora 7. My PC is Pentium III / ASUS CUV4X based. The problem is that during the installation, I can not get past the Loading SCSI Driver. The installation is unable to assign the pata_via HD IDE driver which is necessary for the build. I have seen some references on the internet that the pata_via HD IDE driver is not supported in all kernels. Is there a work around so I can continue with the Build?
Reply With Quote
  #2  
Old 1st June 2007, 11:37 AM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
try adding 'noapic' to the kernel parameters

If it's doesn't work then you may have to wait for a kernel update (or maybe someone else knows of other kernel options to try for this board). Have you installed FC6 or any other linux distros successfully on this pc?
Reply With Quote
  #3  
Old 4th June 2007, 06:15 AM
emnahirn1 Offline
Registered User
 
Join Date: Jun 2007
Posts: 2
Thanks for info. I had this board working in Fedora Core 3. In Fedora Core 3, I just moved my hard drive from another PC to the current PC, and booted. After a longer boot then normal, i.e. the system detected a number of driver changes, the PC was working in FC3. I tried the upgrade in FC6, and now FC7 with the same issue; They both have problems loading the pata_via driver. I'll need to figure out how to chang the 'noapic' to the kernel parameters on boot...
Reply With Quote
  #4  
Old 4th June 2007, 10:42 AM
sblantipodi Offline
Registered User
 
Join Date: Nov 2006
Location: Italy
Posts: 57
some problem here only in fc7 with abit kr7a.
__________________
How fast is your phone/PDA? What special features does it have? FPC Bench can tell you! Try it is free!
My Linux Kernel patch for Motorola RAZR V3x!
Reply With Quote
  #5  
Old 4th June 2007, 11:14 AM
sblantipodi Offline
Registered User
 
Join Date: Nov 2006
Location: Italy
Posts: 57
noapic doen't solve this problem
__________________
How fast is your phone/PDA? What special features does it have? FPC Bench can tell you! Try it is free!
My Linux Kernel patch for Motorola RAZR V3x!
Reply With Quote
  #6  
Old 4th June 2007, 02:30 PM
AlexDudko Offline
Registered User
 
Join Date: Mar 2007
Location: Ukraine
Posts: 381
Almost the same problem: installationfreezes with Loading pata-sis driver... on one of my boxes. FC6 and several other systems installed successfully on it.
If someone solves the problem - let us know, plz!
Reply With Quote
  #7  
Old 4th June 2007, 02:45 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
If you have a ps/2 keyboard and mouse then apparently 'nousb' option helps

http://fcp.surfsite.org/modules/newb...38133&forum=10

(To add options with the live cd press tab at the loading screen, with a normal install disk just add them to the boot options, 'linux nousb')
Reply With Quote
  #8  
Old 5th June 2007, 01:37 PM
sblantipodi Offline
Registered User
 
Join Date: Nov 2006
Location: Italy
Posts: 57
ok, I've found a workaround and now it works for me.

- Add a temp partition to your hd.
- Copy F7 iso to this partition.
- Boot from DVD, when loading PATA_VIA driver your dvd rom will be stopped, now think that your PC has only one hd drive and nothing else.
- Point installation to the temp partition and install F7 from the iso you have selected.
- After installation,recompile the kernel and use VIA82CXXX instead of PATA_VIA.

Have fun
__________________
How fast is your phone/PDA? What special features does it have? FPC Bench can tell you! Try it is free!
My Linux Kernel patch for Motorola RAZR V3x!
Reply With Quote
  #9  
Old 13th July 2007, 10:16 PM
ronald.watson Offline
Registered User
 
Join Date: Aug 2006
Posts: 37
Quote:
Originally Posted by emnahirn1
I am trying to load Fedora 7. My PC is Pentium III / ASUS CUV4X based. The problem is that during the installation, I can not get past the Loading SCSI Driver. The installation is unable to assign the pata_via HD IDE driver which is necessary for the build. I have seen some references on the internet that the pata_via HD IDE driver is not supported in all kernels. Is there a work around so I can continue with the Build?
I've had the same problem with Fedora 7... On the other hand, I did not experience the problem using Unbreakable Linux 4 or Ubuntu 7.0.4 desktop .... so there's some issue with the installer scrpts and/or the lack of a driver. My bet's on the installer....
Reply With Quote
Reply

Tags
driver, ide, viapata

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver needs driver??(driver problem) jarmen_kell Installation, Upgrades and Live Media 5 23rd July 2007 10:04 AM
Fedora 6 ATI driver and livna proprietary driver jonathonp Using Fedora 1 14th May 2007 08:59 PM
Installing SATA Driver from driver disk sandesh_sun2004 Installation, Upgrades and Live Media 0 17th June 2005 03:46 PM


Current GMT-time: 19:18 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Bocsa Travel Photos - Roseville - Panarukan Photos