Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #61  
Old 27th January 2006, 06:48 AM
mgdodge Offline
Registered User
 
Join Date: Jan 2006
Posts: 2
Urgent Help Needed!!!!

This topic has been around for a while...hopefully that means enough of you have resolved the problem that someone will be able to help me out.

I am running CentOS4, which is virtually identical to RedHat Enterprise 4 and Fedora 4. I have followed the instructions in this thread to the letter, and the most I can get is a black VNC screen with an "X" for a cursor. The cursor moves, but nothing ever comes up into the window.

Recently, I moved my server to a new IP, one without a router to act as a firewall. This server never had problems with VNC until I enabled the firewall on it...and poof. I have opened ports 5900 & 5901, UDP 177 and 138 (/var/log/messages had a line with "SPT=138 DPT=138" as per some of the troubleshooting on this forum), nothing helps. I disable the firewall and reboot...nothing.

The wierd thing is that I can log in using putty, type "vncserver" to start it that way, and I get it to work just great.

Any troubleshooting ideas would be most welcome. I am willing to post server logs and config files if it will help out at all.
Reply With Quote
  #62  
Old 27th January 2006, 09:26 AM
giulix Offline
"Fixed" by (vague) request
 
Join Date: Oct 2005
Location: GMT+ 1
Posts: 2,950
Excuse me, but I don't follow you... You mean that, before, you were able to connect to your box without starting vncserver in advance ?
Reply With Quote
  #63  
Old 27th January 2006, 09:44 AM
mgdodge Offline
Registered User
 
Join Date: Jan 2006
Posts: 2
Without manually starting it, yes. The method stated in this thread allows the server to listen on ports 5900 and 5901 for incoming connections, and when it detects one it displays the standard gnome login screen. I was able to do just that until yesterday, when I had to move my server and implement the firewall I described...which seems to have hosed something. I can connect if I start vnc manually, but I would like to have it automatically listening as before.
Reply With Quote
  #64  
Old 27th January 2006, 12:02 PM
giulix Offline
"Fixed" by (vague) request
 
Join Date: Oct 2005
Location: GMT+ 1
Posts: 2,950
Ah, ok...I had missed the first post, sorry.
Reply With Quote
  #65  
Old 27th January 2006, 01:05 PM
alphonsebrown Offline
Registered User
 
Join Date: Feb 2005
Location: Sofia, Bulgaria
Age: 31
Posts: 791
I still don't know how to setup the xvnc setup so that is starts the login form rather than gnome-session for example, can you help me out?
__________________
Windows doesn't just crash - it opens a dialog box and lets you press OK first. Powered by RedHat since I know my self ;) Fedora 12 #379190
Reply With Quote
  #66  
Old 5th February 2006, 04:33 AM
cottsay Offline
Registered User
 
Join Date: Feb 2006
Location: Minnesota, United States
Age: 24
Posts: 24
Alright, for me, I can get the VNC to start, but it doesn't start gdm - I just get a black screen with an X cursur, and when I boot, it sits at the startup screen, and my mouse freezes, when at that point it should be moving to the greeter. Anyone?

Scott K Logan
CottsayNet
logans@cottsay.net
Reply With Quote
  #67  
Old 5th February 2006, 04:41 AM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
See my sig link; I modded this how-to a little and it works fine for me.
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #68  
Old 5th February 2006, 04:58 AM
cottsay Offline
Registered User
 
Join Date: Feb 2006
Location: Minnesota, United States
Age: 24
Posts: 24
Alright, now it just puts up a colored background and a hourglass and then kills the connection, and on startup, I still get no greeter. It just locks up. I'm using FC4 btw...

Thanks,

Scott K Logan
CottsayNet
logans@cottsay.net
Reply With Quote
  #69  
Old 5th February 2006, 05:10 AM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Did you run gdmsetup and allowed TCP connections / enabled XDMCP? That could be the cause of killing X...
And, what resolution / connection speed are you using?
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #70  
Old 5th February 2006, 05:34 AM
cottsay Offline
Registered User
 
Join Date: Feb 2006
Location: Minnesota, United States
Age: 24
Posts: 24
yea, yea both 800 and 1024, and i'm on a 10/100 connection. I've had previous VNC's working - i'm just looking at the GDM approatch - just now I got my FC3 box to do it...sorta - it doesn't bring up the greeter at startup, and when I vnc to it, it brings my to the greeter and I can log in. Is there a way that I could make it so that I don't end the session when I log out of VNC or anything?

Thanks,

Scott K Logan
CottsayNet
logans@cottsay.net
Reply With Quote
  #71  
Old 5th February 2006, 04:33 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Hmmm....
Same happened to me. Eventually I got the gdm to display... How it did it is in that how to... :S I can't really help there
but as for the gdm at startup, I did this part of the how-to:
Code:
      edit /etc/X11/gdm/gdm.conf
      find the [servers] section
      Change
           0=Standard
      to
           #0=Standard
And this disables GDM at startup. So, to enable it, edit /etc/X11/gdm/gdm.conf, and change:
Code:
#0=Standard
to
0=Standard
Also, I'm sure you've done it -- but you'll need to add ports 5900 - 5901 (tcp) to your firewall in order for them to work -- That's another symptom of a connection dieing.

Hope it helps,
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)

Last edited by Firewing1; 5th February 2006 at 04:35 PM.
Reply With Quote
  #72  
Old 5th February 2006, 08:28 PM
cottsay Offline
Registered User
 
Join Date: Feb 2006
Location: Minnesota, United States
Age: 24
Posts: 24
I did find a way of doing what I wanted...

http://www.realvnc.com/products/free/4.1/x0.html

...basically incorperates VNC into X - very easy to do. It works exactly how I wanted it to.
Thanks for your help!
__________________
Scott K Logan
CottsayNet
logans@cottsay.net
Reply With Quote
  #73  
Old 6th March 2006, 02:04 PM
Airmister Offline
Registered User
 
Join Date: Mar 2006
Posts: 27
This is a great post. Thank you so much.

Can't wait to get home from work to try this out on my FC4!!
Reply With Quote
  #74  
Old 7th March 2006, 09:11 AM
alphonsebrown Offline
Registered User
 
Join Date: Feb 2005
Location: Sofia, Bulgaria
Age: 31
Posts: 791
The idea is to do it from your work for example
__________________
Windows doesn't just crash - it opens a dialog box and lets you press OK first. Powered by RedHat since I know my self ;) Fedora 12 #379190
Reply With Quote
  #75  
Old 7th March 2006, 09:41 AM
Airmister Offline
Registered User
 
Join Date: Mar 2006
Posts: 27
Hehe

I understood that. But first I had to set up the system. And secondly at work we have a very restrictive firewall and proxy, so I don't think I'll be able to run my linux box from there.

But it worked perfectly after a few tweaks and tries. I've been trying to do this kind of thing for a week now. Finally I can.

Thank you again to the starter of this tread and the rest of you guys who contributed.
Reply With Quote
Reply

Tags
gdm, vnc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Current GMT-time: 07:07 (Saturday, 26-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat