Fedora Linux Support Community & Resources Center
  #1  
Old 1st September 2007, 07:05 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 26
Posts: 404
Lenovo T61p: wireless, USB mouse, default runlevel, and HIDD issues

I installed F7 i386 on this laptop. I'm going to try X86_64 when I get a chance, but I'd like to fix the problems I'm having now and keep this install. I have a sound problem i posted here and a number of other issues.

wireless: I have a IPW3945 card, the drivers for which are installed (by default on fedora actually, i think). when I open the network configuration tool it lists the same device twice, wlan0 and wlan0.bak, and then there's eth0; all three are active. however, I only have a wired connection. The network connection applet doesn't show up in the gnome panel, and I have no idea how to select a wireless network to connect to. I know this can't be a hardware problem, because the driver is installed; also, on sabayon, it just started up and showed the available networks. I selected one and it worked.

USB mouse: my USB mouse will only work if it is connected at startup, and stays connected. if I unplug it and put it back in, it no longer works. do I have to add something to xorg.conf? currently there is only a section for the touchpad. what do I add? I would prefer it if the mouse will work on any USB port.

Default Runlevel: the current default runlevel of this computer is 3. That's what my smolt profile says, and upon booting up the computer I'm dropped into a bash shell, and I have to start gdm to log into gnome. my guess would be that this is because I had to do a text based install and then download the nvidia driver from livna before I could get x working. how do I change the default runlevel of fedora to 5?

HIDD: every time I boot, I get the message that HIDD failed to start. it looks like it is for bluetooth, and although I currently don't have any bluetooth device, I'll be getting a bluetooth phone at some point. how do I get HIDD to start properly?
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #2  
Old 1st September 2007, 09:06 PM
RobertoVanto Offline
Registered User
 
Join Date: Nov 2006
Location: Italy
Age: 29
Posts: 302
Quote:
Default Runlevel: the current default runlevel of this computer is 3. That's what my smolt profile says, and upon booting up the computer I'm dropped into a bash shell, and I have to start gdm to log into gnome. my guess would be that this is because I had to do a text based install and then download the nvidia driver from livna before I could get x working. how do I change the default runlevel of fedora to 5?
Open /etc/inittab and change the first line(that doesn't start with a #) to "id:5:initdefault:"

Quote:
HIDD: every time I boot, I get the message that HIDD failed to start. it looks like it is for bluetooth, and although I currently don't have any bluetooth device, I'll be getting a bluetooth phone at some point. how do I get HIDD to start properly?
http://fedoraforum.org/forum/showthread.php?t=165033

Also take a look here: http://www.ces.clemson.edu/linux/f7_setup.shtml
__________________
"Love, and do what thou wilt." St. Augustine of Hippo - http://robertovanto.blogspot.com
Reply With Quote
  #3  
Old 1st September 2007, 09:40 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 26
Posts: 404
Quote:
Originally Posted by RobertoVanto
Open /etc/inittab and change the first line(that doesn't start with a #) to "id:5:initdefault:"



http://fedoraforum.org/forum/showthread.php?t=165033

Also take a look here: http://www.ces.clemson.edu/linux/f7_setup.shtml
thanks, I'll try that, I didn't know where the config file for init's default runlevel was. and sorry I missed that thread, it has a sort of obvious title
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #4  
Old 2nd September 2007, 06:09 AM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 26
Posts: 404
Quote:
Originally Posted by slade17
wireless: I have a IPW3945 card, the drivers for which are installed (by default on fedora actually, i think). when I open the network configuration tool it lists the same device twice, wlan0 and wlan0.bak, and then there's eth0; all three are active. however, I only have a wired connection. The network connection applet doesn't show up in the gnome panel, and I have no idea how to select a wireless network to connect to. I know this can't be a hardware problem, because the driver is installed; also, on sabayon, it just started up and showed the available networks. I selected one and it worked.
>.< i figured this problem out and feel sort of stupid... I just had to start NetworkManager. I tried this before, but typed "networkmanager" into the terminal instead... stupid case sensitivity.

all that's left is the mouse issue.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #5  
Old 2nd September 2007, 06:50 AM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 26
Posts: 404
I spoke too soon.

changing the file /etc/inittab didn't solve my problem. the computer boots up to a blank screen, and I can't even get into a terminal through ctrl+alt+f2. I had to change the default runlevel back to 3.

I also get another failure at boot in the 64 bit fedora version (aside from this, they have identical problems):

Code:
enabling /etc/fstab swaps:  swapon:  cannot open /etc/fstab:  permission denied
why is this happening? as far as i know fstab has the correct file permissions...


I also just tried booting the computer up without the ethernet cable attached, and it said that determining the ip information for eth0 failed (which is expected) and then stalled at the line "determining IP information for wlan0" for about a minute. how do I keep this from happening? can I add a timeout to that detection?
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #6  
Old 2nd September 2007, 11:38 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 26
Posts: 404
any help regarding these issues? i'd like to be able to start in run level 5, and having to wait a minute or two to configure the IP addresses is a real pain. I'd also like to have my swap usable, I don't know why it can't read /etc/fstab

I also just got a random message when logged in as root:

Code:
[root@localhost ~]# 
Message from syslogd@ at Sun Sep  2 05:27:09 2007 ...
localhost kernel: Disabling IRQ #19
another issue: can I disable sidescrolling with the touchpad? whenever i hit the bottom of the touchpad to move the cursor off of the browser, it sidescrolls instead, and apparently that's interpreted as hitting the "back" button in my browser. I still want to be able to scroll up/down.

*edit* I think i solved the problem with my runlevel. I had a typo in xorg.conf. I probably would have caught that sooner, but i could log into gnome by typing "gdm" as root, but not by actually going into run level 5. does starting gdm in run level 3 reference another config file instead of xorg.conf?

I'm still trying to figure out the mouse, network, and swap issues though. the only reason i can think that it can't read fstab is that i edited it once as root in sabayon, but all the file permissions are still correct...

an issue which is probably related to my swap problem is that whenever I enter gnome, i get an AVC denial that says "SELinux prevented /bin/mount from mounting on the file or directory "fstab" (type "unlabeled_t")
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/

Last edited by slade17; 3rd September 2007 at 12:11 AM.
Reply With Quote
  #7  
Old 7th September 2007, 10:35 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 26
Posts: 404
my networking issues were just resolved by a firmware update in yum. my mouse just suddenly started working correctly too... fedora is the reverse of windows, things just start working and I don't know why

I'm still having problems with my swap, though. it does look like this has something to do with SElinux. it says I can allow it to mount any filesystem by setting the boolean "setsebool -P allow_mount_anyfile=1", but there has to be a way to do this without messing with SElinux settings; there's a reason its denying access.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
Reply

Tags
default, hidd, issues, lenovo, mouse, runlevel, t61p, usb, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth Mouse not seen on my Thinkpad T61p SlowBrute Hardware & Laptops 3 1st September 2008 05:17 PM
FC9 + Lenovo 3K N200, display and wireless issues lepht Hardware & Laptops 0 28th May 2008 07:36 PM
FC9 + Lenovo 3000 N200, display/wireless issues lepht Hardware & Laptops 0 27th May 2008 08:27 PM
wireless and/or mouse issues zammo Hardware & Laptops 1 18th July 2006 04:09 PM


Current GMT-time: 00:09 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Syosset Travel Photos - Pomerode - Takanosu Travel Photos