Fedora Linux Support Community & Resources Center
  #1  
Old 13th September 2007, 10:45 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
Fedora fails to boot... every other time?

this has happened to me 3-4 times so far.

I turn on my laptop, select fedora from the grub boot menu, and it starts to boot. it gets to the line "starting udev", then the screen goes blank (where its black, but still on).

i wait, then can't do anything but do a hard reset by holding the power switch. I try to start fedora again. it gets to the line "starting udev" and the screen turns off. then it turns on and shows the "nvidia" logo, and boots properly.

this didn't happen when i first installed fedora on this computer, it started happening a day or two ago, after i did (that i can remember) 3 things: set the SELinux autorelabel flag and relabeled the filesystems upon boot, installed a new kernel and nvidia driver, and compiled and installed alsa-driver.

my guess would be that it was the result of the new kernel/nvidia driver; I was just hoping someone would have some input.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #2  
Old 15th September 2007, 02:25 AM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
any ideas? this isn't a huge problem, it's just rather strange, annoying and cumbersome.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #3  
Old 15th September 2007, 05:28 AM
Dies Offline
Registered User
 
Join Date: Oct 2006
Posts: 4,753
Are you using any boot options?

I found that

pci=nommconf idle=poll

solved my issues with the Nvidia drivers, the 'idle=poll' is for dual-core processors.
Reply With Quote
  #4  
Old 15th September 2007, 04:47 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
Quote:
Originally Posted by Dies
Are you using any boot options?

I found that

pci=nommconf idle=poll

solved my issues with the Nvidia drivers, the 'idle=poll' is for dual-core processors.
what do those options actually do?

it looks like the problem isn't with the kernel/nvidia upgrade, because i booted into the old kernel and nvidia module and the exact same problem occurred.

the following also does not help:

booting another operating system first,
using "init 6" to shut down instead of the GUI
shutting down from the login screen

however, shutting the computer off by holding the power button at the login screen did solve the problem. it looks like the only thing that lets fedora boot is if it was shut off unexpectedly. there's something in it's shutdown process that's keeping it from booting again.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #5  
Old 15th September 2007, 07:57 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
I just booted up a restore partition I made a while ago (by copying it over to an external hdd with gparted) and this problem doesn't occur on that partition.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #6  
Old 15th September 2007, 08:06 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
I just set the SELinux /.autorelabel flag, and now fedora fails to boot completely. it looks like SELinux is the problem.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #7  
Old 15th September 2007, 11:17 PM
RJFUatHOME Offline
Registered User
 
Join Date: Aug 2007
Location: Fairfield, CA
Posts: 437
I thought this might help. It's some SELinux relabling advice from Dan Walsh I found in the fedora rss feeds. You might try relabling in permissive mode as he mentions in the third paragraph. Anyhow if it is SElinux trying some of these options may help.

"selinux=0 (Bad idea :^))
If you want to Disable SELinux entirely. You can boot the system with the SELINUX=0 kernel parameter. This will cause the kernel to not load any of the SELinux infrastructure. The init scripts will notice that you booted with SELINUX=0 and will touch /.autorelabel themselves. This will cause the machine to automatically relabel the next time you boot with SELINUX enabled. We do this because anytime you are booted with SELNUX=0 files will not get a label. So the next time the system boots the SELinux would report these files as file_t and almost no domains can interfact with a file_t (Unlabeled file). Files like /etc/resolv.conf get recreated at boot time and probably would get this label and the next time SELinux booted, all heck would break loose.

enforcing=0
Setting this parameter will cause the machine to boot in permissive mode. If your machine will not boot in enforcing mode, this can allow you to boot it and figure out what is wrong. Sometimes you file system can get so messed up that this parameter is your only option. The nice thing about this option, the system continues to create the labels correctly. The AVC messages that are created via this command can be different then in enforcing mode. There are two differences in enforcing mode, every access denial is reported, in permissive only the first denial is reported. However in Enforcing mode you might get a denial on reading a directory and the app will stop. In permissive mode you would get the same avc message but then you would get an avc for each denial when the app continues reading files in the directory.

autorelabel=1
This parameter will force the system to relabel. It does the same thing as "touch /.autorelabe; reboot". Sometimes, if the machines labeling is really bad, you will need to boot in permissive mode in order for the autorelabel to succeed. An example of this is switching from strict to targeted policy. In strict policy shared libraries are labeled as shlib_t while ordinary files in /lib directories are labeled lib_t. strict policy only allows confined apps to execute shlib_t. In targeted policy shlib_t and lib_t are aliases. (Having these files labeled differently is of little security importance and leads to labeling problems in my opinion). So every file in /lib directories gets the label lib_t.
When you boot a machine that is labeled for targeted with strict policy the confined apps try to execute lib_t labeled shared libraries so and they are denied. /sbin/init tries this and blows up. So booting in permissive mode allows the system to relabel the shared libraries as shlib_t and then the next boot can be done in enforcing."
Reply With Quote
  #8  
Old 18th September 2007, 06:39 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
I just confirmed that this is an selinux problem by restoring the partition and testing one thing at a time. any change to selinux (setting the autorelabel flag, changing it to permissive mode, etc.) messes up my system. I got the originally posted problem a few times, and just got a kernel panic. if I don't change selinux, however, it won't let me mount my swap partition. does anyone know how to resolve this?
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #9  
Old 18th September 2007, 07:41 PM
RJFUatHOME Offline
Registered User
 
Join Date: Aug 2007
Location: Fairfield, CA
Posts: 437
There were updates to selinux in the package updates this morning.

I would update the selinux policies from the updater and see if that helps. If not, I don't know if it'll help but I know what I would try next: I would try adding enforcing=0 autorelabel=1 temporarily via grub at boot time and see if a relabel with the new policies from updates doesn't fix the problem. This should force a relabel in permissive mode.

As a last resort I would boot with selinux=0 as an added grub parameter and trying a relabel in permissive mode after a successful boot in disabled mode.

Hope it helps...
Reply With Quote
  #10  
Old 18th September 2007, 10:38 PM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
Quote:
Originally Posted by RJFUatHOME
There were updates to selinux in the package updates this morning.

I would update the selinux policies from the updater and see if that helps. If not, I don't know if it'll help but I know what I would try next: I would try adding enforcing=0 autorelabel=1 temporarily via grub at boot time and see if a relabel with the new policies from updates doesn't fix the problem. This should force a relabel in permissive mode.

As a last resort I would boot with selinux=0 as an added grub parameter and trying a relabel in permissive mode after a successful boot in disabled mode.

Hope it helps...
the selinux updates didn't help and touching selinux at all either creates the original problem, or keeps the system from booting at all.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #11  
Old 19th September 2007, 02:38 AM
RJFUatHOME Offline
Registered User
 
Join Date: Aug 2007
Location: Fairfield, CA
Posts: 437
The only time I saw the same behavior was with FC6 on a Dell laptop with an nvidia chipset in it using the livna drivers that were available at that point in time. It did the exact same thing booting every other time. You always knew when it was going to happen because the nvidia logo wouldn't show. You could try using the NV driver as a test and see if the problem mysteriously disappears, at least you'd be able to isolate it to the driver. Did it happen only recently, like with a kernel and nvidia kmod update? Perhaps you could revert back to an older setup?

This issue happened on my partner's laptop and became an end game scenario for fedora with him. There's nothing like flaky video drivers to ruin any computing experience!
Reply With Quote
  #12  
Old 19th September 2007, 02:49 AM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
Quote:
Originally Posted by RJFUatHOME
The only time I saw the same behavior was with FC6 on a Dell laptop with an nvidia chipset in it using the livna drivers that were available at that point in time. It did the exact same thing booting every other time. You always knew when it was going to happen because the nvidia logo wouldn't show. You could try using the NV driver as a test and see if the problem mysteriously disappears, at least you'd be able to isolate it to the driver. Did it happen only recently, like with a kernel and nvidia kmod update? Perhaps you could revert back to an older setup?

This issue happened on my partner's laptop and became an end game scenario for fedora with him. There's nothing like flaky video drivers to ruin any computing experience!
yeah, its the nvidia driver. its the exact same problem you describe, and its a new laptop with new nvidia card. it happens only when i boot into run level 5, if i boot into 3 there's no problem at all. the confusing thing is that it occasionally works fine and boots properly.

and the nv driver doesn't work... my card (quadro FX570M) is too new to be supported, i guess. I have to do a text based install and then install the driver through livna from the command line. I'm having other issues with the card too, i think it's the reason the display won't dim when the computer is running on the battery.

i'm not sure if I should file a bug report, because this is more of an nvidia problem than a linux problem.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #13  
Old 17th October 2007, 02:28 AM
Dlwood Offline
Registered User
 
Join Date: Sep 2007
Location: Texas
Posts: 23
Ok I have a HP dv6000 that has the same boot problem. on second boot I get the nvidia logo and the login screen. Has anyone fixed the problem? What is the difference in run level 5 and 3 and how do you switch between them? As you can tell I am new to this and still trying to get up to speed.

Thanks for the help
Reply With Quote
  #14  
Old 17th October 2007, 02:47 AM
slade17 Offline
Registered User
 
Join Date: Aug 2006
Location: Sudbury, MA, USA
Age: 25
Posts: 404
Quote:
Originally Posted by Dlwood
Ok I have a HP dv6000 that has the same boot problem. on second boot I get the nvidia logo and the login screen. Has anyone fixed the problem? What is the difference in run level 5 and 3 and how do you switch between them? As you can tell I am new to this and still trying to get up to speed.

Thanks for the help
there was recently an update to the nvidia drivers, i havent rebooted since updating but you should look at it.

use init to switch between the runlevels. init 3 or init 5 from a terminal. if you're already in init 5, you probably don't want to change anything. to change the default runlevel, you have to edit a config file.
__________________
http://www.xkcd.com/149/
http://www.xkcd.com/293/
Reply With Quote
  #15  
Old 18th October 2007, 01:23 AM
FriedChips Offline
Registered User
 
Join Date: Jul 2007
Location: Indiana USA
Posts: 1,715
try disabling rhgb.
su -
gedit /etc/grub.conf

remove rhgb from the kernel line.
__________________
The answer to all of lifes questions are buried somewhere in the Google search engine.

Code:
[Stephen@localhost ~]$ whatis this?
this?: nothing appropriate
Reply With Quote
Reply

Tags
boot, fails, fedora, time

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11 Boot Time. chrispche Using Fedora 7 26th September 2009 11:23 PM
Fedora 8 dual boot with Windows XP [Pavilion dv6137tx] Time gets reset every time! maverick280857 Hardware & Laptops 5 23rd March 2008 11:48 AM
Fedora 7, ipw3945 fails to connect "first" time beldish Servers & Networking 11 10th March 2008 11:43 PM
ntpd fails at boot time caporal Using Fedora 1 18th February 2005 04:13 AM
time fails to update on fedora 3 (FC3) albakeronline Hardware & Laptops 5 14th February 2005 03:23 AM


Current GMT-time: 04:07 (Friday, 25-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat