Fedora Linux Support Community & Resources Center
  #1  
Old 11th November 2007, 02:51 AM
erinspice Offline
Registered User
 
Join Date: Feb 2007
Location: Huntsville, AL
Age: 32
Posts: 41
apache segfaulting on start

I'm trying to set up a devel environment on my FC7 laptop. I installed apache using yum, but when I tried to start it, it segfaults. Can someone help me track down why this may be happening and how I can fix it?
Reply With Quote
  #2  
Old 11th November 2007, 04:04 AM
LLS
Guest
 
Posts: n/a
I would start with this to see if your config file is good and post the error
Code:
/usr/sbin/apachectl configtest
and see if there is anything here
Code:
sudo cat /var/log/httpd/error_log
.
Reply With Quote
  #3  
Old 11th November 2007, 04:57 AM
erinspice Offline
Registered User
 
Join Date: Feb 2007
Location: Huntsville, AL
Age: 32
Posts: 41
Code:
[root@localhost ~]# /usr/sbin/apachectl configtest
/usr/sbin/apachectl: line 91: 11840 Segmentation fault      $HTTPD $OPTIONS -t
/usr/sbin/apachectl: line 91:
Code:
function testconfig() {
# httpd is denied terminal access in SELinux, so run in the
# current context to get stdout from $HTTPD -t.
if test -x /usr/sbin/selinuxenabled && /usr/sbin/selinuxenabled; then
  runcon -- `id -Z` $HTTPD $OPTIONS -t
else
  $HTTPD $OPTIONS -t
fi
ERROR=$?
}
Error log is empty. The $OPTIONS variable is empty.

Last edited by erinspice; 11th November 2007 at 03:23 PM.
Reply With Quote
  #4  
Old 11th November 2007, 03:23 PM
erinspice Offline
Registered User
 
Join Date: Feb 2007
Location: Huntsville, AL
Age: 32
Posts: 41
I should probably also add that SELinux is disabled.
Reply With Quote
  #5  
Old 11th November 2007, 03:34 PM
LLS
Guest
 
Posts: n/a
I could not find anything like that in my httpd/conf. Was SELINUX enabled when you installed apache? Have you tried removing and then reinstalling after backing up /var/www/html and /var/www/cgi-bin. Or just try to comment out that section.
Reply With Quote
  #6  
Old 11th November 2007, 06:11 PM
erinspice Offline
Registered User
 
Join Date: Feb 2007
Location: Huntsville, AL
Age: 32
Posts: 41
That part I quoted wasn't from httpd.conf, it was from the apachectl script. SELinux has never been enabled on my machine.
Reply With Quote
  #7  
Old 11th November 2007, 06:52 PM
LLS
Guest
 
Posts: n/a
The config test reads httpd.conf and checks each section. Go to the one it reports
Quote:
line 91: 11840 Segmentation fault $HTTPD $OPTIONS -t
and comment it out with a # or correct the error and then try a restart.
Reply With Quote
  #8  
Old 11th November 2007, 07:42 PM
erinspice Offline
Registered User
 
Join Date: Feb 2007
Location: Huntsville, AL
Age: 32
Posts: 41
apachectl exits cleanly with those lines commented out. I believe it's still using the default httpd.conf anyway, as I haven't edited anything yet. Thanks again for your continued help. I really have to figure this out, as I have a contract starting soon and this is my primary development environment!
Reply With Quote
  #9  
Old 11th November 2007, 08:29 PM
LLS
Guest
 
Posts: n/a
Quote:
apachectl exits cleanly with those lines commented out.
Do you mean apache would not start even after you commented out the offending line. Maybe someone with more experience will have an idea for you. With yum, a reinstall of apache is so easy that I would also try that after backing up any important files. What is your goal as far as development environ goes? Good luck.

After reading your previous post on the same subject, I might suggest that an upgrade to Fedora 8 and disabling any conflicting repos you might have in yum.repos.d and the use of protectbase post #9 http://forums.fedoraforum.org/forum/...tectbase+leigh in your repos might repair any problems you might have in your system allowing you to keep your data. Then you should be able to construct your LAMP setup once your system is fixed.

Last edited by LLS; 12th November 2007 at 02:49 AM.
Reply With Quote
  #10  
Old 11th November 2007, 11:09 PM
erinspice Offline
Registered User
 
Join Date: Feb 2007
Location: Huntsville, AL
Age: 32
Posts: 41
apachectl runs just fine with that line commented, but apache still will not start. The segfault is in the /usr/sbin/httpd executable, which is called by /etc/init.d/httpd, but isn't called anywhere in apachectl. I have tried erasing with yum and reinstalling with yum several times with no results, which makes me think that this is an environmental thing -- maybe a corrupt or outdated library or something like that. Thanks for your help. I really hope someone else has some insight!

My goal is just to have a LAMP server so that I can do PHP and Perl development.

Last edited by erinspice; 11th November 2007 at 11:34 PM.
Reply With Quote
Reply

Tags
apache, segfaulting, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache will not start thign Using Fedora 1 30th October 2007 04:45 AM
can't start apache on FC5 pompadir Servers & Networking 3 31st May 2007 03:52 AM
FC5: Apache won't start CatharsisCarth Servers & Networking 15 1st June 2006 03:17 AM
Apache doesn't always start RichInToronto Servers & Networking 0 16th November 2005 04:54 PM


Current GMT-time: 16:30 (Thursday, 02-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat