Fedora Linux Support Community & Resources Center
  #1  
Old 4th February 2008, 03:47 AM
lawson Offline
Registered User
 
Join Date: Feb 2008
Posts: 13
Intel ICH8 Family HD Audio Controller no sound

Hi,
I have an Intel Corporation 82801H (ICH8 Family) HD Audio Controller sound card with Fedora 8 and have been unable to get any sound out of it. I've searched what seems like countless forums to no avail, and I've tried installing the development versions (1.0.16rc2) of the alsa drivers, with no success. So I tried Ubuntu 7.10, and voila! - instant success, even though I have only the 1.0.14 version installed. I guess barring unexpected miracles I'll be sticking with Ubuntu for now, but I really am perplexed as to how this could be. Don't Fedora and Ubuntu both use ALSA, and hence, are using the same drivers? Why should it work with one and not the other? Might this be related to this PulseAudio business? Any insights would be appreciated.

Last edited by lawson; 4th February 2008 at 03:47 AM. Reason: typos
Reply With Quote
  #2  
Old 4th February 2008, 04:00 AM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
It could be related to pulseaudio, however (if Fedora's still installed) I would run system-config-soundcard and make sure you're set to analog output... Setting digital results in no sound, a problem that had me going crazy for a day or two until I figured it out

If you want to check that the problem isn't PulseAudio, you could run it from the terminal:
Code:
pulseaudio -k
pulseaudio
That will kill the existing daemon and run it in the terminal. If you see any errors then that could be why there is no sound. If all is well, hit <ctrl+z> and type:
Code:
bg
to put the daemon in the background.
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)

Last edited by Firewing1; 11th February 2008 at 08:09 PM. Reason: typo s-c-settings --> s-c-soundcard
Reply With Quote
  #3  
Old 4th February 2008, 04:39 AM
SuperNu Offline
Registered User
 
Join Date: Mar 2004
Posts: 617
I have an Intel ICH8 based motherboard and use onboard sound with F8 and have no problems. Make sure that you have the module snd_hda_intel loaded (verify by running /sbin/lsmod to list all loaded kernel modules). You can also run system-config-soundcard to play a test sound to see if everything is working.

--SN
Reply With Quote
  #4  
Old 10th February 2008, 03:44 AM
lawson Offline
Registered User
 
Join Date: Feb 2008
Posts: 13
Hi, thanks for the advice. I had in fact uninstalled Fedora, but I had time today to reinstall it, so I figured I'd give this another go. Anyway. the snd_hda_intel module is loaded, so that's apparently not the problem. Regarding firewing's post, system-config-settings does not appear to exist on my machine. Did you mean system-config-soundcard instead? If so, there's not an option for analog vs. digital per se, though under "Device Settings" the PCM Device is listed as STAC92xx Analog - I dunno if that's relevant. As for pulseaudio, I apparently did not have a daemon running in the first place, and

pulseaudio -k

returned the following error message:
E: main.c: Failed to kill daemon.

When I tried restarting it as normal user, I got:
W: polkit.c: Failed to show grant dialog: Unable to lookup exe for caller
W: polkit.c: PolicyKit responded with 'auth_admin_keep_always'
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
E: main.c: Failed to create '/tmp/pulse-djones': Operation not permitted

So I figured I'd try it as root. This produced the following:
pulseaudio --system
W: main.c: Warning: home directory of user 'pulse' is not '/var/run/pulse', ignoring.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM front:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround40:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround41:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround50:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround51:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_284b_alsa_playback_ 0"): initialization failed.
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM front:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround40:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround41:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround50:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround51:0
ALSA lib conf.c:3949:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load module "module-alsa-source" (argument: "device_id=0 source_name=alsa_input.pci_8086_284b_alsa_capture_ 0"): initialization failed.
No protocol specified
E: x11wrap.c: XOpenDisplay() failed
E: module.c: Failed to load module "module-x11-publish" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.

This is a very nice collection of errors, and certainly seems to indicate that something is going wrong. What exactly that something is is perhaps a bit beyond me. Any ideas?
Reply With Quote
  #5  
Old 10th February 2008, 10:59 PM
jesse_kahtava Offline
Registered User
 
Join Date: Feb 2008
Age: 29
Posts: 24
That looks like a bunch of permission problems, though I'm not sure why you'd have problems running as root.

Try just running alsamixer in a terminal:
Code:
alsamixer -D hw:0
If that works look for an analog/digital switch (press M to mute/unmute a column). I, too, have come across the analog/digital problem before.

If alsamixer fails maybe check sound device permissions:
Code:
ls -l /dev/snd/
If there are no sound devices, the problem thickens...
Reply With Quote
  #6  
Old 11th February 2008, 04:36 AM
lawson Offline
Registered User
 
Join Date: Feb 2008
Posts: 13
I tried opening alsamixer as you suggested, but couldn't find anything like an analog/digital switch. I did make everything was unmuted, though. I ran ls -l /dev/snd/, and got the following as output:
Code:
ls -l /dev/snd/
total 0
crw-rw----+ 1 root root 116, 8 2008-02-10 23:11 controlC0
crw-rw----+ 1 root root 116, 7 2008-02-10 23:11 hwC0D0
crw-rw----+ 1 root root 116, 6 2008-02-10 23:11 hwC0D1
crw-rw----+ 1 root root 116, 5 2008-02-10 23:11 pcmC0D0c
crw-rw----+ 1 root root 116, 4 2008-02-10 23:11 pcmC0D0p
crw-rw----+ 1 root root 116, 3 2008-02-10 23:11 seq
crw-rw----+ 1 root root 116, 2 2008-02-10 23:11 timer
So apparently the permissions are set to root for all of these, which is probably (I think?) what I'd expect.
Reply With Quote
  #7  
Old 11th February 2008, 06:16 AM
jesse_kahtava Offline
Registered User
 
Join Date: Feb 2008
Age: 29
Posts: 24
Yeh, that all looks good. The only difference is that my permissions are crw-rw-rw-, though that shouldn't matter if you're logged in as root. I'm not really sure what direction to go from here...
Could you post the results of the following command?
Code:
amixer -D hw:0 scontrols
Reply With Quote
  #8  
Old 11th February 2008, 08:09 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Sorry, I did mean system-config-soundcard... (edited my original post)

As for the pulseaudio problems, I'm pretty sure that's a problem with ConsoleKit (we see this for the nvidia drivers too). I may be wrong, but what I suspect is after updating the PulseAudio packages, the /dev/ permissions are reset and that's why hw:0 doesn't exist: It does, just your user has no permissions to access it. Try running this as your regular user:
Code:
su -c "chown `whoami` /dev/snd /dev/dsp -R"
pulseaudio -k;pulseaudio
That will reset the proper permissions and restart pulseaudio. You could also reboot which would reset the permissions as well.
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #9  
Old 11th February 2008, 11:43 PM
lawson Offline
Registered User
 
Join Date: Feb 2008
Posts: 13
OK, I tried amixer -D hw:0 scontrols, and this is what I got:
Code:
 amixer -D hw:0 scontrols
Simple mixer control 'PCM',0
Simple mixer control 'Front',0
Simple mixer control 'Surround',0
Simple mixer control 'Center',0
Simple mixer control 'LFE',0
Simple mixer control 'Line In as Output',0
Simple mixer control 'Mic as Output',0
Simple mixer control 'Capture',0
Simple mixer control 'Capture',1
Simple mixer control 'Capture',2
Simple mixer control 'Analog Loopback',0
Simple mixer control 'Digital Input Source',0
Simple mixer control 'Input Source',0
Simple mixer control 'Input Source',1
Simple mixer control 'Input Source',2
Simple mixer control 'Mux',0
Simple mixer control 'Mux',1
Simple mixer control 'Mux',2
Simple mixer control 'Swap Center/LFE',0
That looks normal to me, for what it's worth. I also tried changing the permissions as firewing suggested. Here's what I got:
Code:
su -c "chown `whoami` /dev/snd /dev/dsp -R"
pulseaudio -k
W: polkit.c: Failed to show grant dialog: Unable to lookup exe for caller
W: polkit.c: PolicyKit responded with 'auth_admin_keep_always'
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: pid.c: Failed to open PID file '/tmp/pulse-djones/pid': Permission denied
E: main.c: Failed to kill daemon.
This didn't look promising, but I gamely soldiered on:
Code:
pulseaudio
W: polkit.c: Failed to show grant dialog: Unable to lookup exe for caller
W: polkit.c: PolicyKit responded with 'auth_admin_keep_always'
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
E: main.c: Failed to create '/tmp/pulse-djones': Operation not permitted
Also, FWIW, I tried checking the codecs in use while booted in ubuntu, and they were the same as while booted in Fedora, namely SigmaTel STAC9228 and Conexant ID 2c06.
Reply With Quote
  #10  
Old 13th February 2008, 05:48 PM
kantmakm Offline
Registered User
 
Join Date: Feb 2008
Posts: 9
Same Issue

I Am having the same issue with F8 on a lenovo Y410 with the 82801H ICH8 HD Audio Controller. I have the correct driver installed - snd-hda-intel and have specced in my modprobe.conf file:

Code:
alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel index=0 model=fujitsu

I am pretty sure the alsa drivers are version 1.0.15, which purportedly support the card. My my keyboard volume controls do bring up the onscreen volume control, but I cannot get any sound through the speakers when running the test sound.

I have my PCM device set to ALC262 Analog in my audio configuration.

When I run pulseaudio from the command line I get the following message:
Code:
E: module-alsa-sink.c:  Error opening PCM device hw:0  No such file or directory
E: module.c:  Failed to load module "module-alsa-sink:  (argument:  "device=hw:0 sink_name=alsa_output.pci_8086_284b_alsa_playback_0"): initialation failed.
The contents of my /dev/snd/ directory are much the same as lawson with a few addtional entries.

I am logged in as root, so permissions should not be an issue.
Reply With Quote
  #11  
Old 14th February 2008, 09:52 AM
escapeflowne Offline
Registered User
 
Join Date: Aug 2007
Posts: 55
i have an acer aspire 4720 laptop and it has intel ich8 sound controller as i can remember. when i first installed ubuntu and f8 the keyboard control showed the volume bar but there was no physical sound.. i could hear no sound when doing sound testing.after searching through ubuntu wiki i replaced the line "options snd-hda-intel index=0" with "options snd-hda-intel model=acer", rebooted and voila! clear sound through lappy speakers.

may be you should try "options snd-hda-intel model=fuzitsu" instead of "options snd-hda-intel index=0 model=fujitsu"
Reply With Quote
  #12  
Old 14th February 2008, 07:47 PM
kantmakm Offline
Registered User
 
Join Date: Feb 2008
Posts: 9
The soundcard works! Kind of

So the update is that with the config that I had listed above, I actually can hear the test sounds through the speakers now.

Using the System > Preferences > Hardware > Sound preferences panel and try to test I get sound using the autodetect only if i kill the pulseaudio process. I also get sound using the Autodetct and OSS settings. If I try Alsa, Pulseaudio, or ALC262 Analog I get the following error:
gconfaudiosink: Internal GStreamer error state change failed.

Also, no headphone sound at all.

Better than nothing...
Reply With Quote
  #13  
Old 15th February 2008, 03:06 AM
lawson Offline
Registered User
 
Join Date: Feb 2008
Posts: 13
I've tried several variants on the "model=" idea, but none seem to have worked. I also checked my ubuntu modprobe configuration file and there was no model specified. So unfortunately, I'm not so sure that's the problem for me. The other thing I tried was simply copying the file "alsa-base" from my modprobe.d directory in the ubuntu partition into modprobe.d in the fedora partition. Again, no luck.

I'm starting to get the sense that this isn't a problem with the drivers. The alsa drivers are the alsa drivers right? It doesn't make sense that the same drivers would work perfectly fine in one distro but not in another. The only difference is that ubuntu is running version 1.0.14 and fedora is running 1.0.15. It's not exactly unheard of for a new version to cause something to break, but I don't think it's terribly likely, either. Then again, maybe that is the problem, for all I know.

Some have suggested that this may be a problem with permissions, which seem like a sensible alternative explanation. But if that's the case, shouldn't logging in as root eliminate any permission problems? As far as I know, it should, but maybe I'm overlooking something...?
Reply With Quote
  #14  
Old 15th February 2008, 04:52 AM
kantmakm Offline
Registered User
 
Join Date: Feb 2008
Posts: 9
So, once I had sound working I kicked off updates. Unfortunately I had been looking for some apps off of the development repository prior to doing that and my updates grabbed all the fc9 alpha release stuff and completely disabled my machine.

So, I reinstalled from f8 dvd. no sound. added model=fujitsu to the end of my modprobe.conf file, rebooted and had sound - literally that simple after jacking around w/ all the alsa libs for days before and doing model= in both f8 and ubuntu.

there are still probs w/ alsa mixer, etc., but at least there's sound and that's enough for me to move on w/ ditching vista as a primary OS
Reply With Quote
  #15  
Old 15th February 2008, 05:37 AM
escapeflowne Offline
Registered User
 
Join Date: Aug 2007
Posts: 55
Quote:
Originally Posted by lawson
The other thing I tried was simply copying the file "alsa-base" from my modprobe.d directory in the ubuntu partition into modprobe.d in the fedora partition. Again, no luck.
AFAIK, there is no alsa-base in fedora in /etc/modprobe.d folder. is there ?

Quote:
Originally Posted by lawson
I'm starting to get the sense that this isn't a problem with the drivers. The alsa drivers are the alsa drivers right? It doesn't make sense that the same drivers would work perfectly fine in one distro but not in another. The only difference is that ubuntu is running version 1.0.14 and fedora is running 1.0.15. It's not exactly unheard of for a new version to cause something to break, but I don't think it's terribly likely, either. Then again, maybe that is the problem, for all I know.
what do you get when you simply run alsamixer as root ? have you tried removing alsa-plugins-pulseaudio ?
Reply With Quote
Reply

Tags
audio, controller, family, ich8, intel, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SOUND CARD Intel Corporation 82801H (ICH8 Family) HD Audio Cont Coreyjames25 Hardware & Laptops 14 14th January 2009 09:16 AM
sound disappeared, FC8, Intel 82801H (ICH8 Family) maidantal Hardware & Laptops 1 6th September 2008 10:37 AM
Using F8, no sound with Intel (ICH8 Family) sound card garbagio7 Using Fedora 3 1st April 2008 07:58 PM
Modem Si3054 on 82801H ICH8 HD Audio Controller sound card. Not work ustas Hardware & Laptops 1 22nd February 2008 07:22 AM
problem with sound; 2 computers, intel HDA ICH8, and recording streaming audio slade17 Hardware & Laptops 4 4th September 2007 04:34 AM


Current GMT-time: 11:18 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Mocajuba Photos on Instagram - Siping Instagram Photos - Vohipaho