Fedora Linux Support Community & Resources Center
  #1  
Old 28th February 2008, 07:31 PM
Bezique Offline
Registered User
 
Join Date: Feb 2008
Posts: 11
fc6 cannot set up direct rendering

Hi All,
I've attempted not to bother you all, and so have toiled for some time through the forums, but I am still suffering some software problems.
I have followed Leigh's instructions here:here

I am not certian though that they are applicable to fc6. I know it's a little dated now, but workwise I am not allowed to update.

My video card is
$ /sbin/lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M24 [Radeon Mobility X600]

and my ultimate goal is to be able to enable display-effects, which currently I cannot. I understand that first I must enable direct rendering. I'm not up to speed on graphics cards. Is mine too dated for display-effects?

Having Followed Leigh's instructions my terminal's output differs from his at this stage:

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)



Is anybody able to assist me? Do I need to provide you with further information?
All the best,
Bezique
Reply With Quote
  #2  
Old 28th February 2008, 07:53 PM
leigh123linux
Guest
 
Posts: n/a
Post

Code:
rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|grep kernel|sort
Code:
uname -r

Code:
rpm -qa |grep fglrx

and


Code:
cat /etc/X11/xorg.conf
Reply With Quote
  #3  
Old 28th February 2008, 08:02 PM
Bezique Offline
Registered User
 
Join Date: Feb 2008
Posts: 11
Talking

The info you requested is below. I thought I should add one detail, in case it affected my later attempts at installation. Initially I followed your fc8 instructions, and only later did I follow the fc6 ones. I am unsure if that would create a conflict or how to undo the initial mistake.

Thanks for your time
Bezique

Quote:
# rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|grep kernel|sort
kernel-2.6.22.14-72.fc6.i686
kernel-2.6.22.9-61.fc6.i686
kernel-devel-2.6.22.14-72.fc6.i686
kernel-devel-2.6.22.9-61.fc6.i686
kernel-headers-2.6.22.14-72.fc6.i386
Quote:
# uname -r
2.6.22.14-72.fc6
Quote:
# rpm -qa |grep fglrx
kmod-fglrx-8.39.4-2.2.6.22.14_72.fc6
xorg-x11-drv-fglrx-8.39.4-2.lvn6
I have attached the xorg.conf in a file as it otherwise left my post too long to submit.
Kind Regards,
Attached Files
File Type: txt beique_xconfig.txt (11.8 KB, 121 views)
Reply With Quote
  #4  
Old 28th February 2008, 08:29 PM
leigh123linux
Guest
 
Posts: n/a
Back up your old xorg.conf
Code:
su
cp /etc/X11/xorg.conf  /etc/X11/xorg.conf.old

Then replace it with this one ( I have left the monitor section clear as you had commented out all modes )

Code:
su
gedit /etc/X11/xorg.conf


Code:
# Xorg configuration created by livna-config-display

Section "ServerLayout"
        Identifier     "Server Layout"
        Screen         "Screen0" 0 0
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/X11/fonts/local/"
        FontPath     "/usr/share/X11/fonts/misc/"
        FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath     "/usr/share/X11/fonts/Type1/"
        FontPath     "/usr/share/X11/fonts/75dpi/"
        FontPath     "/usr/share/X11/fonts/100dpi/"
EndSection

Section "Module"
        Load  "type1"
        Load  "freetype"
        Load  "glx"
        Load  "dri"
        Load  "extmod"
EndSection

Section "ServerFlags"
        Option      "AIGLX" "off"
EndSection

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "kbd"
        Option      "AutoRepeat" "500 30"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "gb"
EndSection

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "mouse"
        Option      "Protocol" "GlidePointPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "Emulate3Buttons"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        Option      "dpms"
EndSection


Section "Device"
        Identifier  "ATI Graphics Adapter"
        Driver      "fglrx"
        Option      "no_dri" "no"
        Option      "VideoOverlay" "on"
        Option      "OpenGLOverlay" "off"
        Option      "UseFastTLS" "0"
        Option      "BlockSignalsOnLock" "on"
        Option      "UseInternalAGPGART" "no"
        Option      "ForceGenericCPU" "off"
        Option      "KernelModuleParm" "locked-userpages=0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "ATI Graphics Adapter"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x800" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "DRI"
        Mode         0666
EndSection

Section "Extensions"
        Option      "Composite" "Disable"
EndSection



Restart X
Reply With Quote
  #5  
Old 28th February 2008, 09:12 PM
Bezique Offline
Registered User
 
Join Date: Feb 2008
Posts: 11
Hi agian, leigh. Thanks for the effort, I am afraid I still receive the same message:
Quote:
$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
I have noticed that now desktop-effects is different:
I used to be able to load the GUI to request desktop effects, but be told they could not be enabled. Now as I try and open the GUI before reaching the effects option I am told:
"The Compsite extension is not available"

Do you have any further suggestions?
Regards,
Bezique
Reply With Quote
  #6  
Old 28th February 2008, 10:57 PM
leigh123linux
Guest
 
Posts: n/a
Can you post


Code:
su -
lsmod |grep fglrx
Code:
su -
ldconfig -v |grep fglrx
Code:
su -
ldconfig -v |grep libGL
Code:
cat /var/log//Xorg.0.log |grep EE

Code:
cat /var/log//Xorg.0.log |grep WW

What state is selinux set to ? ( i.e enforcing , permissive or disabled )

Last edited by leigh123linux; 28th February 2008 at 10:59 PM.
Reply With Quote
  #7  
Old 28th February 2008, 11:13 PM
Bezique Offline
Registered User
 
Join Date: Feb 2008
Posts: 11
Quote:
# lsmod |grep fglrx
fglrx 697844 12
Quote:
# ldconfig -v |grep fglrx
/usr/lib/fglrx:
libfglrx_dm.so.1.0 -> libfglrx_dm.so.1.0
libfglrx_tvout.so.1 -> libfglrx_tvout.so.1.0
libfglrx_gamma.so.1 -> libfglrx_gamma.so.1.0
libfglrx_pp.so.1.0 -> libfglrx_pp.so.1.0
Quote:
# ldconfig -v |grep libGL
libGL.so.1 -> libGL.so.1.2
libGLU.so.1 -> libGLU.so.1.3.060501
libGL.so.1.2 -> libGL.so.1
Quote:
# cat /var/log//Xorg.0.log |grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
Quote:
# cat /var/log//Xorg.0.log |grep WW
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/X11/fonts/local/" does not exist.
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Only one display is connnected,so single mode is enabled
I'm currently set to permissive mode.
I'm sorry if my case is causing some difficulties. Initially it was maintained in what is starting to appear to be a strange fashion by the IT man at work. Nower days I'm more confident with Linux, but I can't seem to fully get to grips with how he originally configured the system.
Thanks,
Bezique
Reply With Quote
  #8  
Old 28th February 2008, 11:27 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Initially it was maintained in what is starting to appear to be a strange fashion by the IT man at work.

Did you install the livna fglrx driver ? , what driver was used before ?


can you post

Code:
su
updatedb
locate libGL
locate fglrx
and

Code:
cd /usr/lib
ls -l |grep libGL
Reply With Quote
  #9  
Old 29th February 2008, 12:18 AM
Bezique Offline
Registered User
 
Join Date: Feb 2008
Posts: 11
livna I installed as per your instructions on your Howto for fglrx page. As I stated earlier I first made the mistake of installing the fc8 version and only later followed the fc6 instructions. Despite that I can currnetly run the livna display configuration application. Livna was somehow set to 'Disable All (disables both Xgl and AILGLX), this must happened by accident as if I understand correctly it should be on AIGLX. If I attempt to select a manual configuration I am currently not allowed to chose 'Start Xgl with GDM' (or the similar KDE option). I have returned to AIGLX mode and restarted. Regarding desktop-effects due to this change I am now back to the original error message: desktop effects could not be enabled

I am afraid I'm on rather a steep learning curve here, I do not know what the previous driver was. I had never investigated.

Here's the other info you requested,
Quote:
# locate libGL
/usr/X11R6.old/old/lib/FGL.renamed.libGL.so.1.2
/usr/i486-linux-libc5/lib/libGL.so
/usr/i486-linux-libc5/lib/libGLU.so
/usr/lib/FGL.renamed.libGL.so.1.2
/usr/lib/libGL.so
/usr/lib/libGL.so.1
/usr/lib/libGL.so.1.2
/usr/lib/libGLU.so
/usr/lib/libGLU.so.1
/usr/lib/libGLU.so.1.3.060501
/usr/lib/fglrx/libGL.so.1
/usr/lib/fglrx/libGL.so.1.2
/usr/lib/xorg/FGL.renamed.libGL.so.1.2
/usr/lib/xorg/libGL.so
/usr/lib/xorg/libGL.so.1
/usr/lib/xorg/libGL.so.1.2
/usr/lib/xorg/modules/extensions/libGLcore.so
/usr/share/ati/libGLdir.txt
/var/cache/yum/updates-released/headers/xorg-x11-Mesa-libGL-6.8.2-37.FC4.49.2.i386.hdr
/var/cache/yum/updates-released/headers/xorg-x11-Mesa-libGLU-6.8.2-37.FC4.49.2.i386.hdr
/var/cache/yum/updates-released/packages/xorg-x11-Mesa-libGL-6.8.2-37.FC4.49.2.i386.rpm
/var/cache/yum/updates-released/packages/xorg-x11-Mesa-libGLU-6.8.2-37.FC4.49.2.i386.rpm
Quote:
# locate fglrx
This required too many characters to post again, you will fin the information attached.
Quote:

# ls -l |grep libGL
-rwxr-xr-x 1 root root 432048 Jan 24 2007 FGL.renamed.libGL.so.1.2
lrwxrwxrwx 1 root root 26 Oct 31 18:27 libGL.so -> /usr/lib/xorg/libGL.so.1.2
lrwxrwxrwx 1 root root 26 Oct 31 18:27 libGL.so.1 -> /usr/lib/xorg/libGL.so.1.2
lrwxrwxrwx 1 root root 10 Oct 31 18:27 libGL.so.1.2 -> libGL.so.1
lrwxrwxrwx 1 root root 11 Oct 31 14:14 libGLU.so -> libGLU.so.1
lrwxrwxrwx 1 root root 20 Oct 31 14:12 libGLU.so.1 -> libGLU.so.1.3.060501
-rwxr-xr-x 1 root root 527292 Jan 24 2007 libGLU.so.1.3.060501
Attached Files
File Type: txt locate_fglrx.txt (22.3 KB, 147 views)
Reply With Quote
  #10  
Old 29th February 2008, 03:35 AM
leigh123linux
Guest
 
Posts: n/a
It looks like the ATI installer ( the ATI homepage driver ) has been used on your fedora install , this can overwrite crucial system files.


Code:
/usr/share/fglrx/cp.list
/usr/share/fglrx/drv.list
/usr/share/fglrx/fglrx-install.log
/usr/share/fglrx/fglrx-uninstall.sh
/usr/share/fglrx/km.list
/usr/share/fglrx/postun_cp.sh
/usr/share/fglrx/postun_drv.sh
/usr/share/fglrx/postun_km.sh
/usr/share/fglrx/postun_rn.sh
/usr/share/fglrx/preun_km.sh
/usr/share/fglrx/rn.list

Try to uninstall it

Code:
su
cd /usr/share/fglrx
./fglrx-uninstall.sh
Reboot


then uninstall and reinstall the livna driver


Code:
su
yum erase kmod-fglrx xorg-x11-drv-fglrx 
yum install kmod-fglrx xorg-x11-drv-fglrx
Reboot
Reply With Quote
  #11  
Old 29th February 2008, 10:31 AM
Bezique Offline
Registered User
 
Join Date: Feb 2008
Posts: 11
Hi Leigh,
Thanks for continued support. I've tried your latest suggestion. The unistallations and installation went fine. However I still receive the same message indicating that there is no direct rendering.
Quote:
$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
I did skip ahead in your Howto for fglrx instructions. I have now installed Xgl and it is running (albeit very slowly). I had been under the impression that it would not work at all until I had direct rendering. Or is it more the case that direct rendering will make it run properly?
Reply With Quote
  #12  
Old 29th February 2008, 10:45 AM
leigh123linux
Guest
 
Posts: n/a
You could try replacing libGL , this should repair the damage caused by by the ATI installer ( with XGL running it is normal for glxinfo to show no direct rendering )



Code:
su
yum install yum-utils
yum update mesa-libGL xorg-x11-server-Xorg
yumdownloader mesa-libGL xorg-x11-server-Xorg
rpm -U --replacepkgs --replacefiles  mesa-libGL*rpm xorg-x11-server-Xorg*rpm
Reply With Quote
  #13  
Old 29th February 2008, 12:45 PM
Bezique Offline
Registered User
 
Join Date: Feb 2008
Posts: 11
Hi once more, I've implemented the latest suggestion. Though to my ignorant eye I cannot see the improvment. I should clarify, when I stated that I still do not get message informing me that I have direct rendering I meant for when Xgl is disabled and AIGLX is enabled.

Well, I think things work now as I hoped, although unfortunetly as I had feared I am not sure my graphics card is up to the challenge of capitalising on beryl (or similar). I think I'll get away with a few basic features, but nohing more.

Thanks greatly for your assistance Leigh, you're help has been much appreciated.
Reply With Quote
Reply

Tags
direct, fc6, rendering, set

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
direct rendering: no 4z0smq20kk Using Fedora 5 21st October 2008 07:06 PM
No Direct Rendering Axiom119 Hardware & Laptops 2 15th June 2008 01:57 AM
No direct rendering anthony_de Hardware & Laptops 7 17th January 2007 04:05 AM
ATI Direct Rendering Firebird8 Hardware & Laptops 9 7th September 2006 06:35 PM
i need direct rendering Abrocadabro Hardware & Laptops 1 3rd September 2004 07:31 AM


Current GMT-time: 06:58 (Sunday, 26-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Bwizibwera Instagram Photos - Hanumangarh Travel Photos - Yao Photos on Instagram