Fedora Linux Support Community & Resources Center
  #1  
Old 4th March 2008, 02:35 AM
Mr. PC Offline
Registered User
 
Join Date: Mar 2008
Posts: 8
wireless on Dell inspiron 1501

I can't get my wireless to work at all. I can't figure out how to install Ndisrwrapper for the life of me and I'm not even sure if that's the proper solution. I'm the type of person who needs instructions one click at a time; I've read tons of instructions even the ones designed for total newbies but newbie seems to mean something different in the Unix world than it did in Windows.

Please please please please I'm so hopeless nothing woks !(
Reply With Quote
  #2  
Old 4th March 2008, 10:28 AM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,359
Hello Mr. PC

We'll probably need to try and see if we can find a little more detail about your wireless card first. Open a terminal window, in Gnome that is from the 'Applications Menu - System Tools', and in it either type what is below, or copy and paste it:

Code:
/sbin/lspci
The 'lspci' part of the command lists all pci devices and the '/sbin/' part is the path to the command.

You should see a scrollable list of information on your pci devices.

Look for the ones that mention 'ethernet controller' or 'network controller'. Copy and paste those back and we'll think about the next step.
Reply With Quote
  #3  
Old 4th March 2008, 03:49 PM
Linesma Offline
Registered User
 
Join Date: Feb 2008
Location: Northern Virginia, USA
Posts: 149
I feel your pain Mr. PC. Being new to Linux myself, I sometimes think that the instructions given, even for new users, requires some form of prior knowledge. I had the same problem with my Dell Inspiron E1505, and the following thread helped me out.

Ndiswrapper in F8

For it to work, you will need the driver for your wireless card. Do you know what card you have? If you let me know, and I will give you a link to the proper driver. The one packaged with your Laptop from Dell is in a Self-Installing zip file, and probably old.

Let me know.

Mark
Reply With Quote
  #4  
Old 4th March 2008, 05:05 PM
Bslagowski Offline
Registered User
 
Join Date: Dec 2007
Location: Wisconsin
Posts: 196
Using ndiswrapper for your system is probably not the best solution. It's most likely you have a Broadcom card supported by a native driver. Proceed as bbfuller suggested for now, at least. Ndiswrapper is a last ditch alternative.
__________________
So dawn goes down to day,
Nothing gold can stay.
Reply With Quote
  #5  
Old 5th March 2008, 02:34 AM
Mr. PC Offline
Registered User
 
Join Date: Mar 2008
Posts: 8
Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)

ya it is a Broadcom cool. I read that native drivers are really slow with dell cards but I'm not sure if that's true with mine.
Reply With Quote
  #6  
Old 5th March 2008, 04:24 AM
Bslagowski Offline
Registered User
 
Join Date: Dec 2007
Location: Wisconsin
Posts: 196
That's your wired control. Do:

Code:
su - 
lspci | grep Network
and paste that here.
__________________
So dawn goes down to day,
Nothing gold can stay.
Reply With Quote
  #7  
Old 7th March 2008, 05:27 AM
Mr. PC Offline
Registered User
 
Join Date: Mar 2008
Posts: 8
-v Be verbose
-n Show numeric ID's
-nn Show both textual and numeric ID's (names & numbers)
-b Bus-centric view (PCI addresses and IRQ's instead of those seen by the CPU)
-x Show hex-dump of the standard portion of config space
-xxx Show hex-dump of the whole config space (dangerous; root only)
-xxxx Show hex-dump of the 4096-byte extended config space (root only)
-s [[[[<domain>]:]<bus>]:][<slot>][.[<func>]] Show only devices in selected slots
-d [<vendor>]:[<device>] Show only selected devices
-t Show bus tree
-m Produce machine-readable output
-i <file> Use specified ID database instead of /usr/share/hwdata/pci.ids.gz
-k Show kernel drivers handling each device
-p <file> Look up kernel modules in a given file instead of default modules.pcimap
-D Always show domain numbers
-M Enable `bus mapping' mode (dangerous; root only)
-P <dir> Use specified directory instead of /proc/bus/pci
-H <mode> Use direct hardware access (<mode> = 1 or 2)
-F <file> Read configuration data from given file
-G Enable PCI access debugging
Reply With Quote
Reply

Tags
1501, dell, inspiron, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to activate wireless on dell inspiron 1501 paralizer Hardware & Laptops 4 9th August 2008 10:36 AM
Fedora 7, Dell Inspiron 1501, Wireless Issue path_mcgohenn Hardware & Laptops 5 8th March 2008 03:09 PM
Dell Inspiron 1501 no Wireless marisdembovskis Hardware & Laptops 0 16th January 2008 09:00 PM
I can not run 3D on my Dell Inspiron 1501. s-strong Hardware & Laptops 0 3rd April 2007 07:36 PM
FC6 on Dell Inspiron 1501 Notebook......Wireless Card problem oneders Servers & Networking 1 19th February 2007 06:37 PM


Current GMT-time: 22:25 (Wednesday, 20-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat