Fedora Linux Support Community & Resources Center
  #1  
Old 11th March 2008, 02:57 PM
mikefarris Offline
Registered User
 
Join Date: Mar 2008
Location: Arkansas
Age: 60
Posts: 10
Keyboard Problem after running EasyLIfe <Solved>

I originally posted this in another forum, but have deleted and reposted here as being more appropriate

I was reading a thread in the Gamers Lounge and noticed the resource listing in Wayne's signature block, and decided to try EasyLife. It worked great and I like the changes, except for one biggie, a toggled keyboard setting. I'll explain.

I am running Fedora 8 on a Gateway MX6429 15" Laptop (AMD 64 Turion) and Gnome desktop. Installation has been relatively painless--some initial struggle with getting the wireless up but that is now resolved.
After I finished running EasyLife I rebooted and everything seemed normal until I couldn't log in to my wireless network (wouldn't accept the password). I opened Terminal and tried to login as root and couldn't (my keyboard was typing gobbledygook. After closer examination I found that somehow the function key on my keyboard was now defaulted on so that when I typed an 'M' I got a '0' instead. By holding down the Fn key I am able to type normally, but obviously this isn't a good soloution.
The problem only shows up after intial login--when accessing the user accounts the keyboard still works properly so I suspect it is a setting under Gnome. Also, though I only applied EasyLife to one user (myself) the problem shows up when I login to my wife's account also.

Any help would be greatly appreciated. I know I could reformat and start over from scratch, but I hate to do that to a system that seems to be working great other than this one problem.

Thanks,
Mike

Last edited by mikefarris; 12th March 2008 at 05:10 PM.
Reply With Quote
  #2  
Old 11th March 2008, 03:50 PM
spoilt Offline
Registered User
 
Join Date: Nov 2007
Location: London
Posts: 54
hehe press the "Num lock" key on your keyboard and it should be fixed
__________________
---------------------
Edward Karavakis
http://fedoraproject.org/wiki/EdwardKaravakis
http://www.spoiltspace.co.uk
Reply With Quote
  #3  
Old 11th March 2008, 03:56 PM
mikefarris Offline
Registered User
 
Join Date: Mar 2008
Location: Arkansas
Age: 60
Posts: 10
If that works I will feel really stupid! Will try it when I get home tonight.
Though I wonder why I don't have the problem when initially logging in. I would expect if it was the Num Lock key it would apply then as well.

Thanks

Last edited by mikefarris; 11th March 2008 at 03:59 PM.
Reply With Quote
  #4  
Old 11th March 2008, 04:52 PM
spoilt Offline
Registered User
 
Join Date: Nov 2007
Location: London
Posts: 54
you're right.. hm, although i don't use gnome, click the menu: "Applications > Preferences > More preferences > Sessions". In the "Startup Programs" tab, check for numlockx, select it and remove it. NumlockX enables numlock at startup automatically in a Gnome session.

you can even: # yum erase numlockx
please let me know
__________________
---------------------
Edward Karavakis
http://fedoraproject.org/wiki/EdwardKaravakis
http://www.spoiltspace.co.uk

Last edited by spoilt; 11th March 2008 at 04:56 PM.
Reply With Quote
  #5  
Old 11th March 2008, 04:59 PM
mikefarris Offline
Registered User
 
Join Date: Mar 2008
Location: Arkansas
Age: 60
Posts: 10
Thanks, I'll try it and let you know.
Reply With Quote
  #6  
Old 12th March 2008, 02:02 PM
mikefarris Offline
Registered User
 
Join Date: Mar 2008
Location: Arkansas
Age: 60
Posts: 10
Problem Fixed

#yum erase numlockx

That took care of my problem.

One thing I noticed, you had mention going through the applications menu to preferences, exactly like I would have done on my MacBook, but my Gnome Desktop doesn't have that menu structure. Is there another version that does?
I'm using the default installed from my Fedora 8 DvD.

Thanks for the help,
Mike
Reply With Quote
  #7  
Old 12th March 2008, 02:26 PM
spoilt Offline
Registered User
 
Join Date: Nov 2007
Location: London
Posts: 54
hm, no that's the standard gnome desktop...maybe it's not under preferences... frankly i don't know ( i prefer kde ).
update: i guess it's under system>preferences>sessions
the bin file: /usr/bin/gnome-session-properties
__________________
---------------------
Edward Karavakis
http://fedoraproject.org/wiki/EdwardKaravakis
http://www.spoiltspace.co.uk
Reply With Quote
  #8  
Old 12th March 2008, 03:23 PM
mikefarris Offline
Registered User
 
Join Date: Mar 2008
Location: Arkansas
Age: 60
Posts: 10
Thanks, I'll check it out.
__________________
Gateway MX6429
AMD 64 Turion Laptop
Fedora 8
Broadcom Wireless (Working :D )
Reply With Quote
  #9  
Old 23rd March 2008, 04:52 AM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 34
Posts: 702
Hello:

I removed the package numlockx from the default "utils" options from esayLife, so it won't give any trouble to laptop users.

Cheers,
duli
Reply With Quote
Reply

Tags
easylife, keyboard, problem, running

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
easyLife - Automated installs and configurations on Fedora! Duli Guides & Solutions (No Questions) 352 27th January 2014 06:19 PM
Installing java64 using easylife bobo60 Using Fedora 0 28th December 2008 10:18 PM
Help Easylife Installer Dwarflord Installation, Upgrades and Live Media 1 7th October 2008 10:30 PM
easylife doesn't work in Fedora 9 1inxs Alpha - Beta (Fedora 9 Only) 5 18th April 2008 07:01 AM
Running an arbitary command from keyboard key jimbobsma Using Fedora 1 18th August 2007 02:24 PM


Current GMT-time: 18:42 (Sunday, 20-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat