Fedora Linux Support Community & Resources Center
  #1  
Old 25th March 2008, 05:08 PM
alexandre_go Offline
Registered User
 
Join Date: Mar 2008
Posts: 5
Lightbulb wireless activation at boot

i need to be able to have my wifi connection active during boot.

what files I need to edit in order to write the wireless configuration of network (ESSD, encryption, ...), in order to get connected during boot?

i think that no one in the world has this problem.... i'm desperate for a solution, but i simply can't find it!!!

thanks
Reply With Quote
  #2  
Old 25th March 2008, 05:30 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
You can edit the file which pertains to the name of your wireless device. It might be:
ifcfg-wan0, ifcfg-eth1, or some other variation. They are contained:

/etc/sysconfig/network-scripts/

Just change the "onboot" option to yes.

But a better solution would be to use NetworkManager to manage your wireless. Goto system ->administration ->services, and add check marks to the 2 NM services, save it and reboot, you should have a new icon in the top panel. Now since you didn't mention what type of wireless device you have, there may be some other items to attend to. Open a terminal window and type:

/sbin/lspci

and post the output here.
Reply With Quote
  #3  
Old 25th March 2008, 06:04 PM
alexandre_go Offline
Registered User
 
Join Date: Mar 2008
Posts: 5
thanks iron_mike.

i have networkmanager and networkmanagerdispatcher started at boot.
the wireless adapter is activated at boot!

the point is that there is no connection, because (i assume) the wireless credentials are not set anywhere (essid, wkeys, encryption, ...)

anyway here is the output of /sbin/lspci

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600M GT (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
07:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
08:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
08:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
08:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
08:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)

best regards.
Reply With Quote
  #4  
Old 25th March 2008, 06:24 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
If you going to use NetworkManager, under the system ->administration ->network configuration the wireless device should not be set to "activate on boot", NM will activate it. When left clicking the NM icon, does your access point appear in the list?
Reply With Quote
  #5  
Old 25th March 2008, 06:36 PM
alexandre_go Offline
Registered User
 
Join Date: Mar 2008
Posts: 5
yes my access point appears in the list.

for some reason nm has the wkey stored in the default keyring. after I unlock the keyring, nm connects immeadiately. but this happens after the login! what i need is tgo have the network connection active before login.
Reply With Quote
  #6  
Old 25th March 2008, 08:12 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
I see now, this would involve editing the startup scripts to include something along these lines or however your network is configured. I believe the startup script is /etc/rc.local

ifconfig wlan0 up
/etc/init.d/wpa_supplicant start
dhclient -wn wlan0
ifconfig eth0 up
dhclient -wn eht0
etc
Reply With Quote
  #7  
Old 25th March 2008, 11:02 PM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,363
Hello alexandre_go

You can get wireless working at a certain level before login, in fact at the same time as the other network devices without editing scripts but only if you are prepared to restrict yourself to WEP encryption levels.

Mine, and I assume others, used to work like that before the advent of NM.

You would need to disable the NM applet from Gnome Menu - System - Administration - Services.

Then set up your card in System Menu - Administration - Network.

If you highlight your card there and select "Edit" there is the option to set the card to "Activate device when computer starts", to select dhcp or enter ip addresses and to enter a WEP wireless key. That is usually hexadecimal and requires 0x to preface it in that case (zero, lower case x).

If you require WPA then as Iron_Mike says you need to find other methods like scripting the commands.
Reply With Quote
  #8  
Old 27th March 2008, 03:10 AM
alexandre_go Offline
Registered User
 
Join Date: Mar 2008
Posts: 5
[B]i found the solution to the problem.... wicd!!!! it rocks!
Reply With Quote
Reply

Tags
activation, boot, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with wireless card activation sundjata Servers & Networking 16 30th April 2008 01:05 PM
getting IP adresses using dhcp after eth activation on boot! redzo Using Fedora 0 10th February 2007 01:15 PM
FC5 swap boot activation problem buhochileno EOL (End Of Life) Versions 0 26th June 2006 09:43 AM
Activation help w/Intel Pro Wireless 2200BG bsenefeld Installation, Upgrades and Live Media 8 23rd May 2006 07:03 AM
Wireless Activation help required Maverick-23feb Hardware & Laptops 19 15th January 2006 03:38 AM


Current GMT-time: 14:06 (Sunday, 21-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat