Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10th April 2008, 12:49 PM
otnateos Offline
Registered User
 
Join Date: Oct 2007
Posts: 110
Problem with QEMU and Virtual Machine Manager after updates, guest machine slow

Hi,

Basically I used to had a Windows XP guest and works well. However after few updates of libvirtd, etc, etc, and including my stupid combination to re-add the guest image somehow the Windows XP guest run far slower.

I only notice that previously my guest saying the processor as QEMU 2.4GHz, now it says Pentium II 2.4GHz.

I wonder if someone could point out to specific way to edit settings for Qemu guest machine in Virtual Machine Manager, or even help me to find quick fix to my problem. Thanks
Reply With Quote
  #2  
Old 11th April 2008, 04:59 AM
webaware Offline
Registered User
 
Join Date: Nov 2007
Location: Australia
Posts: 36
It sounds like you no longer have /dev/kqemu loaded. Have you also had a kernel update? This is what usually does it - you probably don't have kqemu module for your new kernel.

I have a routine of rebuilding / reinstalling the kqemu and nvidia modules every time I get a kernel update. See here for a simple guide to QEMU and kqemu.
Reply With Quote
  #3  
Old 12th April 2008, 12:19 AM
otnateos Offline
Registered User
 
Join Date: Oct 2007
Posts: 110
I did have the kernel update and I didn't have kqemu module for my kernel. I think if I remember correctly I never use kqemu previously so the problem might not with the kqemu.

I tried to install kqemu and use my normal way to run my virtual XP and still doesn't improve the performance.
Reply With Quote
  #4  
Old 12th April 2008, 12:58 PM
webaware Offline
Registered User
 
Join Date: Nov 2007
Location: Australia
Posts: 36
Ah, I didn't catch it before - you're running from the Virtual Machine Manager. If you ticked the option for "kernel / hardware acceleration" that means you're running KVM (qemu-kvm). Or you were, when it was faster. You should check for /dev/kvm to see if this kernel module is still being loaded, as it sounds like maybe it isn't.

I played around with the VMM briefly one afternoon recently, and couldn't see where you can switch this setting on / off after the fact, but maybe there is a way to do it from the shell - see here for more information about managing VMM from the shell.

Alternatively, you could try to run KVM directly from the shell without messing about with the VMM. It allows you to specify lots of options, and you'll also get to see the output of KVM which might tell you what's going wrong. Run KVM just like QEMU, except specify qemu-kvm instead of qemu. e.g.

Code:
qemu-kvm -m 512 -hda /path/to/your.img
Reply With Quote
  #5  
Old 12th April 2008, 01:59 PM
otnateos Offline
Registered User
 
Join Date: Oct 2007
Posts: 110
Hey thanks webaware,

I was thinking I could simply use VMM and don't worry about configuration and such, and from your post I just realised that my VM was using qemu instead qemu-kvm to run it (even though I have specified to use kernel/hardware acceleration).

I changed the emulator in the configuration and the speed returns back to normal. I guess something is not really set well on the current version of VMM that I'm using. I can't even shutdown my VM. Well that's another matter.

Thanks again for your guide.
Reply With Quote
  #6  
Old 12th April 2008, 02:31 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
wow, qemu-kvm really is much faster. I just booted a F8 liveCD iso image in 30 secs!

Code:
yum install kvm
Then I rebooted (I probably could have just loaded the relevant kernel modules kvm, kvm_intel)

Code:
qemu-kvm -m 512 -cdrom /data/F8LiveCD.iso
Thanks for the tip, I'll be using it from now on. stevea posted a while back about the latest kvm modules being even faster, I'll have a look at that when I get the time.
Reply With Quote
  #7  
Old 12th April 2008, 03:29 PM
webaware Offline
Registered User
 
Join Date: Nov 2007
Location: Australia
Posts: 36
Yay! Good to hear all is working fast again. And glad that sideways is ripping along now too!
Reply With Quote
Reply

Tags
guest, machine, manager, problem, qemu, slow, updates, virtual

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Machine Manager error when add a new virtual machine bizar Using Fedora 3 1st November 2009 10:37 PM
Virtual Machine Manager vs. QEMU early-ehlinger Using Fedora 2 8th February 2008 01:58 PM
F 7 qemu-kvm (virtual machine manager) windows XP cpu utilization russellr Using Fedora 4 12th September 2007 10:46 AM
problem creating a new virtual system with Virtual Machine Manager in Fedora 7 reboot Using Fedora 3 3rd June 2007 01:51 AM
Xen QEMU virtual machine stuff Saint Mike Using Fedora 0 13th July 2006 05:15 AM


Current GMT-time: 02:02 (Monday, 15-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat