Fedora Linux Support Community & Resources Center
  #1  
Old 2nd May 2008, 06:52 AM
TheLK Offline
Registered User
 
Join Date: Aug 2007
Location: Toronto
Posts: 33
Protected WLAN Dont Work, Unprotected Works

Hardware:
IBM Thinkpad X40 w/ (Atheros Communications, Inc. AR5212 802.11abg NIC)
Distrobution:
Fedora 8 XFCE4
SELinux all set with "permissive" permissions



For some reason I can connect to multiple of my neighbour's unprotected wireless networks.
However i cannot connect to my own network.

I tried:
1. Linksys WAP54G 54Mbps 802.11g Wireless Access Point (WPA Personal encryption) ...'says' connected, but cannot do anything such as browse the internet

2. Linksys WRT54GC Compact Wireless-G Broadband Router (WEP 128bit encryption)......Won't even connect






BTW: On my other labtops running windows it works, and this particular labtop also worked before i converted


Anyone have any clue's whats going wrong here, any suggestions would be great
Thanks in advance
Reply With Quote
  #2  
Old 2nd May 2008, 03:23 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
With it connected to yours, open a terminal window and change to root with su - (the dash is important) and type:

ifconfig -a

and post the results
Reply With Quote
  #3  
Old 2nd May 2008, 06:55 PM
TheLK Offline
Registered User
 
Join Date: Aug 2007
Location: Toronto
Posts: 33
Code:
[andey@localhost ~]$ su -
Password: 
[root@localhost ~]# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0A:E4:2C:24:05  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:2734 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2778 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1618485 (1.5 MiB)  TX bytes:416779 (407.0 KiB)
          Base address:0x7000 Memory:d0220000-d0240000 

irda0     Link encap:IrLAP  HWaddr 00:00:00:00  
          NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:8 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1213 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1213 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2551560 (2.4 MiB)  TX bytes:2551560 (2.4 MiB)

wlan0     Link encap:Ethernet  HWaddr 00:0E:9B:6E:2D:7D  
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20e:9bff:fe6e:2d7d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3621 (3.5 KiB)  TX bytes:13584 (13.2 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-0E-9B-6E-2D-7D-18-79-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

[root@localhost ~]#
Thanks for any help
Reply With Quote
  #4  
Old 2nd May 2008, 07:32 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
Are you using Network Manager or using system-config-network to start/stop your wireless device? Are you using static or dhcp for the configuration? If using system-config-network, check the gateway and dns settings.
Reply With Quote
  #5  
Old 5th May 2008, 02:30 AM
vodamaxe Offline
Registered User
 
Join Date: Nov 2007
Posts: 26
Also take into consideration to give 'wlassistant' a try. At my laptop (fujitsu siemens amilo with Intel wlan card) this tool was the only way to connect to protected WLAN networks in fedora 8. (Of course, you also need to have installed wpa_supplicant to connect to WPA/WPA2 protected WLANs.
__________________
/h.
linux.ll--ll.net
Reply With Quote
  #6  
Old 5th May 2008, 06:29 PM
TheLK Offline
Registered User
 
Join Date: Aug 2007
Location: Toronto
Posts: 33
Quote:
Originally Posted by Iron_Mike
Are you using Network Manager or using system-config-network to start/stop your wireless device? Are you using static or dhcp for the configuration? If using system-config-network, check the gateway and dns settings.
- i use the graphical system-config-network
- i always use dhcp...however
how can i configure my gateway / dhcp settings


Quote:
Originally Posted by vodamaxe
Also take into consideration to give 'wlassistant' a try. At my laptop (fujitsu siemens amilo with Intel wlan card) this tool was the only way to connect to protected WLAN networks in fedora 8. (Of course, you also need to have installed wpa_supplicant to connect to WPA/WPA2 protected WLANs.
I tried wlassistant, no luck
wpa_supplicant - 1:0.5.10-4.fc8.i386 (installed) (and running in the services)
Reply With Quote
  #7  
Old 6th May 2008, 04:55 AM
vodamaxe Offline
Registered User
 
Join Date: Nov 2007
Posts: 26
Quote:
Originally Posted by TheLK
-
I tried wlassistant, no luck
wpa_supplicant - 1:0.5.10-4.fc8.i386 (installed) (and running in the services)
Well, you said that you can perfectly connect to unencrypted WLAN (DHCP) networks, right ?
Then lets make one thing clear: your DHCP settings are ok.

So lets focus at the problems with the encryption layer:

That wpa is running as a service does not necessarily mean that wlassistent (or any other WLAN tool) is actualy using it ...

my tip is:
- make sure you have the right security settings (WPA password etc.) made inside the wlassistent
- start wlassistent as root
- start it in a shell and do not force it into background- so you can see what messages the wlassistent is producing (actualy the tool shows all the wlan-commands it is using in the background)
- check for the call of the wpa-suplicant
- check for error messages

here is like it looks at my laptop ( note the 3 lines:
Using wpa_supplicant driver: wext
WPA client started. Waiting for status...
WPA Authorisation successful.)

cheers
/h.

[root@schleppix heiko]# wlassistant

Loaded application options.
All interfaces: eth0, wlan0, wmaster0
Wireless interface(s): wlan0
Permissions checked.
DHCP Client: dhclient
All executables found.
scan: /sbin/iwlist wlan0 scan
Networks found: 1
Running DHCP client found.
kill_dhcp: /sbin/dhclient -r wlan0
==>stderr: Internet Systems Consortium DHCP Client V3.0.6-Fedora
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:18:de:8b:de:2a
Sending on LPF/wlan0/00:18:de:8b:de:2a
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.1.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
No pre-connection command specified.
iwconfig_set: /sbin/iwconfig wlan0 mode managed channel 6 key off essid mntlab
iwconfig_ap: /sbin/iwconfig wlan0 ap 00:1A:70F:F4:34
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
Using wpa_supplicant driver: wext
WPA client started. Waiting for status...
WPA Authorisation successful.
ifconfig_dhcp: /sbin/dhclient wlan0
==>stderr: Internet Systems Consortium DHCP Client V3.0.6-Fedora
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:18:de:8b:de:2a
Sending on LPF/wlan0/00:18:de:8b:de:2a
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPOFFER from 192.168.1.1
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.102 -- renewal in 39835 seconds.
No post-connection command specified.
__________________
/h.
linux.ll--ll.net
Reply With Quote
Reply

Tags
protected, unprotected, wlan, work, works

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
yum dont work jideck Using Fedora 4 5th May 2009 01:06 PM
F9: WLAN only works in gnome desktop phonk Servers & Networking 3 30th January 2009 09:49 PM
cat dont work Yentor Using Fedora 0 29th September 2007 12:44 PM
Realtek ALC880 dont works multi sound ardainbox Using Fedora 0 1st March 2007 09:18 AM
I just dont understand WLAN in Linux Crimson Tide Hardware & Laptops 5 28th December 2005 10:27 PM


Current GMT-time: 07:22 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Kazerun Instagram Photos - Mangrol Photos on Instagram - Lugo Instagram Photos