Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 14th May 2008, 06:15 PM
jon3k Offline
Registered User
 
Join Date: Sep 2004
Posts: 60
Problems Binding "Open a Terminal" to keyboard shortcut

I'm unable to bind "Open a Terminal" under System -> Preferences -> Personal -> Keyboard Shortcuts to any key combination. For example, I tried to bind windows key + t to run terminal (after adjusting the Windows key behavior under Hardware -> Keyboard appropriately) but it doesn't do anything when I press it. However, I can bind the same key combination to something else ("Run an Application" for example) and it works fine.
Reply With Quote
  #2  
Old 14th May 2008, 07:36 PM
ivancat Offline
Registered User
 
Join Date: Dec 2007
Posts: 596
Yes, noticed that too
__________________
Ivan Cat (registered linux user #471784)
Linux Projects: constat | nconv
Fedora-related: Message In the Bottle
Reply With Quote
  #3  
Old 14th May 2008, 08:14 PM
jon3k Offline
Registered User
 
Join Date: Sep 2004
Posts: 60
I filed a bugzilla report for this one, I'll let everyone know what I find out.

Filed at:
https://bugzilla.redhat.com/show_bug.cgi?id=446478

Please post there if you're also experiencing this problem.

Last edited by jon3k; 14th May 2008 at 09:13 PM.
Reply With Quote
  #4  
Old 14th May 2008, 09:14 PM
ivancat Offline
Registered User
 
Join Date: Dec 2007
Posts: 596
maybe it's gnome's 2.20 bug, because I've checked that in gnome 2.22 and it worked well
__________________
Ivan Cat (registered linux user #471784)
Linux Projects: constat | nconv
Fedora-related: Message In the Bottle
Reply With Quote
  #5  
Old 14th May 2008, 10:43 PM
jon3k Offline
Registered User
 
Join Date: Sep 2004
Posts: 60
thanks ivancat
Reply With Quote
  #6  
Old 15th May 2008, 12:49 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
I've always found that in gnome, you can't mix the Windows key with anything. Everytime I used their gui to try some keyboard combo like Windows + r for terminal, it just shows the binding as Super_L.

Probably a Gnome bug, as was said. The combos work with fluxbox and openbox.
Reply With Quote
  #7  
Old 15th May 2008, 03:10 PM
jon3k Offline
Registered User
 
Join Date: Sep 2004
Posts: 60
Scottro -

I'm able to map windows key + (X) to other shortcuts, just not "Open A Terminal". The problem you're describing can be solved by:

Ssystem ->Preferences -> Hardware -> Keyboard

Click "Layout Options" tab

Under the "Alt/Win" section choose "Meta is mapped to win keys"
Reply With Quote
  #8  
Old 16th May 2008, 12:19 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
Ah, handy to know. It enabled m to do Windows+Alt plus a few things.

Thank you very much. Despite my fears in our PM conversation, the Alt key also worked.

Thanks very much. I don't use Gnome too often, but this is good to know.

Edit--by the way, I was also able to use it to open a terminal. (My usual fluxbox/openbox shortcut is Mod4 R.)
Reply With Quote
  #9  
Old 16th May 2008, 03:33 PM
jon3k Offline
Registered User
 
Join Date: Sep 2004
Posts: 60
This is pretty interesting, if I disable "Desktop Effects" the keyboard shortcut works!
Reply With Quote
  #10  
Old 28th May 2008, 01:31 AM
Deonis Offline
Registered User
 
Join Date: May 2008
Location: Montreal
Posts: 198
Hello ! I have a same problem, but with binding "HOME FOLDER" with any shortcuts ....nothing helps even gconf. Shortcut is set but it does not works. As for terminal shortcut I have been able to set it correctly with gconf /apps/metacity/global-keybindigs. Any IDEA?!
Reply With Quote
  #11  
Old 28th May 2008, 01:33 AM
Deonis Offline
Registered User
 
Join Date: May 2008
Location: Montreal
Posts: 198
I forget to tell. I am using Fedora 9 with last updates.
Reply With Quote
Reply

Tags
binding, keyboard, open a terminal, problems, shortcut

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Open a new terminal using keyboard shortcut. Simen Using Fedora 2 11th March 2009 07:55 PM
Problems with FC6 yum, "Error: Cannot open/read repomd.xml file for repository: core" Osirius EOL (End Of Life) Versions 1 15th February 2007 12:21 PM
How to add "Open Terminal" to context menu? Daedalus Using Fedora 5 16th April 2006 02:09 PM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM
Scroll down to the last line by "end" key in "less" using "Terminal GNOME&q Szpak Using Fedora 0 7th June 2004 02:24 AM


Current GMT-time: 05:22 (Thursday, 31-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat