Fedora Linux Support Community & Resources Center
  #1  
Old 15th May 2008, 05:50 AM
jojohippo Offline
Registered User
 
Join Date: Dec 2007
Posts: 32
How do I enable 'tap to click' on mousepad?

Hi, I understand that the new default behaviour of the synaptic driver is to disable tap to click by defualt (Boo!). I learnt from here that all you have to do is add
Code:
       Option "TapButton1" "1"
       Option "TapButton2" "2"
to xorg.conf to get the tap to click working.

My xorg.conf file does not have any touchpad input devices. How do I add those two lines.

This is my xorg.conf

# Xorg configuration created by pyxf86config
Code:
Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Reply With Quote
  #2  
Old 15th May 2008, 01:19 PM
dejan.kitic Offline
Registered User
 
Join Date: May 2008
Posts: 34
This is how it should look like:
PHP Code:
Section "ServerLayout"
    
Identifier     "Default Layout"
    
Screen      0  "Screen0" 0 0
    InputDevice    
"Keyboard0" "CoreKeyboard"
        
InputDevice    "TouchPad" "CorePointer"
EndSection

#Another section for Touchpad
Section "InputDevice"

    
Identifier  "Touchpad"
    
Driver      "synaptics"
       
Option      "SendCoreEvents"
       
Option      "Protocol" "auto-dev"
       
Option      "TapButton1" "1"
       
Option      "TapButton2" "2"
       
Option      "TapButton3" "3"
       
Option      "SHMConfig" "on"
EndSection 

Also take a look at this for more details:
http://gentoo-wiki.com/HARDWARE_Synaptics_Touchpad

Cheers, D

Last edited by dejan.kitic; 15th May 2008 at 08:40 PM. Reason: Correct driver name is synaptics...Damn typos
Reply With Quote
  #3  
Old 15th May 2008, 07:49 PM
joko77 Offline
Registered User
 
Join Date: May 2006
Posts: 2
The driver is synaptics and not synaptic.

Code:
Driver "synpatics"
Reply With Quote
  #4  
Old 15th May 2008, 09:47 PM
jojohippo Offline
Registered User
 
Join Date: Dec 2007
Posts: 32
Talking

Thanks both of you! I copied dejan.kitic's post and changed it to synaptics... mousepad now works great! This is what my xorg.conf file looks like now:

Code:
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "TouchPad" "CorePointer" 
EndSection

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

#Another section for Touchpad
Section "InputDevice"

    Identifier  "Touchpad"
    Driver      "synaptics"
       Option      "SendCoreEvents"
       Option      "Protocol" "auto-dev"
       Option "TapButton1" "1"
       Option "TapButton2" "2"
       Option "TapButton3" "3"
       Option      "SHMConfig" "on"
EndSection 

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Reply With Quote
  #5  
Old 17th May 2008, 07:41 PM
MrGroover Offline
Registered User
 
Join Date: Oct 2005
Location: Germany
Age: 30
Posts: 38
Is there a way of setting these values without using the xorg.conf file?
Reply With Quote
  #6  
Old 19th May 2008, 02:31 AM
jojohippo Offline
Registered User
 
Join Date: Dec 2007
Posts: 32
MrGroover, The only way I found for enabling tap to click without editing grub was adding a line to my grub menu file. Unfortunately it wasn't as good as editing xorg.conf because scrolling on the touchpad didnt' work.

You have to edit /boot/grub/menu.lst and add 'psmouse.proto=imps' to the line that begins with kernel. You can see this post. Again, the xorg.conf way worked better for me.
Reply With Quote
  #7  
Old 20th May 2008, 01:19 AM
tscheez Offline
Registered User
 
Join Date: Mar 2005
Location: Fairport, NY (Rochester)
Age: 36
Posts: 113
editing xorg.conf enabled tapping when X first starts, but if it goes to suspend, tapping doesn't work until X is restarted.
__________________
i'd rather be motoring
Reply With Quote
  #8  
Old 20th May 2008, 03:26 AM
jojohippo Offline
Registered User
 
Join Date: Dec 2007
Posts: 32
tscheez, I've noticed that too. anyone know of a fix?
Reply With Quote
  #9  
Old 20th May 2008, 12:10 PM
dejan.kitic Offline
Registered User
 
Join Date: May 2008
Posts: 34
Quote:
Originally Posted by jojohippo
tscheez, I've noticed that too. anyone know of a fix?
Thanks to Bob Kashani, there is solution:
Install package from here, and touchpad will work just peachy.

http://www.ocf.berkeley.edu/~bobk/packages/

This resolves both tapping and suspend/resume problem, taken from
https://bugzilla.redhat.com/show_bug.cgi?id=439386

Cheers D
Reply With Quote
  #10  
Old 20th May 2008, 08:34 PM
jojohippo Offline
Registered User
 
Join Date: Dec 2007
Posts: 32
Thansk dejan.kitic, touchpad works just peachy =)
Reply With Quote
  #11  
Old 20th May 2008, 09:28 PM
MrGroover Offline
Registered User
 
Join Date: Oct 2005
Location: Germany
Age: 30
Posts: 38
Quote:
Originally Posted by jojohippo
You have to edit /boot/grub/menu.lst and add 'psmouse.proto=imps' to the line that begins with kernel.
As long as the i810 driver isn't working in X, I don't want to use a xorg.conf file, because for me, it works better without that file. But I have an idea how to work out the problem, no xorg.conf file present and the still having the ability to configure the synaptics touchpad. There is a tool called synclient (its in the repos) and with this tool, one can adjust the parameters of the Synaptics without editing the xorg.conf file and without restarting X. My idea is to write a basic script that is called when X starts and this script will set the parameters for the touchpad as I want to have them.
I'll just have to find out, how to tell xorg that a synaptics touchpad is present and not a generic ps2 mouse or something. I haven't look what X detects without the config file... Maybe your hint with the parameter in the menu.lst file is a good starting point...
Reply With Quote
  #12  
Old 24th May 2008, 12:08 PM
BobNutfield Offline
Registered User
 
Join Date: May 2008
Location: United Kingdom
Posts: 90
[QUOTE]Thanks to Bob Kashani, there is solution:
Install package from here, and touchpad will work just peachy.

After weeks of trying to get the touchpad working, you link to the driver solved it. Thank you very much.

Bob
Reply With Quote
  #13  
Old 29th July 2008, 05:28 AM
negativeEntropy Offline
Registered User
 
Join Date: May 2007
Posts: 23
How would I go about installing this new driver if I have a previous one already installed? Do I need to disable the old one first? Can I just rpm -e it?

I tried using rpm -ivh synaptics-0.14.6-8.1.fc9.i386.rpm, but its getting conflicts from the 0.14.6-7.fc9.i386 version. I also installed gsynaptics for a gui, which I'm not sure if it needs to be removed as well.
Reply With Quote
  #14  
Old 29th July 2008, 09:10 AM
djselbeck Offline
Registered User
 
Join Date: Jun 2006
Location: Germany
Age: 26
Posts: 61
Have you tried "rpm -Uvh" ? If this also does not work you could force rpm with the "--force" option
Reply With Quote
  #15  
Old 30th July 2008, 01:01 AM
negativeEntropy Offline
Registered User
 
Join Date: May 2007
Posts: 23
rpm -Uvh did it for me. Thanks!!!
Reply With Quote
Reply

Tags
click, enable, mousepad, tap

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Needing left-click to open files upon single-click theAdmiral Hardware & Laptops 6 30th October 2009 04:55 AM
Click "Enable Desktop Effects" = log out tdcrooks Using Fedora 6 14th September 2009 07:19 AM
Mousepad, tap doesn't work billgoldberg Using Fedora 2 11th June 2009 05:00 PM
Mousepad click zlx Using Fedora 2 30th June 2008 04:43 AM


Current GMT-time: 17:56 (Monday, 24-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Citrus Heights Instagram Photos - Kheda - Horstel