Fedora Linux Support Community & Resources Center
  #1  
Old 16th June 2008, 07:46 AM
johnfitz Offline
Registered User
 
Join Date: Jun 2008
Posts: 8
tftp will not start.

I have setup nimol on a Fedora 9 machine. Nimol is installed and correctly configured and I have a client rs6000 (43p) declared in the dhcpd.conf file. all is running correctly and tftp is installed. I am monitoring /var/log/messages when I start the 43p and see the dhcp request come in and a reply with the correct address and subnet mask given as the reply. However tftp does not start and the 43p goes to SMS. Anyone know why tftp does not start please?
Reply With Quote
  #2  
Old 16th June 2008, 09:09 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,768
I think you'd be better off asking on an AIX forum.
Reply With Quote
  #3  
Old 16th June 2008, 09:30 AM
notageek Online
Registered User
 
Join Date: Jan 2008
Location: Bangalore, India
Posts: 2,138
Did you start xinetd?

tftp in Fedora is started by xinetd, you'll have to edit the following configuration located here /etc/xinetd.d/tftp and which looks like this

Code:
service tftp
{
   disable        = yes
   socket_type    = dgram
   wait           = yes
   user           = root
   server         = /usr/sbin/in.tftpd
   server_args    = -s /tftpboot
}
change disable=yes to disable=no and start xinetd

Code:
# service xinetd start
(I'm not on my Fedora box or anywhere near a linux box, I may be little off in configuration. Please make sure to use man and refer /usr/share/doc before you try this)
__________________
Robot Nite - Designated device drivers drink free
Reply With Quote
  #4  
Old 17th June 2008, 06:39 AM
johnfitz Offline
Registered User
 
Join Date: Jun 2008
Posts: 8
Quote:
Originally Posted by notageek
Did you start xinetd?

tftp in Fedora is started by xinetd, you'll have to edit the following configuration located here /etc/xinetd.d/tftp and which looks like this

Code:
service tftp
{
   disable        = yes
   socket_type    = dgram
   wait           = yes
   user           = root
   server         = /usr/sbin/in.tftpd
   server_args    = -s /tftpboot
}
change disable=yes to disable=no and start xinetd

Code:
# service xinetd start
(I'm not on my Fedora box or anywhere near a linux box, I may be little off in configuration. Please make sure to use man and refer /usr/share/doc before you try this)
I have checked the tftp file and it is correct but still will not start any other ideas will be gratefully recieved.
Reply With Quote
  #5  
Old 17th June 2008, 08:25 AM
notageek Online
Registered User
 
Join Date: Jan 2008
Location: Bangalore, India
Posts: 2,138
Nope no other ideas.

I tried the following

Code:
# yum install tftp-server
My config file (in /etc/xinetd.d/tftp) looks like this
Code:
service tftp
{
        socket_type             = dgram
        protocol                = udp
        wait                    = yes
        user                    = root
        server                  = /usr/sbin/in.tftpd
        server_args             = -s /var/lib/tftpboot
        disable                 = no
        per_source              = 11
        cps                     = 100 2
        flags                   = IPv4
}
I then started xinetd

Code:
# service xinetd start
I then checked for the service with the following...

Code:
[root@localhost Download]# grep tftp /etc/services 
tftp            69/tcp
tftp            69/udp
tftp-mcast      1758/tcp
tftp-mcast      1758/udp
mtftp           1759/udp        spss-lm
subntbcst_tftp  247/tcp                 # SUBNTBCST_TFTP
subntbcst_tftp  247/udp                 # SUBNTBCST_TFTP
etftp           1818/tcp                # Enhanced Trivial File Transfer Protocol
etftp           1818/udp                # Enhanced Trivial File Transfer Protocol
tftps           3713/tcp                # TFTP over TLS
tftps           3713/udp                # TFTP over TLS

[root@localhost Download]# ps aux |grep tftp
root      2770  0.0  0.0  10480   748 ?        Ss   12:45   0:00 in.tftpd -s /var/lib/tftpboot
root      2787  0.0  0.0  83708   772 pts/0    R+   12:47   0:00 grep tftp

[root@localhost Download]# netstat -pan |grep tftp
unix  2      [ ]         DGRAM                    16957  2770/in.tftpd       

[root@localhost Download]# netstat -pan |grep :69
udp        0      0 0.0.0.0:69                  0.0.0.0:*                               2736/xinetd
And double checked by the following...

Code:
[root@localhost Download]# tftp localhost
tftp> status 
Connected to localhost.localdomain.
Mode: netascii Verbose: off Tracing: off Literal: off
Rexmt-interval: 5 seconds, Max-timeout: 25 seconds

tftp> verbose 
Verbose mode on.

tftp> get install.log
getting from localhost.localdomain:install.log to install.log [netascii]
Received 51481 bytes in 0.1 seconds [2950411 bit/s]

[root@localhost Download]# ll
total 60
-rw-r--r-- 1 root root 50304 2008-06-17 12:51 install.log
Beyond this I don't have any more ideas, perhaps it's be good to check the output of pstree.
__________________
Robot Nite - Designated device drivers drink free

Last edited by notageek; 17th June 2008 at 08:27 AM.
Reply With Quote
  #6  
Old 18th June 2008, 07:00 AM
johnfitz Offline
Registered User
 
Join Date: Jun 2008
Posts: 8
Quote:
Originally Posted by notageek
Nope no other ideas.

I tried the following

Code:
# yum install tftp-server
My config file (in /etc/xinetd.d/tftp) looks like this
Code:
service tftp
{
        socket_type             = dgram
        protocol                = udp
        wait                    = yes
        user                    = root
        server                  = /usr/sbin/in.tftpd
        server_args             = -s /var/lib/tftpboot
        disable                 = no
        per_source              = 11
        cps                     = 100 2
        flags                   = IPv4
}
I then started xinetd

Code:
# service xinetd start
I then checked for the service with the following...

Code:
[root@localhost Download]# grep tftp /etc/services 
tftp            69/tcp
tftp            69/udp
tftp-mcast      1758/tcp
tftp-mcast      1758/udp
mtftp           1759/udp        spss-lm
subntbcst_tftp  247/tcp                 # SUBNTBCST_TFTP
subntbcst_tftp  247/udp                 # SUBNTBCST_TFTP
etftp           1818/tcp                # Enhanced Trivial File Transfer Protocol
etftp           1818/udp                # Enhanced Trivial File Transfer Protocol
tftps           3713/tcp                # TFTP over TLS
tftps           3713/udp                # TFTP over TLS

[root@localhost Download]# ps aux |grep tftp
root      2770  0.0  0.0  10480   748 ?        Ss   12:45   0:00 in.tftpd -s /var/lib/tftpboot
root      2787  0.0  0.0  83708   772 pts/0    R+   12:47   0:00 grep tftp

[root@localhost Download]# netstat -pan |grep tftp
unix  2      [ ]         DGRAM                    16957  2770/in.tftpd       

[root@localhost Download]# netstat -pan |grep :69
udp        0      0 0.0.0.0:69                  0.0.0.0:*                               2736/xinetd
And double checked by the following...

Code:
[root@localhost Download]# tftp localhost
tftp> status 
Connected to localhost.localdomain.
Mode: netascii Verbose: off Tracing: off Literal: off
Rexmt-interval: 5 seconds, Max-timeout: 25 seconds

tftp> verbose 
Verbose mode on.

tftp> get install.log
getting from localhost.localdomain:install.log to install.log [netascii]
Received 51481 bytes in 0.1 seconds [2950411 bit/s]

[root@localhost Download]# ll
total 60
-rw-r--r-- 1 root root 50304 2008-06-17 12:51 install.log
Beyond this I don't have any more ideas, perhaps it's be good to check the output of pstree.
I have checked the setup and have found the following:

[root@localhost Download]# ps aux |grep tftp
root 2770 0.0 0.0 10480 748 ? Ss 12:45 0:00 in.tftpd -s /var/lib/tftpboot
root 2787 0.0 0.0 83708 772 pts/0 R+ 12:47 0:00 grep tftp

When I run the ps aux the is no tftpd running although all the socket definition in /etc/services is correct. Once I start tftp and run the get command then I see in.tftpd in the process stack. Was it the same for you or does the daemon start once xinetd is started? Where is the install.log in /var/lib/tftpboot? On my machine this directory is empty! I tried defining the directory as /tftpboot as this is where Nimol puts the required files. I run the get command there and a file is returned! I also tried an arp -s statement to include the IP / MAC address of the server I am trying to install to.
Reply With Quote
Reply

Tags
start, tftp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't use tftp ACiD GRiM Servers & Networking 4 29th July 2009 12:32 PM
problem with tftp raycome Servers & Networking 1 3rd February 2009 02:44 PM
where is tftp sonicss Servers & Networking 2 30th March 2008 03:18 PM


Current GMT-time: 11:48 (Friday, 22-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat