Fedora Linux Support Community & Resources Center
  #1  
Old 20th June 2008, 01:13 AM
heat84 Offline
Registered User
 
Join Date: May 2008
Posts: 45
Install Firefox 3 on FC5

I have to use that version for school.

I assume FF3 will install on FC5 if I installed a FC5 version of these dependancies:
Missing Dependency: libxul.so is needed by package firefox
Missing Dependency: xulrunner >= 1.9-1.fc9 is needed by package firefox
Missing Dependency: system-bookmarks is needed by package firefox


So does anyone know where I could get a FC 5 version of these dependancies?
Reply With Quote
  #2  
Old 20th June 2008, 01:51 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
On CentOS, rather than drive myself crazy, I just downloaded the tarball from Mozilla.

I untari it in my home directory and after that, can start it wtih ~/firefox/firefox

There's probably rpms somewhere, but I never looked, I just did it as described above.
Reply With Quote
  #3  
Old 20th June 2008, 01:51 AM
muep Offline
Registered User
 
Join Date: Jun 2006
Posts: 123
Fedora Core 5 is dead and unsupported. It hasn't got any security updates for years. Consider installing a newer Linux distribution, especially since the system is most probably connected to the internet, at least at times (Or you wouldn't need FF3 on it).
Reply With Quote
  #4  
Old 20th June 2008, 01:54 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,997
*WHY* would you assume anything modern will install on FC5 ? It's been out of support for over 1yr. and FC3 for 2+yrs. Ancient history - no one cares.

Nobody rational is interested in trying to retry-fit any current sw to anything before FC7 (and FC7 is getting crispy as we speak). If your course requires FC3 - then:

*DO* tell the instructor and administration they need to update.
*DO* install a current (F8, F9) installation in another partition for dual boot.
*DO* use this as a learning experience and try to update the dozen+ libraries needed b y FF/FC3 w/o breaking your "course required" system.
*DONT* blame me when you mess up your FC3 libraries.

Last edited by Seve; 20th June 2008 at 02:04 AM. Reason: language
Reply With Quote
  #5  
Old 20th June 2008, 02:32 AM
marcrblevins Offline
Registered User
 
Join Date: Jun 2006
Location: Texas
Age: 43
Posts: 4,168
Mind telling us what state or country you are from? Maybe a nearby Fedorian wouldn't mind loaning you its Fedora DVD.
Reply With Quote
  #6  
Old 20th June 2008, 03:25 AM
heat84 Offline
Registered User
 
Join Date: May 2008
Posts: 45
I don't need FF3 here. Its not a big deal to use an older version. I was just wondering if I could do it without jumping through too many hoops. I was able to find a version of the REMI package that both FC5 and the FF3 installer like. There aren't any such versions of libxul.so or xulrunner? And also the bookmarks one?

I bet the Windows version of FF3 will install on Windows 98 which is 10 years old. FC 5 is only 2 or 3.
Reply With Quote
  #7  
Old 20th June 2008, 03:53 AM
bws2007 Offline
Registered User
 
Join Date: Jun 2008
Posts: 7
and why are u still running FC5
Reply With Quote
  #8  
Old 20th June 2008, 04:13 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
Quote:
Originally Posted by heat84
I don't need FF3 here. Its not a big deal to use an older version. I was just wondering if I could do it without jumping through too many hoops. I was able to find a version of the REMI package that both FC5 and the FF3 installer like. There aren't any such versions of libxul.so or xulrunner? And also the bookmarks one?

I bet the Windows version of FF3 will install on Windows 98 which is 10 years old. FC 5 is only 2 or 3.
Well, if the FF3 package from Remi's repo installed, are you saying that xulrunner would not? Because that's the package with those prerequisites that are missing. It's in the same repo....

I won't belabor what's already been said about FC3/5 or whatever - if xulrunner doesn't install, you can try disassembling the RPM with an archiver and put the critical libraries wherever they belong.

V
Reply With Quote
  #9  
Old 20th June 2008, 09:43 AM
lazlow Offline
Registered User
 
Join Date: Aug 2005
Posts: 3,172
Heat84

Quote:
I bet the Windows version of FF3 will install on Windows 98 which is 10 years old. FC 5 is only 2 or 3.

You would loose that bet:


http://support.mozilla.com/tiki-view...4873&forumId=1
Reply With Quote
  #10  
Old 21st June 2008, 02:04 AM
bws2007 Offline
Registered User
 
Join Date: Jun 2008
Posts: 7
and then again why are u still running FC5??????
Reply With Quote
  #11  
Old 21st June 2008, 03:58 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
I think that everyone who has asked the OP the question of why does he use Fedora 5 didn't read his post.

I believe he anticipated the question, answering it before asking his own question.
Reply With Quote
  #12  
Old 21st June 2008, 04:06 AM
Wayne
Guest
 
Posts: n/a
It looks like some people are trying to push their post count up without adding anything constructive, or reading the original question

Wayne
Reply With Quote
  #13  
Old 21st June 2008, 05:12 AM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 47
Posts: 3,946
as to fc 5
we had a TA a few weeks/months back who's prof. FORCED the issue ( thinking that fc5 would be the best supported and most stable !! ha,ha,ha)
some profs. can't live with them can't get the grade without them
see
http://forums.fedoraforum.org/showth...light=fedora+5
and heat84 if you are one of those students , i feel sorry for you
hold a "sit in " complain ...
and what course and univ.and who is the prof.
__________________
OpenSUSE 13.1-64bit & Scientific Linux 6.5-64bit ( fedora 4 to 11) and 19/20 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10

Last edited by JohnVV; 21st June 2008 at 05:50 AM.
Reply With Quote
  #14  
Old 21st June 2008, 05:24 AM
hyperspace Offline
Registered User
 
Join Date: Oct 2006
Location: Lincoln, NE
Age: 56
Posts: 414
Quote:
Originally Posted by heat84
I bet the Windows version of FF3 will install on Windows 98 which is 10 years old. FC 5 is only 2 or 3.
What!? Am I in another Universe?
__________________
lost in hypertime...

Registered Linux User #329061
Reply With Quote
  #15  
Old 21st June 2008, 07:46 AM
heat84 Offline
Registered User
 
Join Date: May 2008
Posts: 45
In my case its the school that's not upgrading. The instructor would have no problem upgrading. But for the purposes of the class, FC5 is sufficient I suppose.
Reply With Quote
Reply

Tags
fc5, firefox, install

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
uninstall Firefox 3.5 Beta 4, install Firefox 3.0.11 stable Dillio Using Fedora 4 1st July 2009 08:42 PM
remove firefox 3.5 b and install firefox 3.0.11 marielitag Using Fedora 4 23rd June 2009 07:33 PM
Firefox install vijayasarathy Using Fedora 8 9th June 2009 06:15 AM
Install firefox 1.0.4 borgward Using Fedora 2 29th June 2005 08:48 PM


Current GMT-time: 01:09 (Saturday, 29-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Complex Skatepark - Uchi Houston