Fedora Linux Support Community & Resources Center
  #1  
Old 24th July 2008, 01:01 AM
Mr.Clean Offline
Registered User
 
Join Date: Mar 2008
Posts: 45
Pulse problem - TeamSpeak

I've read the other posts about pulse audio, and I'm still having problems with it.(I'm in FC9 by the way) I can't get any sound drivers to work with a VOIP program called TeamSpeak. I can sometimes here people but can't talk. Has anyone figured out how to get it to work with it?

Last edited by Seve; 24th July 2008 at 02:29 AM. Reason: Added TeamSpeak to Thread Title
Reply With Quote
  #2  
Old 24th July 2008, 07:15 AM
kto Offline
Registered User
 
Join Date: May 2008
Location: Germany
Age: 26
Posts: 166
You should make sure, that your microphone is configured correctly. To do this:
Open the gnome-audio-recorder and the audio-settings dialog (System => Seetings => Hardware => Audio) and try all the options for the microphone and then test them with the audio-recorder.
__________________
Desktop: Intel Core 2 Duo 2.13 GHz, 2 GB RAM, 2.5 TB HDD, GeForce 8600 GTS : Fedora 15 x86_64
Notebook: Dell xps with Intel Core 2 Duo 2.13 GHz, 4 GB RAM, 320 GB HDD , GeForce 8400m GS : Fedora 13 x86_64
Server: Intel Celeron 900 MHz, 128 MB RAM, 20 GB HDD: Debian stable
Reply With Quote
  #3  
Old 24th July 2008, 12:20 PM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
Quote:
Originally Posted by Mr.Clean
I've read the other posts about pulse audio, and I'm still having problems with it.(I'm in FC9 by the way) I can't get any sound drivers to work with a VOIP program called TeamSpeak. I can sometimes here people but can't talk. Has anyone figured out how to get it to work with it?
First of all, TeamSpeak uses the old and deprecated OSS sound API. That in itself is the source for many, many problems with it. Secondly, PA has very, very poor support (and tolerance) for OSS applications. In order for you to use TeamSpeak, you will have to either suspend or kill PulseAudio, which depending on your hardware will render your system to only be able to output sound from TeamSpeak (unless you have figured out an esoteric way to have sound from TeamSpeak working at the same time as other source through ALSA's dmix), and you may see such strange behavior like if you have pidgin opened it will cease producing sounds while TS is running, but as soon as you close TS, all the sounds in the queue from pidgin will rush to the sound card in such a cacophony you'll want to shut your speakers before unleashing the sounds... Other software may complaint about the sound device not being present or available to them in the system (such as Audacious or XMMS, Xine and other multimedia players).

If you are willing to cope with the limitations TS imposes and are willing to stop PA from running when you want to use TS, you may:

Code:
pulseaudio --kill
or
killall -9 pulseaudio
Alternatively, use pasuspender:

Code:
pasuspender /path/to/TeamSpeak
The latter would be the preferred method as it will ensure that PA is restored as soon as you shut down the program you want to run without PA. In the case of TS, if you installed TS through its setup program, you can simply place a launcher in your panel (right click the icon in the Applications - Games menu to place the launcher in the panel), right click the icon in the panel and edit the launcher properties. In the command field, just append pasuspender before the path to TS. Assuming a default install of TS:

Code:
pasuspender /opt/TeamSpeak2RC2/TeamSpeak

NOTE: TS will cause SELinux to go crazy and you may get several notifications from SELinux that TS is trying to do something nasty, you may disable SELinux (at your own risk!) or ignore these warnings. In order to successfully run TS, though you will have to set it to permissive or else it won't run.
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
Reply

Tags
problem, pulse, teamspeak

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F10 Bluetooth Audio + Pulse == pulse crashes. fwelland Hardware & Laptops 2 7th February 2009 01:07 PM
TeamSpeak Mr.Clean Using Fedora 1 16th March 2008 01:15 AM
TeamSpeak segfault, need help MNKyDeth Using Fedora 4 11th April 2006 08:17 PM
FC4 2.6.16-1.2069smp & Teamspeak LouieLouie Using Fedora 0 2nd April 2006 02:11 PM
Teamspeak on 2.6.8 mustangfanatic Using Fedora 2 6th November 2004 10:32 PM


Current GMT-time: 09:04 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Monte Estoril Instagram Photos - Axochiapan Travel Photos on Instagram - Rome Instagram Photos