Fedora Linux Support Community & Resources Center
  #1  
Old 29th July 2008, 02:38 AM
masta Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
EeePC 1000 Fedora 9

Greetings,

I recently purchased the EeePC 1000:

40gb ssd
1gb ram
1.6MHz Intel Atom i686


Because Ubuntu treats users like morons, I prefer to use Fedora 9, despite the fact there seems to be more support for Asus in that user community. So here is a collection of my notes, and issues.


challenges:

1. networking:
# lspci
. . .
01:00.0 Network controller: RaLink Unknown device 0781
03:00.0 Ethernet controller: Attansic Technology Corp. Unknown device 1026 (rev b0)

The stock fedora 9 did not support either Wireless or Ethernet hardware, but fortunately I was able to get my company CDMA card to work, and get the latest software updates online. This would be a big show stopper for most people, freshly installing fedora and not having any networking. My advice is to get a cheap usb-to-ethernet device, or a supported mobile-wireless usb device like I used. Once all the updates to the kernel went in, the Attansic card became functional as ATL1E driver. The wireless driver is still not working which is a RaLink rt2860. I found Linux drivers frm the Ralink website:

http://www.ralinktech.com/ralink/Hom...ort/Linux.html

So far I have been unable to compile the driver. =(
As off this writing I'm using:

2.6.25.11-97.fc9.i686 #1 SMP

libgcc-4.3.0-8.i386
gcc-c++-4.3.0-8.i386
gcc-4.3.0-8.i386
glibc-common-2.8-8.i386
glib2-2.16.5-1.fc9.i386
glib-1.2.10-29.fc9.i386
glibc-devel-2.8-8.i386
glibc-2.8-8.i686
glibmm24-2.16.2-1.fc9.i386
glibc-headers-2.8-8.i386


Has anybody been able to compile this driver? If yes, can I have a copy of your .ko file, or instructions that worked for you to compile?

The insulting thing about all this is that the Linux distro that ships pre-installed with EeePC has working wifi driver, and ethernet. I'm considering to use the ndiswrappers, but I find the idea to be undesirable,, so I'm keeping that as an option of last resort.


The next challenge is ACPI related. After all my system updates completed, I tried to hibernate to the SSD drive, and the screen went black with blinking cursor. I shutdown the system by force (power key), and on the next bootup the system resumed to my previous desktop instance. So it partialy works just not all the way. I suspect the kernel module eeepc_laptop had something to do with that. See you lsmod output for modules.

All in all Im extremely happy with fedora 9 core on the EeePC 1000. The Gnome desktop does not overwhelm the device, and even compiz effects work with snappiness, and efficiency. I prefer to use fluxbox which is more suited for a light-weight laptop environment, and more importantly for 1024x600 desktop display. For example, in gnome you have basic gnome preference panels that are too tall to display in 600 pixels vertical. There is no acceptable method to move the window beyond the top boundary to reach the buttons you must "ok" , or "accept", or even "cancel" at the bottom. This is a major usability problem with Gnome in general, and is why Linus himself advocates users to avoid gnome as I suggest Ubuntu thinks users are morons. Anyways, the important ability Fluxbox provides is the capability to press 'alt+right click' to move/drag the window around when they are too big for the screen to get to the region of window you need. Also fluxbox is more efficient and makes Mozilla browsing better.


I hope this helps other EeePC 1000 and 901 users. Also I hope somebody can assist the 1000/901 community to get RaLink drivers working. =)

cheers,
-masta
Reply With Quote
  #2  
Old 29th July 2008, 03:06 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
The EEE PC uses the AR5007EG card. I'm not sure if the Xandros install uses MadWifi or ndsiwrapper--I think it might be the latter as at least one person I know couldn't connect to a WPA2 network, which has frequently been mentioned in connection with the net5211 driver used with ndiswrapper and that card.

For detaild instructions on getting the wireless working
see
http://home.nyc.rr.com/computertaiju...less.html#5007

NOTE--that page assumes a working internet connection. If running Fedora 9, the livna-testing (note that I said testing) repo might work, which is covered on that page.
Reply With Quote
  #3  
Old 29th July 2008, 03:26 AM
masta Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
Quote:
Originally Posted by scottro
The EEE PC uses the AR5007EG card.
The old EeePC used the Atheros wifi driver, And the NEW EeePC 901/1000 uses the RaLink wifi.

Here is the output from lspci:
. . .
01:00.0 Network controller: RaLink Unknown device 0781
03:00.0 Ethernet controller: Attansic Technology Corp. Unknown device 1026 (rev b0)

Madwifi will not work with non-atheros hardware, but thanks for trying to help scott. =)
Reply With Quote
  #4  
Old 29th July 2008, 03:38 AM
masta Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
Again, the new EeePC uses RaLink rt2860 wifi-b/g/n hardware.
The Ralink drivers are open source, and available here:

http://www.ralinktech.com/ralink/Hom...ort/Linux.html


When I compile the driver, here is the error output:

[root@localhost 2008_0325_RT2860_Linux_STA_v1.6.1.0]# make
make -C tools
make[1]: Entering directory `/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/tools'
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/tools/bin2h
cp -f os/linux/Makefile.6 /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/Makefile
make -C /lib/modules/2.6.25.11-97.fc9.i686/build SUBDIRS=/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux modules
make[1]: Entering directory `/usr/src/kernels/2.6.25.11-97.fc9.i686'
CC [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../common/rtmp_init.o
CC [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.o
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c: In function ‘rt_ioctl_giwscan’:
. . .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1206: error: too few arguments to function ‘iwe_stream_add_event’
. .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1222: error: too few arguments to function ‘iwe_stream_add_point’
. . .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1249: error: too few arguments to function ‘iwe_stream_add_event’
. . .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1269: error: too few arguments to function ‘iwe_stream_add_event’
. . .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1284: error: too few arguments to function ‘iwe_stream_add_event’
. . .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1302: error: too few arguments to function ‘iwe_stream_add_point’
. . .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1332: error: too few arguments to function ‘iwe_stream_add_value’
. . .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1357: error: too few arguments to function ‘iwe_stream_add_point’
. . .
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.c:1378: error: too few arguments to function ‘iwe_stream_add_point’
make[2]: *** [/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.o] Error 1
make[1]: *** [_module_/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.25.11-97.fc9.i686'
make: *** [LINUX] Error 2


I omitted the warnings about invalid cast from pointer with the elipes' but if you want those can be preserved for more verbose readers.
Reply With Quote
  #5  
Old 29th July 2008, 05:02 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
Hrrm, interesting. I missed that the wireless was a Ralink in the first post (I was expecting to see something about wireless in lspci and for some reason, thought both lines were for the wired interface.)

I'm very glad you posted though, I had been considering buying the 900 series. Do you know if the Ubuntu folks have it working, as I might still buy one for my wife to use while traveling? Mandriva probably does, as I think they have had an EEE PC version for awhile.

I've also been looking at the Sylvania Netbook, though the tiny mouse pad seems as if it would be a pain. I've been, so far, unable to find out what card it uses.

It seems to be getting harder and harder to actually find out what hardware a laptop has--even newegg. which I always thought of as Linux friendly, will seldom post more than 802.11 a/b/g/n wlan or the like.
Reply With Quote
  #6  
Old 29th July 2008, 09:09 AM
djselbeck Offline
Registered User
 
Join Date: Jun 2006
Location: Germany
Age: 26
Posts: 61
You could also try using ndiswrapper !? As far as I know it should work with Ralink Cards but is absolutely not the best solution.
Reply With Quote
  #7  
Old 29th July 2008, 01:42 PM
hdp Offline
Registered User
 
Join Date: Jul 2008
Posts: 9
I have an eee 901 (same wireless chipset) and have managed to modify the Ralink driver so that it works. I have tested it with an open network, WEP and WPA2 using Network Manager and it was able to connect to all of them.

The patch is attached, and it needs to be applied to os/linux/sta_ioctl.c

After applying that make sure you follow the instructions in the readme, then it should compile and install cleanly.
Attached Files
File Type: patch sta_ioctl.patch (4.8 KB, 3388 views)
Reply With Quote
  #8  
Old 29th July 2008, 06:09 PM
masta Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
thanks hda (you fixed it)

Quote:
Originally Posted by hdp
The patch is attached, and it needs to be applied to os/linux/sta_ioctl.c

After applying that make sure you follow the instructions in the readme, then it should compile and install cleanly.

HDP:

I read your patch to see what you did, and see the fix is trivial, and pretty much exactly what the warnings/errors tell me. I added "info" to the functions to make it work like you did.

One thing about the patch, it does not apply cleanly, so after applying, on the resulting file on line (aprox) 1380 I simply added "info" as the first parameter, and it compiled clean.


Here is a log of my console for those who might like to read an example of how it should work:


[root@localhost linux]# patch sta_ioctl.c sta_ioctl.patch
patching file sta_ioctl.c
Hunk #1 succeeded at 243 with fuzz 2 (offset 33 lines).
Hunk #2 succeeded at 1172 (offset 97 lines).
Hunk #3 succeeded at 1124 (offset 33 lines).
Hunk #4 succeeded at 1215 (offset 97 lines).
Hunk #5 succeeded at 1171 (offset 33 lines).
Hunk #6 succeeded at 1250 (offset 97 lines).
Hunk #7 succeeded at 1204 (offset 33 lines).
Hunk #8 succeeded at 1296 (offset 97 lines).
Hunk #9 FAILED at 1320.
Hunk #10 FAILED at 1338.
Hunk #11 succeeded at 1259 with fuzz 2 (offset -3 lines).
misordered hunks! output would be garbled
Hunk #12 FAILED at 1359.
3 out of 12 hunks FAILED -- saving rejects to file sta_ioctl.c.rej


[root@localhost 2008_0325_RT2860_Linux_STA_v1.6.1.0]# vi os/linux/sta_ioctl.c
[root@localhost 2008_0325_RT2860_Linux_STA_v1.6.1.0]# make
make -C tools
make[1]: Entering directory
`/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory
`/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/tools'
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/tools/bin2h
cp -f os/linux/Makefile.6
/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/Makefile
make -C /lib/modules/2.6.25.11-97.fc9.i686/build
SUBDIRS=/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux
modules
make[1]: Entering directory `/usr/src/kernels/2.6.25.11-97.fc9.i686'
CC [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../common/rtmp_init.o
CC [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/sta_ioctl.o
CC [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../common/2860_rtmp_init.o
CC [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../os/linux/2860_main_dev.o
CC [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/../../common/cmm_data_2860.o
LD [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/rt2860sta.o
Building modules, stage 2.
MODPOST 1 modules
CC /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/rt2860sta.mod.o
LD [M] /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/rt2860sta.ko
make[1]: Leaving directory `/usr/src/kernels/2.6.25.11-97.fc9.i686'
cp -f /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux/rt2860sta.ko
/tftpboot
[root@localhost 2008_0325_RT2860_Linux_STA_v1.6.1.0]# make install
make -C /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux
-f Makefile.6 install
make[1]: Entering directory
`/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux'
rm -rf /etc/Wireless/RT2860STA
mkdir /etc/Wireless/RT2860STA
cp /home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/RT2860STA.dat
/etc/Wireless/RT2860STA/.
install -d /lib/modules/2.6.25.11-97.fc9.i686/kernel/drivers/net/wireless/
install -m 644 -c rt2860sta.ko
/lib/modules/2.6.25.11-97.fc9.i686/kernel/drivers/net/wireless/
/sbin/depmod -a 2.6.25.11-97.fc9.i686
make[1]: Leaving directory
`/home/diz/build/2008_0325_RT2860_Linux_STA_v1.6.1.0/os/linux'
Reply With Quote
  #9  
Old 29th July 2008, 06:17 PM
hdp Offline
Registered User
 
Join Date: Jul 2008
Posts: 9
You seem to be using an older version of the driver, version 1.7.0.0 is available on the RaLink site, which has some fixes if you can be bothered to compile again.
Reply With Quote
  #10  
Old 29th July 2008, 07:17 PM
masta Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
fixed - part two.

Quote:
Originally Posted by hdp
You seem to be using an older version of the driver, version 1.7.0.0 is available on the RaLink site, which has some fixes if you can be bothered to compile again.

Acknowledged. The 1.70 version patched clean.

After reboot network-manager presents to me AP's and works. Before with 1.60 the network manager did not work.

Thanks HDP!
I'm going to add these steps to my eeepc-901/1000 howto, may I cite you?
Reply With Quote
  #11  
Old 29th July 2008, 07:22 PM
hdp Offline
Registered User
 
Join Date: Jul 2008
Posts: 9
Sure. Have you gotten the special/fn buttons working yet?
Reply With Quote
  #12  
Old 29th July 2008, 07:46 PM
masta Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
Quote:
Originally Posted by hdp
Sure. Have you gotten the special/fn buttons working yet?

Thanks. No I have not made the buttons work yet, but I've noticed acpi began working mysteriously after the ralink driver issue was resolved. So now the only task left is the special buttons.
Reply With Quote
  #13  
Old 29th July 2008, 08:23 PM
masta Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
Quote:
Originally Posted by hdp
Sure. Have you gotten the special/fn buttons working yet?
hdp:

when I use fluxbox instead of gnome, the fn buttons work.


for example, the Fn+F5 (dim) and Fn+F6 (brighten) work.

However, the mute (F10) and volume (F11, and f12 respective) do not work.

I'll see if I can reproduce some of the noob'untu steps.
Reply With Quote
  #14  
Old 29th July 2008, 11:41 PM
masta Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
acpi and buttons.

I can confirm the RaLink driver operates at wireless-N speed.

I'm getting a solid 65Mb/s.

Ever since the RA0 device appeared in ifconfig, acpi hibernate mode started working when I shut the lid.

It would suggest the acpi DSDT needs to be tweaked.

I suspect to get the buttons working we could dump that file and try some modifications.
I'll start working on this now.
Reply With Quote
  #15  
Old 30th July 2008, 12:06 AM
hdp Offline
Registered User
 
Join Date: Jul 2008
Posts: 9
I have most of the buttons working. See: http://fedoraproject.org/wiki/EeePc for more information. The provided scripts needed a few tweaks, I must go to bed now but I can provide what I have done tomorrow.

Fn+F5 and Fn+F6 worked in Gnome for me out of the box as well as suspend, all others had to be configured by me.
Reply With Quote
Reply

Tags
1000, eeepc, fedora

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
EeePC 1000 and FC 10 mickeyboy Hardware & Laptops 3 28th January 2009 12:43 AM
EeePC 1000, after resume brightness controls fail D-Caf Hardware & Laptops 5 27th September 2008 03:10 AM
eeePC 900 Thank you Fedora Team schnullerbacke Hardware & Laptops 4 17th September 2008 04:09 PM
eeepc, fedora 9 and SD card bingoUV Using Fedora 8 3rd August 2008 05:49 PM
eeepc + fedora 8... a power pig karlpiuemeno Hardware & Laptops 0 30th April 2008 12:30 PM


Current GMT-time: 21:31 (Monday, 24-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Managua Photos - Norfolk Photos on Instagram - Krotoszyn