Fedora Linux Support Community & Resources Center
  #1  
Old 14th October 2008, 07:50 PM
Drolyk Offline
Registered User
 
Join Date: Mar 2008
Posts: 33
x11 keyboard layout

Hi All!

I have a problem with switching keyboard layout from 'us' to 'ru'. In system-config-keyboard I choose "Russian". I know that all input devices now handled by hal and not by xorg.conf. Here is relevant part of hal-device output:

Code:
4: udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  info.subsystem = 'input'  (string)
  input.xkb.model = 'pc105'  (string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  input.keymap.data = { 'e001:fn_esc', 'e009:battery', 'e00a:screenlock', 'e00b:camera', 'e00c:media', 'e00e:dvd', 'e031:help', 'e033:f21', 'e057:wlan', 'e008
:player', 'e058:f22', 'e059:f23' } (string list)
  input.xkb.layout = 'us,ru'  (string)
  info.category = 'input'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'  (string)
  input.xkb.options = 'grp:shifts_toggle,grp_led:scroll'  (string)
  input.x11_driver = 'evdev'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio0/input/input5/event5'  (string)
  input.device = '/dev/input/event5'  (string)
  info.callouts.add = { 'hal-setup-keymap', 'fedora-setup-keyboard' } (string list)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  info.capabilities = { 'input', 'input.keyboard', 'input.keypad', 'input.keys', 'input.keymap', 'button' } (string list)
  input.product = 'AT Translated Set 2 keyboard'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  linux.subsystem = 'input'  (string)
  linux.device_file = '/dev/input/event5'  (string)
  input.xkb.rules = 'base'  (string)
According to it layout switch is - "left_shift + right_shift", but it doesn`t work. Also there is no Russian layout in gnome-keyboard-layout-switcher applet.

Does any one have similar problem with x11 layouts ?
  #2  
Old 15th October 2008, 08:12 AM
Drolyk Offline
Registered User
 
Join Date: Mar 2008
Posts: 33
Some more information

For custom xkb setting I put following file in /etc/hal/fdi/policy/ :

$ cat /etc/hal/fdi/policy/x11-input.fdi
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keyboard">
<merge key="input.xkb.layout" type="string">us,ru</merge>
<merge key="input.xkb.options" type="string">grp:alt_shift_toggle,grp_led:scroll</merge>
</match>
</device>
</deviceinfo>

but it works if I disable system-config-keyboard`s hook:

$ sudo chmod -x /usr/bin/fedora-setup-keyboard

But even if hal reports that all settings are fine, I can`t switch keyboard layout to Russian
 

Tags
keyboard, layout, x11

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard layout / keyboard selector simpson0107 Using Fedora 0 26th February 2009 03:43 PM
Keyboard Layout Options per Keyboard sgarrity Hardware & Laptops 0 21st August 2008 02:53 PM
keyboard layout bee Using Fedora 0 26th July 2008 07:57 PM
KDE Keyboard Layout bowens44 Using Fedora 0 9th March 2008 12:37 AM
FC5 - keyboard layout Trek1701 Using Fedora 0 22nd March 2006 02:23 AM


Current GMT-time: 04:13 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Kaya Travel Photos on Instagram - Acheng Photos on Instagram - Likino-Dulevo