Fedora Linux Support Community & Resources Center
  #1  
Old 1st January 2009, 03:13 PM
genitumnonfactu Offline
Registered User
 
Join Date: Dec 2008
Posts: 4
NetworkManager wired network connection "auto" fedora 10

I don't want my computer being connected automatically via DHCP, I want to use a fix IP-address.

The settings of the "auto eth0" connection is not editable with Network-Manager, so I need a hint where to change it manually.

A customised new wired network connection is not very useful, because I have to choose the entry after every login.

Thanks for your help!
Reply With Quote
  #2  
Old 3rd January 2009, 03:37 AM
normyzo Offline
Registered User
 
Join Date: Oct 2004
Posts: 24
Quote:
Originally Posted by genitumnonfactu View Post
I don't want my computer being connected automatically via DHCP, I want to use a fix IP-address.

The settings of the "auto eth0" connection is not editable with Network-Manager, so I need a hint where to change it manually.

A customised new wired network connection is not very useful, because I have to choose the entry after every login.

Thanks for your help!
One way to do this:

1) System -> Administration -> Network

2) Double click on the 'eth0' item in that list

3) Customize the settings, add static IP, etc. Make sure the "Controlled by NetworkManager" box is *checked*.

4) Hit OK

5) Quit Network Configuration, and when it asks if you want to save, say "Yes"

6) Reboot

You should now have a static IP address. If you don't, please attach /etc/sysconfig/network-scripts/ifcfg-eth0 and the output of /var/log/messages. That'll help figure out what went wrong.
Reply With Quote
  #3  
Old 5th January 2009, 09:13 AM
genitumnonfactu Offline
Registered User
 
Join Date: Dec 2008
Posts: 4
Thumbs up

Hi normyzo,

It worked just the way you described it.

I had only two problems:

1. I had to switch off den Network Manager at all by taking it off the start up sequence and to activate network, otherwise the Network Manager always takes over eth0 .

Code:
chkconfig NetworkManager off
chkconfig network on
2. The network Configuration -> Ethernet Device dialog is buggy. If you save your input, the IP-address of the default gateway address is also saved as subnet mask IP. So you can't get the network up correctly. You have to edit the /etc/sysconfig/network-scripts/ifcfg-eth0 manually first.

Raoul from the german fedoraforum helped me detecting these problems:
http://www.fedoraforum.de/viewtopic.php?f=5&t=17119

Thanks a lot! Günter
Reply With Quote
  #4  
Old 5th January 2009, 04:30 PM
Duilio Offline
Registered User
 
Join Date: Sep 2005
Location: Zena
Posts: 47
Quote:
Originally Posted by genitumnonfactu View Post
Hi normyzo,

2. The network Configuration -> Ethernet Device dialog is buggy. If you save your input, the IP-address of the default gateway address is also saved as subnet mask IP. So you can't get the network up correctly. You have to edit the /etc/sysconfig/network-scripts/ifcfg-eth0 manually first.
then
yum update system-config-network
to get the correct version.
Reply With Quote
  #5  
Old 5th January 2009, 04:40 PM
brunson Offline
Registered User
 
Join Date: Jun 2005
Location: Westminster, Colorado
Posts: 2,306
Network manager does support manually setting your IP address.

__________________
Registered Linux User #4837
411th in line to get sued by Micro$oft
Quote:
Basically, to learn Unix you learn to understand and apply a small set of key ideas and achieve expertise by expanding both the set of ideas and your ability to apply them - Paul Murphy
Reply With Quote
  #6  
Old 6th January 2009, 01:57 PM
genitumnonfactu Offline
Registered User
 
Join Date: Dec 2008
Posts: 4
But always uses the auto-eth0 connection, which uses DHCP to get the IP-address.
Reply With Quote
Reply

Tags
networkmanager

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wired network card "unmanaged" KaiTheory Servers & Networking 5 15th July 2010 07:56 AM
Network Manager connects with "auto eth 0" piet85 Servers & Networking 15 2nd July 2009 12:32 PM
Bug Buddy throws "Network Connection Error" in Fedora Core 9 Sorata Using Fedora 0 16th July 2008 11:36 AM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM
"Keep Partitions and Use free space" + "Auto parition" = wipe anything? oldman_420 Installation, Upgrades and Live Media 4 6th May 2005 04:32 AM


Current GMT-time: 13:15 (Friday, 18-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat