Fedora Linux Support Community & Resources Center
  #1  
Old 4th February 2009, 02:31 AM
BravoMike Offline
Registered User
 
Join Date: Feb 2009
Location: Glasgow, Scotland
Posts: 18
Strange Compiz Problem

Hi there guys, new to the forum, Fedora and Gnome

I followed the guide to installing and running Compiz which was very helpful.

I had to use Xorg -configure to make an xorg.conf file to add the hardware acceleration option as I am using the Intel 945GM integrated card but thats all good.

Only problem is, is that when I start Compiz I get this very strange problem.



As you can see, the image is completely distorted and unusable. I did have it working before on Kubuntu and OpenSuse (KDE 3.5.9) but I am bit perplexed as to how to solve this.

Cheers for looking!
__________________
Whiskey and sudo don't mix.
Reply With Quote
  #2  
Old 4th February 2009, 02:46 AM
Demz
Guest
 
Posts: n/a
that looks like a video problem, what Videocard you got?
Reply With Quote
  #3  
Old 4th February 2009, 02:49 AM
BravoMike Offline
Registered User
 
Join Date: Feb 2009
Location: Glasgow, Scotland
Posts: 18
Thanks for the speedy reply!

As I said in my post above its an Intel 945GM integrated chip set, but I below is the pasted output for (what I think) are the relevant sections of lscpi

Code:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
__________________
Whiskey and sudo don't mix.
Reply With Quote
  #4  
Old 4th February 2009, 03:03 AM
Demz
Guest
 
Posts: n/a
i would assume your using the latest intel driver from Xorg? is there an updated intel driver in updates-testing repo?

sorry i over-looked the #1 post an didnt see the video you were using but
Reply With Quote
  #5  
Old 4th February 2009, 03:20 AM
BravoMike Offline
Registered User
 
Join Date: Feb 2009
Location: Glasgow, Scotland
Posts: 18
I am not quite sure which drivers I am using, how would I check?

From this page I can see that the latest drivers are xf86-video-intel-2.5.

You mentioned the repo to install these drivers, how would I go about getting the drivers from this repo? Because the installtion method listed on the above site look complicated....unless I still need to compile the source
__________________
Whiskey and sudo don't mix.
Reply With Quote
  #6  
Old 4th February 2009, 04:18 AM
BravoMike Offline
Registered User
 
Join Date: Feb 2009
Location: Glasgow, Scotland
Posts: 18
UPDATE

I took off my idiot hat and realised that compiling the graphics drivers are no different from any other software.

Started to work on it and have resolved a few dependencies, however I am stuck on libdrm, while running ./configure on the graphics driver I get this error
Code:
Checking for DRM... configure: error: Package requirements (libdrm >= 2.4.3) were not met:

Requested 'libdrm >= 2.4.3' but version of libdrm is 2.4.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DRM_CFLAGS
and DRM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
I input

Code:
yum install *libdrm*
Only to recieve

Code:
Package libdrm-2.4.0-0.21.fc10.i386 already installed and latest version
Package libdrm-devel-2.4.0-0.21.fc10.i386 already installed and latest version
Nothing to do
Obviously this is of no use, so I got libdrm v2.4.4 and compiled it and everything went ok, however I still get that error above while trying to install my graphics driver.

Also, the newest graphics driver is :xf86-video-intel 2.6.0, not 2.5.0 as stated earlier.

Anyone have any ideas how to get this working?
__________________
Whiskey and sudo don't mix.
Reply With Quote
  #7  
Old 5th February 2009, 04:11 AM
BravoMike Offline
Registered User
 
Join Date: Feb 2009
Location: Glasgow, Scotland
Posts: 18
First of all, apologies for triple posting. 150 % more of a faux pas than double posting!

I cant seem to figure out how to replace my existing copy of libdrm (2.4.0) with the one that is needed (>=2.4.3).

Im too tired to work it out, so I'm going to wait until I cant get my hands on a Fedora 11 copy as it seems like it comes bundled with libdrm 2.4.3.

I know its not the right mentallity, to just leave it till someone else fixes it. But I'm too sick and tired of trying to get the fscking backward assed integrated graphics card to work on linux correctly.

Cheers for the help Demz!

See you guys on the forum
__________________
Whiskey and sudo don't mix.
Reply With Quote
  #8  
Old 5th February 2009, 04:18 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,291
I would recommend that you not compile the Intel drivers, since the "stock" Fedora stuff is very up-to-date, and you'll be forever updating due to the rapid development of Intel stuff at X.Org/DRI. Still: it can be a fun learning experience.

Have you searched these forums? I recall many Intel video problems mentioned....

V
Reply With Quote
  #9  
Old 5th February 2009, 08:36 AM
Demz
Guest
 
Posts: n/a
i happen to disagree with Hlinger,

compiling your own intel drivers is a good learning curve, if you do a good job of compiling them report back in the forum what you did an how you did it so others can learn from it
Reply With Quote
  #10  
Old 9th February 2009, 01:08 PM
BravoMike Offline
Registered User
 
Join Date: Feb 2009
Location: Glasgow, Scotland
Posts: 18
Sorry to resurrect a dead thread. But I really cant get my head around this libdrm problem.

Its made me wonder, do you really think that its a problem with the graphics drivers?

I had compiz working fine in openSuse with KDE 3.5 and Kubuntu with KDE 3.5 and 4.1. Also the "Desktop Effects" switch worked fine when I first booted Fedora 10, I just felt that it was a little limited as I couldnt use the CCSM so I started a fresh install, which has put me in this mess
__________________
Whiskey and sudo don't mix.
Reply With Quote
  #11  
Old 9th February 2009, 02:40 PM
leigh123linux Online
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,375
Have you tried adding these options to xorg.conf ?


xorg.conf options for the intel, nv, radeon & radeonhd drivers ( should help graphics lag and CPU load )

add to the device section



Code:
         Option          "AccelMethod" "EXA"  
         Option          "MigrationHeuristic" "greedy"
__________________
https://admin.fedoraproject.org/pkgdb/users/packages/leigh123linux

https://badges.fedoraproject.org/user/leigh123linux
Reply With Quote
  #12  
Old 10th February 2009, 11:22 AM
BravoMike Offline
Registered User
 
Join Date: Feb 2009
Location: Glasgow, Scotland
Posts: 18
Here is my Xorg.conf file here

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "catalogue:/etc/X11/fontpath.d"
	FontPath     "built-ins"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "dri"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "CacheLines"         	# <i>
        #Option     "Dac6Bit"            	# [<bool>]
        #Option     "DRI"                	# [<bool>]
        #Option     "NoDDC"              	# [<bool>]
        #Option     "ShowCache"          	# [<bool>]
        #Option     "XvMCSurfaces"       	# <i>
        #Option     "PageFlip"           	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
	BusID       "PCI:0:2:0"
        Option      "AccelMethod" "EXA"  
        Option      "MigrationHeuristic" "greedy"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
As you can see, I have already added those lines. In fact I followed your very helpful guide on installing fedora which is when this problem started.

I am considering uninstalling everything to do with compiz and just starting again, don't know if it will help though =/

[Edit] The xorg file was automatically generated with Xorg --configure so I dont think its quite right for my system yet
__________________
Whiskey and sudo don't mix.
Reply With Quote
  #13  
Old 10th February 2009, 11:36 AM
leigh123linux Online
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,375
Try setting the default depth to 24 bit , compiz needs 24 bit depth to work.



i.e



Code:
Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
__________________
https://admin.fedoraproject.org/pkgdb/users/packages/leigh123linux

https://badges.fedoraproject.org/user/leigh123linux
Reply With Quote
  #14  
Old 10th February 2009, 10:56 PM
BravoMike Offline
Registered User
 
Join Date: Feb 2009
Location: Glasgow, Scotland
Posts: 18
Thanks for the reply, I tried adding that line into my xorg.conf which did nothing as far as I can see.

As an experiment, I undid the steps which I took in the guide which you posted, and then installed the compiz packages the come as standard with the installation.

So now compiz was being controlled by the "Desktop Effects" program, you know the small window that gives 2 options and an enable desktop effects button. Im sure it has a name but I cant remember :/

I digress, I reverted back to that setup and it still doesnt work. The only thing I can think of that has changed is that I am using this auto generated xorg.conf file.

It makes me think that the problem is in there, other than the fact that it doesnt list any resolutions in the screen section I cant see anything wrong.
__________________
Whiskey and sudo don't mix.
Reply With Quote
  #15  
Old 10th February 2009, 11:22 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,291
You must re-start the X11 server after making such edits to xorg.conf. Did you do so?

V
Reply With Quote
Reply

Tags
compiz, compiz fusion, distortion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange GNOME compiz problem with AWN - compiz-gtk? jeffers_uk Using Fedora 1 19th March 2009 08:32 PM
SMB file transfer performance. Strange strange strange geekboxnz Using Fedora 0 11th February 2006 08:55 AM


Current GMT-time: 22:54 (Tuesday, 29-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat