Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 3rd March 2009, 02:24 PM
jannom Offline
Registered User
 
Join Date: Mar 2009
Posts: 10
Keyboard input missing after today's Fedora (ver .10) update

Hello

I applied all today's patches (18 of them) and Fedora asked me to log out/log on after the completion of update.
But after logon, in 2 programs (KeePassX and Oracles Sql Developer) there is not possible to use keyboard! Mouse is still functioning within them, but not keyboard. No ENTER, no arrow keys, no characters.

Has anyone else encountered same problems with todays updates and how to fix it?

Janno
Reply With Quote
  #2  
Old 3rd March 2009, 02:57 PM
jannom Offline
Registered User
 
Join Date: Mar 2009
Posts: 10
Seems like thing called SCIM has appeared (with today's update?) in my system and now trying to manage keyboard input-system.
After I disabled it

System → Preferences → Personal → Input Method to enable or disable SCIM

then KeepassX resumed its normal work, I mean, I can use keyboard with it now. But in SQL Developer, only characyter keys function (at least that is better then previously, when nothing accepted input), but not ENTER or arrow-keys.

Should I completle uninstall SCIM to resume normal work with keyboard?
Reply With Quote
  #3  
Old 3rd March 2009, 03:09 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 485
You are not alone. xemacs has completely lost keyboard focus since a recent update. I am just now investigating your suggestions on SCIM.
Reply With Quote
  #4  
Old 3rd March 2009, 03:36 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 485
Well this is rather bizarre. The input method was not enabled so I tried enabling it but no joy. So I disabled it again and now xemacs seems to get keyboard focus, but not reliably. After working a bit everything seems to map to down.
Reply With Quote
  #5  
Old 3rd March 2009, 03:38 PM
Muspellsson Offline
Registered User
 
Join Date: Mar 2009
Location: Russia, Pereslavl-Zalessky
Posts: 10
I have problem with keyboard in SDL apps
Reply With Quote
  #6  
Old 3rd March 2009, 03:39 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 485
Ok, that seems to be because the keyboard buffer is not being flushed when it should be.
Reply With Quote
  #7  
Old 3rd March 2009, 03:43 PM
jmvidal Offline
Registered User
 
Join Date: Mar 2009
Posts: 6
xemacs now working

I figured out one way to get xemacs working (for me)

1- System->preferences->personal->input method
there click on "enable input method feature" and
"Show the status icon"
then click OK
2- An icon will show up in the task bar. Click on this icon to "disconnect from the SCIM"

now xemacs works.
Reply With Quote
  #8  
Old 3rd March 2009, 03:49 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 485
Looking though my yum log nothing with scim has been updated for a while. Personally I suspect xorg-x11-drv-evdev-2.1.3-1.fc10.i386 or xorg-x11-drv-vmmouse-12.6.3-3.fc10.i386
Reply With Quote
  #9  
Old 3rd March 2009, 03:53 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 485
jmvidal, have you tried filling the keyboard buffer? Just keep your finger on the down arrow key until the cursor reaches the bottom of the buffer and then hold it for a few seconds longer.
Reply With Quote
  #10  
Old 3rd March 2009, 03:59 PM
jmvidal Offline
Registered User
 
Join Date: Mar 2009
Posts: 6
Quote:
Originally Posted by kldixon View Post
jmvidal, have you tried filling the keyboard buffer? Just keep your finger on the down arrow key until the cursor reaches the bottom of the buffer and then hold it for a few seconds longer.
Not sure what you mean by this.

I turned clicked on the icon to "connect to input method". If I then go to a terminal window and press the down key I just get beeping from the computer. If I go to the xemacs window and press and hold the down key, nothing happens.
Reply With Quote
  #11  
Old 3rd March 2009, 04:11 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 485
Do your cursor keys still work in the xemacs window?
Reply With Quote
  #12  
Old 3rd March 2009, 04:17 PM
jmvidal Offline
Registered User
 
Join Date: Mar 2009
Posts: 6
Quote:
Originally Posted by kldixon View Post
Do your cursor keys still work in the xemacs window?
Yes, the arrow keys still work.

Also, something just happened (I think I tried to maximize xemacs) where the IM chooser died (the icon is gone) and I had to kill xemacs because it disappeared. I restarted xemacs and it still gets keyboard input, but the IM chooser has "Enable input methos feature" NOT enabled.
Reply With Quote
  #13  
Old 3rd March 2009, 04:25 PM
jannom Offline
Registered User
 
Join Date: Mar 2009
Posts: 10
I grepped through my log and found this :

# grep -i scim yum.log
Jan 13 11:21:04 Updated: scim-chewing-0.3.3-0.fc10.i386
Feb 03 12:37:56 Updated: scim-anthy-1.2.7-1.fc10.i386

so, today "scim-anthy-1.2.7-1.fc10.i386" got updated. Maybe that is the culprit.

And still my arrow keys and ENTER does not function in Sql Developer, although I tried several SCIM configurations.

Jmvidal, what do you mean by "disconnect from the SCIM"?
Reply With Quote
  #14  
Old 3rd March 2009, 04:26 PM
jannom Offline
Registered User
 
Join Date: Mar 2009
Posts: 10
Sorry! today is not Feb 3, but already March.
So, that log-trace does not give us much.
Reply With Quote
  #15  
Old 3rd March 2009, 04:29 PM
kldixon Offline
Registered User
 
Join Date: Aug 2005
Posts: 485
When I did what you suggested in post #7 and xemacs seemed to work I scrolled down to the bottom of a directory buffer in xemacs using the down arrow key and then tried to move back up with the up arrow but the cursor did not move. So I positioned the cursor with the mouse and thereafter any keystroke just moved the cursor down. My hypothesis in comment #6 was that the keyboard buffer was not flushed when the cursor hit the bottom of the xemacs buffer and so was full of down characters which were read whenever a keyboard event was seen by xemacs.
Reply With Quote
Reply

Tags
fedora, input, keyboard, missing, today, update, ver

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Today's update / FC10/KDE Popeye Using Fedora 3 6th February 2009 12:21 AM
how do i enable chinese input keyboard on fedora 9? vitasoy Using Fedora 1 9th September 2008 04:50 PM
today's F9 update fails badly, anyone else? marko Alpha - Beta (Fedora 9 Only) 29 24th May 2008 02:45 AM
Missing keyboard in Fedora Core 5 install dasphoebus Installation, Upgrades and Live Media 4 13th July 2006 01:53 PM


Current GMT-time: 21:17 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Jackson Photos - Winter Haven Travel Photos - Gauting