Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #61  
Old 5th March 2009, 04:05 PM
bms270 Offline
Registered User
 
Join Date: Mar 2009
Posts: 13
Please DO NOT change the topic. we need to be able to follow the keyboard issue here. you can always post your kernel issue in a new post. Thanks.
Reply With Quote
  #62  
Old 5th March 2009, 04:09 PM
nicholas.urfe Offline
Registered User
 
Join Date: Apr 2008
Posts: 46
Quote:
Originally Posted by bms270 View Post
Please DO NOT change the topic. we need to be able to follow the keyboard issue here. you can always post your kernel issue in a new post. Thanks.
Sorry. I agree with you, completely.
Reply With Quote
  #63  
Old 5th March 2009, 05:14 PM
leigh123linux
Guest
 
Posts: n/a
Here's another relevant report.




https://bugzilla.redhat.com/show_bug.cgi?id=488083
Reply With Quote
  #64  
Old 5th March 2009, 05:33 PM
Dan Online
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 23,267
Grrrrr!

Update applied ... Nedit still borked!
Reply With Quote
  #65  
Old 5th March 2009, 05:53 PM
bms270 Offline
Registered User
 
Join Date: Mar 2009
Posts: 13
I just got a new update for libgxim-0.3.2-4.fc10.i386 and after the reboot so far so good! but still too early to say for sure because the bug comes up after a while. I had issues in Opera and Intellij Idea (java IDE) and now both are working fine. I will update later of my status.
Reply With Quote
  #66  
Old 5th March 2009, 05:57 PM
bms270 Offline
Registered User
 
Join Date: Mar 2009
Posts: 13
Quote:
Originally Posted by leigh123@linux View Post
Hey Thanks, I see they just updated the BUG. so I have to wait a while and test this new update. I will update the bug in bugzilla after thoroughly testing this today's update:

libgxim-0.3.2-4.fc10.i386

and here's other updates I received today, not sure if they are related to this issue or not:

fftw-3.2.1-1.fc10.i386
libgxim-0.3.2-4.fc10.i386
rsibreak-0.9.0-10.fc10.i386
xorg-x11-drv-synaptics-0.15.2-4.fc10.i386

Thanks
Reply With Quote
  #67  
Old 5th March 2009, 06:14 PM
SA365 Offline
Registered User
 
Join Date: Nov 2007
Posts: 8
Quote:
Originally Posted by PatMcLJr View Post
Here, try this, it worked for me

http://forums.fedoraforum.org/showthread.php?t=215734

Best of Luck,
Pat Jr.
Hello PatMcLJr

Thank you for bringing me on the right track
Changing to i386 version of opera (opera-9.64.gcc4-qt4.i386.rpm) solved my problem!

Any idea what's causing this?
Note also the working package is qt4 as opposed to qt3 in the x86_64 package..

Best regards
Ivar
Reply With Quote
  #68  
Old 5th March 2009, 06:44 PM
bms270 Offline
Registered User
 
Join Date: Mar 2009
Posts: 13
Hi,

Bad News: Test of the new update FAILED! The issue is back on my Intellij Idea (Java IDE). as I type the keyboard buffer gets messed up. it runs a few keys behind what I type. and to synch it up I have to keep pressing "esc" to see what I have been typing!

The Opera is still working fine though.

Thanks
Reply With Quote
  #69  
Old 6th March 2009, 04:48 PM
bms270 Offline
Registered User
 
Join Date: Mar 2009
Posts: 13
Another BAD NEWS:

The issue is back on Opera as well. Not sure where to complain about this. Any suggestions?

Thanks,

P.S Is there anyway to rollback all the upodates to for example a week ago?
Reply With Quote
  #70  
Old 6th March 2009, 05:12 PM
Dan Online
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 23,267
Update:

After a reboot (necessitated by an unbelievable amount of dust and dirt in the power supply and the CPU heatsink) Nedit is now functional again.

Fedora! Install, strap in, hang on tight ... then update!

You've just got to enjoy the ride. <....>
Reply With Quote
  #71  
Old 20th March 2009, 09:03 PM
kyuso Offline
Registered User
 
Join Date: Jul 2004
Posts: 212
So the keyboard input issue hasn't been solved yet?

I have similar issues and I have done all possible solutions posted in this thread (libgxim-0.3.2-4 + reboot, nohpet in grub, etc.) and the only partial solution seems to be to quit scim.

Before exiting scim

My problem involves xterm and wine, where keyboard input is not responding in xterm and in some games running wine, like Halo or Tomb Raider 3, but Red Alert and Tomb Raider 2 works flawlessly (except that Tomb Raider 2 movie stops at first frame so I have to press ESC to make the game move to next stage.)

If I run vavoom in xterm and it exits, xterm consistently loses key input afterwards. Maybe this will be a good starting point for debugging.

There is a workaround in xterm, where if I move the mouse to another window to focus key event to it, keyboard works, and moving mouse back to xterm makes the keyboard work there too. For wine running Red Alert 2, keyboard comes back after initial movie is finished and game menu appears. For Halo, key input never works.

I also found that no matter what, all gnome window manager key combination works (Alt-F7, Alt-TAB, etc.) It also makes keyboard work again in xterm, but never in wine running Halo (although I can still move its window with arrow keys after Alt-F7.)

After exiting scim

If I exit scim, all open xterms cannot receive any key input (Alt-F7 etc. still works though), but when a new xterm is run, the new xterm always works whether running vavoom or otherwise. Halo with wine still doesn't receive ESC key during movie but the key input works after the game menu appears, and Tomb Raider 3 key input now works from the beginning (movie stalling in Tomb Raider 2 is not fixed and may not be related.)

And scim always restarts automatically after manual exit, so I don't lose scim, except no xterm will have scim access anymore. But that's ok for now. BTW, the option of disconnecting input method wasn't any better (actually worse since scim is now off, on top of existing xterm never receiving any normal key input.)

At least I have almost a solution, but I hope the real problem gets solved, since I have to make a choice of either giving up scim in xterm or being annoyed with xterm and no Halo.

Last edited by kyuso; 20th March 2009 at 09:24 PM.
Reply With Quote
  #72  
Old 21st March 2009, 12:01 AM
kyuso Offline
Registered User
 
Join Date: Jul 2004
Posts: 212
I find that there are regressions due to the new update of libgxim-0.3.2-4 which causes problems with xterm:

https://bugzilla.redhat.com/show_bug.cgi?id=488773
https://bugzilla.redhat.com/show_bug.cgi?id=488777

I also found that gnome session preferences show that there are two copies of 'IMSettings Applet' enabled in session preferences startup programs, one with and one without '--disable-xsettings'. I wonder if this may cause problems, although I only see one process with '--disable-xsettings' running.

Anyway, guess I'll have to wait for xterm to be fixed or start learning to like gnome-terminal.

Update: I finally found what font xterm was using (MiscFixed 10) so I used the same font in gnome-terminal. Now I have no reason to use xterm anymore. Wine games executed from gnome-terminal has no problem. It was xterm that was the culprit. Case closed for me.

Last edited by kyuso; 21st March 2009 at 12:26 AM. Reason: new info
Reply With Quote
  #73  
Old 25th March 2009, 10:06 PM
SDGathman Offline
Registered User
 
Join Date: Sep 2006
Posts: 21
gnome-terminal screws up fkeys

Quote:
Originally Posted by kyuso View Post
I find that there are regressions due to the new update of libgxim-0.3.2-4 which causes problems with xterm:

Anyway, guess I'll have to wait for xterm to be fixed or start learning to like gnome-terminal.

Update: I finally found what font xterm was using (MiscFixed 10) so I used the same font in gnome-terminal. Now I have no reason to use xterm anymore. Wine games executed from gnome-terminal has no problem. It was xterm that was the culprit. Case closed for me.
gnome-terminal is unusable for me because it captures Fkeys. F10 can be released in the config, but F1 is tied to help. Legacy applications depend on Fkeys. It is also annoying that gnome-terminal sends completely different escape sequences for the keys it does implement than xterm. This requires a special terminal type to use gnome-terminal with legacy apps (and that assigns some lame alternate for "F1").
Reply With Quote
  #74  
Old 25th March 2009, 11:55 PM
dschornack Offline
Registered User
 
Join Date: Aug 2008
Posts: 18
Dead applications after latest Fedora (ver 10) update

Yes, I took the update and yes I am having lots of problems. KeePassX will not open. Netbeans 6.5.1, SQL Developer will not display. The applications are running if you look at the system monitor. I have to kill them to get rid of them. Today, I could not even click on any icon on the desktop. My work around so far has been to shutdown the machine and wait a few minutes, restart and cross my fingers that I get the magically bug report. When I click on KeePassX after a reboot and I get a bugreport, everything starts working again. Here is what was updated on my system yesterday ...

selinux-policy-3.5.13-49.fc10.noarch
selinux-policy-targeted-3.5.13-49.fc10.noarch
1:java-1.6.0-openjdk-javadoc.1.6.0.0-11.b14.fc10.i386
libX11.1.1.5.1.fc10.i386
1:java-1.6.0-openjdk-1.6.0.0-11.b15.fc10.i386
gtk2-2.14.7-7.fc10.i386
lcms-libs-1.18-1.fc10.i386
ffmpeg-libs-0.4.9-0.55.20080908.fc10.i386
postgresql-libs-.8.3.7-1.fc10.i386
lcms-1.18-1.fc10.i386
1:java-1.6.0-openjdk-plugin-1.6.0.0-11.b14.fc10.i386
1:java.1.6.0-openjdk-devel-1.6.0.0-11.b14.fc10.i386
keepassx-0.3.4-3.fc10.i386
xorg-x11-drv-vesa-2.2.0-3.fc10.i386
libX11-devel-1.1.5-1.fc10.i836
1:java-1.6.0-openjdk-src-1.6.0.0-11.b14.fc10.i386
gtk2-devel-2.14.7-7.fc10.i386

I have attached the bug report and it looks like the problem is in libX11 which was updated yesterday. Let me know if the file does not get attached.

Please, please test before you release. This is now the 3rd major problem since Fedora 10 was released. I had no problems like this with Fedora 7, 8, or 9. What gives with 10?

David
Reply With Quote
Reply

Tags
fedora, input, keyboard, missing, today, update, ver

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Today's update / FC10/KDE Popeye Using Fedora 3 6th February 2009 12:21 AM
how do i enable chinese input keyboard on fedora 9? vitasoy Using Fedora 1 9th September 2008 04:50 PM
today's F9 update fails badly, anyone else? marko Alpha - Beta (Fedora 9 Only) 29 24th May 2008 02:45 AM
Missing keyboard in Fedora Core 5 install dasphoebus Installation, Upgrades and Live Media 4 13th July 2006 01:53 PM


Current GMT-time: 23:46 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat