Fedora Linux Support Community & Resources Center
  #1  
Old 14th March 2009, 02:55 AM
juanfgs Offline
Registered User
 
Join Date: Mar 2008
Location: Entre Rios, Argentina
Posts: 166
Keyboard lag on Wine and native games

Hello, it's been a while since I posted here :P.

I'm having a strange issue since I upgraded my PC hardware, on some games after playing from a while the keyboards starts lagging (with a lot of lag ). However if I quit the game the lag stops immediatelly (no lag on the command line or GUI) and I can restart the game normally.
For example today I've finished playing Quake 4 (almost during an hour) without a problem but I started Quake Wars and before even finishing a match it started lagging like crazy.
This seems to be happening more often when I play a game through wine than native games .

I don't know if the upgrades that I did to the PC may be causing this problem(or maybe there is bug on the new hardware's drivers) but I'll list them here:

Before:
Motherboard:NF61SM2 Biostar (chipset Nforce)
RAM: 1GB
Monitor: Samsung SyncMaster 796MB

After:
Motherboard: N61PB-M2S Biostar (chipset NForce)
RAM: 2GB (2 banks of 1 GB at 800Mhz)
Monitor: FLATRON L177WS LG (this is highly unlikely to cause the problem)

I didn't change the Processor, it's a AMD 64 3800+ Dual Core, I'm running an up to date i386 Fedora 10 installation.

Thank you in advance.
__________________
I'm back... again...

Last edited by juanfgs; 14th March 2009 at 02:57 AM.
Reply With Quote
  #2  
Old 15th March 2009, 04:09 AM
tparker Offline
Registered User
 
Join Date: Feb 2009
Posts: 88
Did you re-install the OS and games or move your old harddrive to the new system unchanged?
Reply With Quote
  #3  
Old 16th March 2009, 12:29 PM
juanfgs Offline
Registered User
 
Join Date: Mar 2008
Location: Entre Rios, Argentina
Posts: 166
I didn't reinstall, I usually work on this computer too, so I don't reinstall to often. However everything else works OK
__________________
I'm back... again...
Reply With Quote
  #4  
Old 16th March 2009, 04:31 PM
tparker Offline
Registered User
 
Join Date: Feb 2009
Posts: 88
Do you have SCIM enabled? It can mess up keyboard input through wine. (In case you need it: System>Preferences>Personal> 'something about input or keyboard', sorry I deleted all of SCIM so I can't see the wording anymore )

Also some versions of libgxim can cause input problems, I didn't need it for anything so I deleted it (SCIM is one thing that uses it). If you have something else that needs libgxim just be sure you are not using 0.3.2-4, 0.3.1-anything should not have the lag issue. (the command to check what version you have is: rpm -q libgxim )

No promises, but those two fix my keyboard lag and insanity issues, might be worth checking.
Reply With Quote
  #5  
Old 16th March 2009, 04:44 PM
juanfgs Offline
Registered User
 
Join Date: Mar 2008
Location: Entre Rios, Argentina
Posts: 166
Quote:
Originally Posted by tparker View Post
Do you have SCIM enabled? It can mess up keyboard input through wine. (In case you need it: System>Preferences>Personal> 'something about input or keyboard', sorry I deleted all of SCIM so I can't see the wording anymore )

Also some versions of libgxim can cause input problems, I didn't need it for anything so I deleted it (SCIM is one thing that uses it). If you have something else that needs libgxim just be sure you are not using 0.3.2-4, 0.3.1-anything should not have the lag issue. (the command to check what version you have is: rpm -q libgxim )

No promises, but those two fix my keyboard lag and insanity issues, might be worth checking.
SCIM seems to be disabled, I'll try to remove libgxim as you say


Thanks, I'll let you know if it worked.
__________________
I'm back... again...
Reply With Quote
  #6  
Old 16th March 2009, 04:55 PM
aleph Offline
Banned (for/from) behaving just like everybody else!
 
Join Date: Jul 2007
Location: Nanjing, China
Posts: 1,332
Well, since it's Wine, any strange behavior should be "expected"

Did you configured Wine so that it bypasses the native window manager? If so, try using your native WM: in Wine settings (winecfg) -> Graphics -> "Allow the window manager to decorate the windows" and "Allow the window manager to control the windows". I've had problems with Warcraft III's keyboard control under Wine and this seemed to do.
__________________
Code:
from rlyeh import cthulhu
cthulhu.fhtagn()
Reply With Quote
  #7  
Old 16th March 2009, 05:04 PM
juanfgs Offline
Registered User
 
Join Date: Mar 2008
Location: Entre Rios, Argentina
Posts: 166
Quote:
Originally Posted by aleph View Post
Well, since it's Wine, any strange behavior should be "expected"

Did you configured Wine so that it bypasses the native window manager? If so, try using your native WM: in Wine settings (winecfg) -> Graphics -> "Allow the window manager to decorate the windows" and "Allow the window manager to control the windows". I've had problems with Warcraft III's keyboard control under Wine and this seemed to do.
It's not only on wine but also on native games too. I'm starting to think it has something to do with the CPU load as it doesn't happen until I've played for a while (and more often on CPU intensive games).
__________________
I'm back... again...
Reply With Quote
  #8  
Old 17th March 2009, 02:56 AM
aleph Offline
Banned (for/from) behaving just like everybody else!
 
Join Date: Jul 2007
Location: Nanjing, China
Posts: 1,332
if it's happening everywhere, probably it's an X problem.

The recent updates of the Xorg X11 server has a lot of buzzing about keyboards... Just guessing it's related to your problem.
__________________
Code:
from rlyeh import cthulhu
cthulhu.fhtagn()
Reply With Quote
  #9  
Old 17th March 2009, 08:05 PM
giant03 Offline
Registered User
 
Join Date: Mar 2009
Posts: 1
I was having the same problem as juanfgs and tried removing SCIM and the libgxim as suggested by tparker. I seemed to work as I had no issues with it last night with keyboard lag. Thanks for the fix!

Now if I could only get rid of the lag in game from switching workspaces...
Reply With Quote
  #10  
Old 17th March 2009, 08:19 PM
juanfgs Offline
Registered User
 
Join Date: Mar 2008
Location: Entre Rios, Argentina
Posts: 166
I forgot to try that one , I'll uninstall libgxim now
__________________
I'm back... again...
Reply With Quote
  #11  
Old 19th March 2009, 04:24 PM
juanfgs Offline
Registered User
 
Join Date: Mar 2008
Location: Entre Rios, Argentina
Posts: 166
It worked, last night I could play S.T.A.L.K.E.R. (on wine) for a couple of hours without a problem.
Thanks!
__________________
I'm back... again...
Reply With Quote
Reply

Tags
games, keyboard, lag, native, wine

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi Wine help using games. 2. Lascolb Gamers' Lounge 57 12th January 2008 05:45 AM
ATI and Wine and Games... mbtigger Gamers' Lounge 0 18th December 2007 09:30 PM
Top native linux games on live DVD schwim Gamers' Lounge 7 17th September 2007 03:51 AM
Linux games - Native and Wine-emulated johny Links 0 27th June 2005 05:43 PM
Where to buy native linux games? Detour Linux Chat 5 8th March 2005 04:21 AM


Current GMT-time: 22:24 (Wednesday, 20-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat