Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 21st April 2009, 07:34 AM
EdHsieh Offline
Registered User
 
Join Date: Apr 2009
Posts: 5
How to make the configuration saved in .gconf/desktop/gnome/screen work?

I found Fedora9's gnome-display-properties using unstable APIs and saving the configuration in .gnome2/monitors.xml. However, this scheme can't work when multiple screens. My screen 1 is for usbvga. How to make the configuration saved in .gconf/desktop/gnome/screen work?
Reply With Quote
  #2  
Old 21st April 2009, 08:17 AM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hello:
I'm not sure I understand what you are asking ?

Usually, display properties, other than the default(s) are dictated by the driver you have installed, your hardware and the content of your /etc/X11/xorg.conf

Then again I could be completely wrong.


Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #3  
Old 21st April 2009, 08:40 AM
EdHsieh Offline
Registered User
 
Join Date: Apr 2009
Posts: 5
I am developing a usbvga driver that supports RANDR. Normally a usbvga occupies screen 1.
"gnome-display-properties" of ver 2.22 can manipulate the resolutions of all screens in the run time, but it cannot remember the settings after restarting X. It saved the setting in .gconf/desktop/gnome/screen

In FC9, the default gnome-display-properties has been modified and does not work when multiple screens. Only screen 0 can be adjusted, and it can keep the setting. It saved the setting in .gnome2/monitors.xml. It is the same with FC10 that equipped gnome-display-properties of ver 2.24.

I want to know how to enable the gconf's setting instead of that in .gnome2
Reply With Quote
  #4  
Old 5th May 2009, 08:14 AM
EdHsieh Offline
Registered User
 
Join Date: Apr 2009
Posts: 5
The answer is "gnome-control-center" needs a corresponding "gnome-settings-daemon." If gnome-display-property of ver 2.22 is applied, gnome-settings-daemon of ver 2.22 is required to keep the configuration after restarting.
Reply With Quote
Reply

Tags
gconf, gnome-display-properties, usbvga

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome - login screen - make changes akvino Using Fedora 9 29th January 2009 11:03 AM
Gconf Error: Black Screen and Icon only in desktop. DOBius Using Fedora 2 12th May 2008 01:20 PM
Desktop resolution doesn't match either xorg.conf or gconf desktop settings markitz Hardware & Laptops 1 16th May 2006 11:15 AM
Please check your GConf configuration... Ritariassa Using Fedora 1 19th February 2006 03:46 PM


Current GMT-time: 19:01 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat