Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > The Dungeon > Archived (Click Header To See Sub-Forums) > Alpha, Beta & Snapshots Discussions (Fedora 11 Only)
FedoraForum Search

Forgot Password? Join Us!

Alpha, Beta & Snapshots Discussions (Fedora 11 Only) Post Development Version comments and questions that don't belong in Bugzilla here. These posts will be moved or deleted once the Final version is released

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 4th May 2009, 05:15 PM
gletscher Offline
Registered User
 
Join Date: May 2009
Posts: 8
Touchpad tapping doesn't work in F11 Preview

I just tried the F11 Preview and it's the most polished KDE4 distribution out there. I am amazed, good job!!

However tapping on the touchpad doesn't work, meaning I actually have to use the clicker for every single click I do, and for scrolling, too. I so would switch to fedora, but this is too annoying. I read somewhere that the new XOrg handles input devices differently, is that connect to my issue?

I have a standard synaptic touchpad in an Asus U3s.


Greetings,
Gletscher
  #2  
Old 4th May 2009, 07:38 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Code:
synclient TapButton1=1
will enable basic tapping, see 'man synclient' for further options, or just type 'synclient -l' to see current settings. probably easier to use ksynaptics
  #3  
Old 4th May 2009, 10:53 PM
gletscher Offline
Registered User
 
Join Date: May 2009
Posts: 8
wow that's crazy, tapping works, awesome! thanks for the fast help!!


Is it supposed to be disabled by default?

thanks again!
  #4  
Old 4th May 2009, 11:44 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Quote:
Originally Posted by gletscher View Post
wow that's crazy, tapping works, awesome! thanks for the fast help!!


Is it supposed to be disabled by default?
Yes, in F11 tapping is disabled by default. (In previous releases it was not trivial to re-enable it, which wasn't very sensible)
  #5  
Old 5th May 2009, 01:09 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
I've seen a few different versions of the best way to fix this permanently by now. The way I use is to copy /usr/share/hal/fdi/policy/20thirdparty/10-synaptics.fdi to /etc/hal/fdi/policy.

Then edit that file. It looks like, in part

Code:
    <!-- To add custom options for the touchpad, modify the examples below
             to suit your needs. The available options are listed in the
             "synaptics" man page. After modifyfing this file, you must
             restart HAL. Check the output of lshal whether your modifications
             have been merged successfully.

             Note: Options must always be type "string".
             The following examples enable left, right, middle clicks on
             single, double, triple finger tapping, respectively.

             <merge key="input.x11_options.TapButton1" type="string">1</merge>
             <merge key="input.x11_options.TapButton2" type="string">3</merge>
             <merge key="input.x11_options.TapButton3" type="string">2</merge>
        -->
Note that those merge key lines are commented (it's an xml file, so anything between that <!-- and --> are comments.

So, you want to put those three lines with the TapButton in them below the comment part.

So, after the --> in the file put

Code:
    <merge key="input.x11_options.TapButton1" type="string">1</merge>
             <merge key="input.x11_options.TapButton2" type="string">3</merge>
             <merge key="input.x11_options.TapButton3" type="string">2</merge>
Making sure they're above the </match> line that you'll see lower down in the file.

Also, note that for some reason, they have TapButton2 being 3 and 3 being 2. Whether that was a typo or some nefarious xorg or Fedora design, I have no idea, but you probably want to change those two lines so that TapButton2 is 2 and 3 is 3.

Mostly, I've put this info in (I believe sideways has posted it elsewhere) so that next time someone asks, I can find it by using the subscribed posts feature.
__________________
--
http://home.roadrunner.com/~computertaijutsu

Do NOT PM forum members with requests for technical support. Ask your questions on the forum.


"I don't know why there is the constant push to break any semblance of compatibility" --anon
  #6  
Old 5th May 2009, 05:20 PM
gletscher Offline
Registered User
 
Join Date: May 2009
Posts: 8
Well thanks alot for the help, still I think in the long run there should be an option in the mouse configuration to enable it by point&click, to help people enjoy tapping without consulting the forum and moving xml files around :-)
  #7  
Old 5th May 2009, 05:40 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Quote:
Originally Posted by gletscher View Post
Well thanks alot for the help, still I think in the long run there should be an option in the mouse configuration to enable it by point&click, to help people enjoy tapping without consulting the forum and moving xml files around :-)
There is in Gnome, don't know about KDE
  #8  
Old 7th May 2009, 07:03 AM
wnaris Offline
Registered User
 
Join Date: May 2009
Location: Bkk
Posts: 2
wow !

Thank you so much
  #9  
Old 7th May 2009, 07:31 AM
wnaris Offline
Registered User
 
Join Date: May 2009
Location: Bkk
Posts: 2
Quote:
Originally Posted by sideways View Post
Code:
synclient TapButton1=1
will enable basic tapping, see 'man synclient' for further options, or just type 'synclient -l' to see current settings. probably easier to use ksynaptics

this really work, fast and simple
 

Tags
f11, preview, tapping, touchpad, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Touchpad tapping problem gcell Alpha, Beta & Snapshots Discussions (Fedora 11 Only) 1 20th April 2009 10:17 AM
F9 - touchpad no workee (speed and tapping) forkbomb Hardware & Laptops 4 6th August 2008 03:30 PM
Fedora 8 : disable tapping on ALPS touchpad udutronik Hardware & Laptops 11 23rd April 2008 07:05 AM
Tapping touchpad speeds up boot mick Hardware & Laptops 6 25th October 2007 07:08 AM
Warning: gsynaptics cripples touchpad tapping dshaw256 Hardware & Laptops 5 26th August 2007 10:04 PM


Current GMT-time: 07:58 (Thursday, 23-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Sainthia - Syriam Photos on Instagram - Ludwigsfelde Travel Photos on Instagram