Fedora Linux Support Community & Resources Center
  #1  
Old 17th May 2009, 09:37 AM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzs, France
Posts: 104
NFS export an NTFS removable drive

Hi all,

I used to have all my mp3s, photos, etc. on a Seagate "Freeagent" removable USB drive and share it over a Windows network. We've gone all Linux in the house and I tried to export the same drive over NFS (got the NTFS support installed, ntfs-3g) but get this error:

Code:
Starting NFS services:  exportfs: Warning: /media/FreeAgent Drive does not support NFS export.
Any ideas what might be going wrong? Google is fruitless, thus far. =(
__________________
http://drupaler.drupalgardens.com
Reply With Quote
  #2  
Old 17th May 2009, 03:40 PM
Brian1 Offline
Registered User
 
Join Date: Nov 2004
Location: Seymour, Indiana
Posts: 2,509
NFS does not support the Window formats like NTFS, Fat, Fat32. Look at this file under your kernel source if you have it installed. /usr/src/linux/Documentation/filesystems/Exporting. Of course the linux directory may be a different name. I would say get a second drive or install an internal drive somewhere on the network and format ext2. Copy files to it. Samba would be your alternitive to uses the hardware the way it is now.

Brian
__________________
Distribution: RHEL 5.1 with Pieces of this and that.
Kernel 2.6.23.9, KDE 3.5.8 and KDE 4.0 beta, Plus Development src.rpm, ATI fglrx64_7_1_0-8.433-1 rpm with 3D and DRI working.
Acer 5100-5840 with webcam, ati, sdcard reader, sound, atheros based wireless, all working. Only thing not working is the memory stick reader.
Reply With Quote
  #3  
Old 17th May 2009, 06:30 PM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzs, France
Posts: 104
Thanks for your reply, but are you sure? I was under the (perhaps mistaken) impression that NFS could read NTFS disks with the right additional software installed. There are several HOWTOs and other forum threads about it. For example threads like this one on the Ubuntu forum seem to imply that a combo of NFS, NTFS-3G and FUSE make it possible without Samba:
http://ubuntuforums.org/showthread.php?t=597298

I would rather trouble-shoot this solution, and anyway I'm pretty sure Samba won't help me because it's for connecting to Windows networks, which this is *not*. It's just an NTFS partition on a Linux network, no?
__________________
http://drupaler.drupalgardens.com
Reply With Quote
  #4  
Old 17th May 2009, 08:18 PM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzs, France
Posts: 104
Also found this, which again implies it *should* work. In fact, from what I've read I should be able to write safely to NTFS too with the 3g version of ntfs drivers:
http://www.ntfs-3g.org/support.html#nfs

Anyone able to offer some support on this method? All the necessary bits are installed but NFS just can't export this drive. It couldn't be something silly like the space in the drive name could it?
__________________
http://drupaler.drupalgardens.com
Reply With Quote
  #5  
Old 18th May 2009, 12:41 AM
Brian1 Offline
Registered User
 
Join Date: Nov 2004
Location: Seymour, Indiana
Posts: 2,509
Never done it so can't help there. Let us know how it goes and what you do to get it to mount.

Brian
__________________
Distribution: RHEL 5.1 with Pieces of this and that.
Kernel 2.6.23.9, KDE 3.5.8 and KDE 4.0 beta, Plus Development src.rpm, ATI fglrx64_7_1_0-8.433-1 rpm with 3D and DRI working.
Acer 5100-5840 with webcam, ati, sdcard reader, sound, atheros based wireless, all working. Only thing not working is the memory stick reader.
Reply With Quote
  #6  
Old 18th May 2009, 08:10 AM
sej7278 Offline
Registered User
 
Join Date: Sep 2004
Posts: 2,008
if you're just sharing it across the network then format it ext3 and share that, no need for ntfs if you're not plugging it into a windows box.
Reply With Quote
  #7  
Old 18th May 2009, 09:43 AM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzs, France
Posts: 104
Thanks again for replies, guys.

sej7278, the point is there's *loads* of data on it from when it was on a Windows network. I don't really want to have to copy it all off, format the drive and copy it back again, especially when it *should* work! Sure, I can do that if all else fails, but holding off (it's not urgent) in the hopes that someone knows what I'm doing wrong and joins this thread. =)

(Btw, off topic but just installed gparted and it says the filesystem for sda2 (my main drive) is "unknown"! Is this the norm for Fedora?? )
__________________
http://drupaler.drupalgardens.com
Reply With Quote
  #8  
Old 18th May 2009, 02:54 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
NTFS exports in NFS are supported by default in F10 (and F11) you should not have to install ntfs-3g manually. Which Fedora are you using?

I have a multiboot machine with ip 192.168.1.204, to export my main windows ntfs partition I add this to /etc/exports
Code:
/media/OS     *(ro,no_root_squash)
(Gnome mounts the drive at /media/OS)

then 'sudo service nfs start', and on the remote fedora 10/11 machine I mount as

Code:
sudo mount -t nfs 192.168.1.204:/media/OS /mnt/windows
The firewall may give problems, install system-config-nfs and lock the rpc ports to 4001-4005*, then open them all in the firewall (udp & tcp), also open 111 and 2049 (for quick testing of nfs before configuring the firewall you can do 'service iptables stop')

*or just add this to /etc/sysconfig/nfs

LOCKD_TCPPORT=4001
STATD_PORT=4004
RQUOTAD_PORT=4005
LOCKD_UDPPORT=4002
MOUNTD_PORT=4003

then check the firewall is set correctly, type 'sudo iptables-save', it'll list the defined rules, make sure you have:

iptables -A INPUT -p tcp -m state --state NEW -m tcp --dport 2049 -j ACCEPT
iptables -A INPUT -p udp -m state --state NEW -m udp --dport 2049 -j ACCEPT
iptables -A INPUT -p tcp -m state --state NEW -m tcp --dport 111 -j ACCEPT
iptables -A INPUT -p tcp -m state --state NEW -m tcp --dport 4001:4005 -j ACCEPT
iptables -A INPUT -p udp -m state --state NEW -m udp --dport 4001:4005 -j ACCEPT



(gparted shouldn't give that error, so that may be the problem)
Reply With Quote
  #9  
Old 18th May 2009, 04:49 PM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzs, France
Posts: 104
Hi sideways! Thanks for the detailed response! =)

I am using Fedora 10, so this should be working...

/etc/exports looks like this:

Code:
/home/gharvey/share             *(ro,sync)
Where /home/gharvey/share is a symbolic link to /media/FreeAgent Drive (because I didn't like the space and someone suggested elsewhere that might be an issue, but I don't think it's making any difference, since Fedora isn't fooled).

Anyway, did all of the above but still so cigar. NFS restart still says this, so there's obviously some issue with NFS here:

Code:
[gharvey@gharvey ~]$ su -c "service nfs restart"
Password: 
Shutting down NFS mountd:                                  [  OK  ]
Shutting down NFS daemon:                                  [  OK  ]
Shutting down NFS quotas:                                  [  OK  ]
Shutting down NFS services:                                [  OK  ]
Starting NFS services:  exportfs: Warning: /media/FreeAgent Drive does not support NFS export.
                                                           [  OK  ]
Starting NFS quotas:                                       [  OK  ]
Starting NFS daemon:                                       [  OK  ]
Starting NFS mountd:                                       [  OK  ]
Going to try renaming the drive, on a hunch, just in case!
__________________
http://drupaler.drupalgardens.com
Reply With Quote
  #10  
Old 18th May 2009, 05:02 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
what does 'mount' show?
Reply With Quote
  #11  
Old 18th May 2009, 05:02 PM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzs, France
Posts: 104
Hurrah! All working!

My hunch about the space was correct. NFS can't handle spaces in drive labels. You have to re-label your drive, as described here:

https://help.ubuntu.com/community/RenameUSBDrive
__________________
http://drupaler.drupalgardens.com
Reply With Quote
  #12  
Old 18th May 2009, 05:47 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
so I guess the man page for exports needs changing (anyone volunteer to bugzilla?)

Quote:
man exports
...
If an export name
contains spaces it should be quoted using double quotes. You can also specify
spaces or other unusual character in the export name using a backslash followed by
the character code as three octal digits.
...
(octal for space would be \040)
Reply With Quote
  #13  
Old 20th May 2009, 01:39 PM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzs, France
Posts: 104
Never used Bugzilla before, but I can pick this up when I get a mo.

EDIT: no further issues. I did have problems, but resolved them myself ... namely:

1. I was using the wrong command (mount -t ntfs instead of mount -t nfs!)

2. Entering the iptables lines from the command line and using iptables-save was not committing the changes to iptables for some reason - did them with the UI instead, no probs. Still not sure why command line changes didn't stick though - that was weird.


Finally, for interested parties, got the drive to mount automatically by adding this line to /etc/fstab:

Code:
192.168.1.200:/media/freeagent    /media/freeagent     nfs     defaults      0 0
It fails on boot for a number of reasons, but it gets set and as soon as you connect to the wireless network it appears on the desktop. Perfect! =)
__________________
http://drupaler.drupalgardens.com

Last edited by greg.harvey; 20th May 2009 at 02:16 PM. Reason: resolved
Reply With Quote
  #14  
Old 20th May 2009, 03:33 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
2. because iptables-save doesn't save iptables settings, it just dumps the current settings in a format you can feed to a setup script using iptables commands. To save current iptables settings use
Code:
su -c 'service iptables save'
3. It is not usually a good idea to mount nfs drives like that in /etc/fstab, this will stall the bootup if the remote machine is down or if the local network is not ready, which in the case of wifi will often be true. You used to be able to set up automounts so the drives were only mounted when first accessed, don't know if that still works, you can also specify _netdev as a mount option in fstab, that's supposed to prevent mounting until the network is ready, but in the case of networkManager it probably won't help.

If the boot up messages aren't a big issue and it automounts when wifi starts then might as well leave it, but if the boot is slow then specify noauto in the fstab options.
Reply With Quote
  #15  
Old 20th May 2009, 04:06 PM
greg.harvey Offline
Registered User
 
Join Date: May 2009
Location: Uzs, France
Posts: 104
Thanks again! =)

2. Doh!!!

3. Ah, ok - seems fine for now - barely impeded boot at all and just discreetly warned when the login screen came up, so I'll leave it, but good to know.


Trying to add that bug, but not sure on the component to pick. "exports" isn't there, but I guess it's something to do with NFS? nfs-utils?

(Sorry ... Bugzilla n00b...)
__________________
http://drupaler.drupalgardens.com
Reply With Quote
Reply

Tags
drive, export, nfs, ntfs, removable

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
filesystem for removable drive joskaefer Using Fedora 4 7th March 2008 08:55 AM
dvdrw as removable drive Wiles Using Fedora 2 10th August 2007 07:18 AM
install on removable drive Wiles Installation, Upgrades and Live Media 1 28th July 2007 03:31 PM
Problem mounting NTFS partitions of Removable HD Alerander Using Fedora 1 27th August 2005 05:53 PM


Current GMT-time: 10:20 (Monday, 28-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin Copyright 2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat