Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 4th July 2009, 11:43 AM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
Fedora 11: Complete guide to fix PulseAudio and video/audio VLC Media Player issues

Guide now available in PDF format! (see thread attachments)
Quote:
Originally Posted by Silpheed2K
Before you read this guide, I would like to point out that I've been working hard on this guide. I can not stress how long I've spent figuring out and coming up with solutions for the problems I encountered. (and frustration at times) I recommend you go through the ENTIRE guide so everything gets done. I also put the uninstall part in the beginning so we can have a clean start. I really hope this guide helps a lot of you. I also hope this guide lasts a while. This guide is subject to change and be updated. Thank you.
P.S. PulseAudio team please get it right. I can't be around to fix everything, especially after what this distro put me through.

This tutorial is going to explain how to fix pulseaudio completely and the video/audio playback issues of VLC Media Player. Hope this helps. The time scheduling function is still a bit bugged and gives off audio issues I noticed. So unless you want 5 seconds of chopping, skipping, and garbling each time you start an audio app, we're not going to use it. Also, if you're fine with that, can live with the issue and like how it makes PulseAudio less CPU intensive, then skip the step where we disable time scheduling in this tutorial. (You can disable it later if needed after you're done)
So let's get started.

Fixing PulseAudio: We want no less than perfection.

Fresh off of an upgraded install I noticed many things were broken with the audio, so we're going to uninstall PulseAudio first.

In a terminal, type the following:
Code:
su -
yum remove pulseaudio
Restart your computer completely now.

Now that you're back, open a terminal and type the following:
Code:
su -
yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter
This will reinstall PulseAudio and all the extras we need to work with.

[Skip this step if you can live with time-scheduling, skipping is not recommended]
Next, run the following as root: (or open "/etc/pulse/default.pa" manually as root)
Code:
gedit /etc/pulse/default.pa
and replace the line:
Quote:
load-module module-hal-detect
with:
Quote:
load-module module-hal-detect tsched=0
save your changes. This will disable time-scheduling.

Next, run the following as root: (or open "/etc/pulse/daemon.conf" manually as root)
Code:
gedit /etc/pulse/daemon.conf
then change the line:
Quote:
; realtime-scheduling = no
to
Quote:
realtime-scheduling = yes
also, change the line:
Quote:
; default-fragment-size-msec = 25
to
Quote:
default-fragment-size-msec = 10
save your changes.

Restart your computer completely again.

Now, open System > Preferences > Advanced Volume Control and make sure that PCM, Master, and the various PulseAudio devices under the "Device:" menu aren't muted and are raised to adequate volume levels.


Next, open Applications > Sound & Video > PulseAudio Device Chooser
and make sure the Default Server, Default Sink, and Default Source are all set to Default.


After that, in the device chooser, select the "Volume Control" option in the menu and go through each tab making sure none of the streams are muted.



Now, go to the Configuration tab and for Internal Audio - Profiles set it to the appropriate profile until you hear audio from an audio file. If you're hearing audio already then it is probably set to the proper profile already. Experiment with the profiles using an audio file of some sort, playing it. I used Michael Jackson's (R.I.P) Beat It.


The wrong profile means no audio will come from your sound card at all. Example: I didn't hear any sound because my profile was set to digital and not analogue, because analogue is what my sound card supports.

If you are not hearing any audio at all then you need to check the last 3 routines we just went through. (The advanced volume controls for mutes, Defaults of the Device Chooser, volume control in the device chooser for wrong settings)

You're done! Now you can finally enjoy your audio in Fedora.

sidenote: I also noticed the time-scheduling feature can also cause lagging in video playback; which is why I like it better disabled.

If you're still having PulseAudio issues then please open a support thread and ask for help. Now, I shall continue to the next part of my guide.


Fixing video playback issues with VLC Media Player

Before we start to fix VLC Media Player, I would like to ask you to Download this file as we're going to use it, for testing, later. I chose this file because it is going to give you a fair amount of problems playing it with the default settings.

We are going to fix the chopping, skipping and stutter of the audio with VLC Media Player that some of you been experiencing.

First, open VLC and go to Tools > Preferences. (CTRL+P for those who cant find it)
The options should already be set to simple; hit the Audio tab and change Output: Type to Pulseaudio audio output; As shown in the picture below.


Now, change the Show settings option to All and go to Input / Codecs > Access Modules > File; Change the caching value to 1500 (there are 1000 milliseconds in a second)

You can adjust this a little higher or lower later. As long as it's 1000 or above, it should be fine. (I ultimately ended up lowering mine to around 1300, personally)

Now, that video I had you download? Now it's time to test VLC. Open the video file in VLC and press play, watching it from beginning to end. You are watching it for things like glitches in the audio and the audio cutting off half way through the video. If everything is fine with the audio and video, you're done! If not, continue to the next part of this tutorial.
(If it's an audio issue still then you may want to check your settings or open a support thread)
You can try playing the video and skipping around back-and-forth to see if the audio crashes out, but it shouldn't with the settings in this tutorial.


If there is screen tearing in the video (slices in the video images) you may want to try changing the video output settings. (assuming your CPU/GPU is fast enough to handle the video)
In Tools > Preferences (Simple) go to the Video tab and change Display: Output to various options and play the video until the tearing stops. (experiment) I have mine set to OpenGL because I have OpenGL drivers installed for my video card.

(If it's an issue still after your experimentation, then you may want to open a support thread)

There are more things you can do in-depth, which can degrade video quality, but those are better left for a support thread.

Hope this guide has solved your audio and video issues.
Attached Files
File Type: pdf F11_VLC_and_PulseAudio_Guide.pdf (251.2 KB, 1860 views)

Last edited by Silpheed2K; 15th November 2009 at 09:24 PM.
Reply With Quote
  #2  
Old 4th July 2009, 01:04 PM
SwampKracker Offline
Registered User
 
Join Date: Jun 2009
Location: Champaign, IL
Posts: 222
Good job

Just finished going through your guide and applying the tweaks to pulseaudio and vlc.

IT WORKED!!!

Thanks. I use VLC in both Linux and Windows environments and was annoyed at video playback problem which only existed in the Linux world.
Reply With Quote
  #3  
Old 4th July 2009, 06:39 PM
wvn Offline
Registered User
 
Join Date: Jul 2008
Location: Mir space station
Age: 36
Posts: 738
I am applying all the changes right now and i have to ask. Why all the kde libs and stuff?

thanks for all your hard work

UPDATE

Well, it worked my good man. Just a bit of skipping at the very first m.seconds of audio but thats about it.

thanks again.

Last edited by wvn; 4th July 2009 at 07:03 PM.
Reply With Quote
  #4  
Old 5th July 2009, 03:44 AM
mklym Offline
Registered User
 
Join Date: Mar 2009
Location: Alberta, Canada
Posts: 4
Nice guide. Clear and easy to follow. Thank you for the time and effort, Silpheed2k, I appreciate it.
__________________
T61p X7800@2.6GHz 4GB DDR2 Quadro FX570M 15.4"WSXGA+ 500GB 7200.4 HDD w/FC11 x64 Ultrabay 500GB 7200.4 HDD w/Vista Ult x64
Reply With Quote
  #5  
Old 5th July 2009, 03:28 PM
dr_dan_uk Offline
Registered User
 
Join Date: Jul 2009
Location: London, England
Posts: 3
Thanks so much for this, Silpheed2K. Very much appreciated.

I've been having all sorts of weird sound problems since upgrading from Fedora 10, and was considering downgrading back to F10.
Reply With Quote
  #6  
Old 5th July 2009, 07:40 PM
neighborlee Offline
Registered User
 
Join Date: Nov 2003
Location: Seattle , WA
Age: 57
Posts: 235
Quote:
Originally Posted by wvn View Post
I am applying all the changes right now and i have to ask. Why all the kde libs and stuff?

thanks for all your hard work

UPDATE

Well, it worked my good man. Just a bit of skipping at the very first m.seconds of audio but thats about it.

thanks again.
No joy here atm, as when I started kde it asked if I wanted to remove what kde thought were devices no longer desired ?

I started pulseaudio applet and its there in tray, but while server, sink and source are set to 'default', im getting connection refused when I try to bring up volumne or management of pulse.

any ideas ? )))

cheers
nl
__________________
One Heart at a time-

http://heartseed.sf.net
Reply With Quote
  #7  
Old 6th July 2009, 10:18 AM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
@neighborlee
Is the pulseaudio daemon running? I've had that happen before when the daemon wasn't running at all (while I was working on the guide)
Make sure the pulseaudio daemon is running when your computer starts.
Reply With Quote
  #8  
Old 6th July 2009, 10:06 PM
neighborlee Offline
Registered User
 
Join Date: Nov 2003
Location: Seattle , WA
Age: 57
Posts: 235
Quote:
Originally Posted by Silpheed2K View Post
@neighborlee
Is the pulseaudio daemon running? I've had that happen before when the daemon wasn't running at all (while I was working on the guide)
Make sure the pulseaudio daemon is running when your computer starts.
I dont know what else to do, as I am def. no expert on audio in fedora at this time..avahi is starting at boot ( is this what you meant by making sure pulseaudio daemon starts ?) and still I get 'can't connect' error trying to run say, pulse vol. control.

thx for any help here...
cheers
nl
__________________
One Heart at a time-

http://heartseed.sf.net

Last edited by neighborlee; 6th July 2009 at 10:11 PM.
Reply With Quote
  #9  
Old 6th July 2009, 11:07 PM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
Open the gnome-system-monitor (Applications > System Tools > System Monitor) and look for a process running called "pulseaudio";
If it is running then I'm assuming it started during boot-up. If not, you need to go to System > Preferences > Startup Applications and click the Add button. Once in the add menu, insert the following information.

Name: PulseAudio Daemon
Command: pulseaudio
Comment: Starts daemon for the PulseAudio sound server

Logout and then log back in and see if that makes any progress. If not, then try reinstalling pulseaudio. (removing it first of course)
Reply With Quote
  #10  
Old 7th July 2009, 12:18 AM
neighborlee Offline
Registered User
 
Join Date: Nov 2003
Location: Seattle , WA
Age: 57
Posts: 235
Quote:
Originally Posted by Silpheed2K View Post
Open the gnome-system-monitor (Applications > System Tools > System Monitor) and look for a process running called "pulseaudio";
If it is running then I'm assuming it started during boot-up. If not, you need to go to System > Preferences > Startup Applications and click the Add button. Once in the add menu, insert the following information.

Name: PulseAudio Daemon
Command: pulseaudio
Comment: Starts daemon for the PulseAudio sound server

Logout and then log back in and see if that makes any progress. If not, then try reinstalling pulseaudio. (removing it first of course)
Thx much better ))

cheers
nl
__________________
One Heart at a time-

http://heartseed.sf.net
Reply With Quote
  #11  
Old 7th July 2009, 12:43 AM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
Quote:
Originally Posted by wvn View Post
I am applying all the changes right now and i have to ask. Why all the kde libs and stuff?
I was just covering all my bases when I made the guide by listing all the pulseaudio packages I had installed. I knew I had some KDE libs installed, but I didnt realise they would transfer over into the tutorial. (I was experimenting with some KDE tools, for a little while, to see if I needed to tweak the audio settings with any other apps available. Ultimately those options were thrown out.)

Last edited by Silpheed2K; 7th July 2009 at 12:49 AM.
Reply With Quote
  #12  
Old 7th July 2009, 01:39 AM
theLinuxDoctor Offline
Registered User
 
Join Date: Jul 2009
Location: Marlborough,MA
Posts: 6
Finally! someone had the patience and the know-how to put together a guide to getting this sucker working! Thank you!!!! I can't tell you how much time I wasted googling only to find posts that were just a little too out of date to be of any use.

I have followed your instructions but am seeing messages like the following in /var/log/messages ->
Jul 6 19:11:03 bigboy pulseaudio[3086]: alsa-source.c: Your kernel driver is broken: it reports a volume range from 18.00 dB to 18.00 dB which makes no sense.
Jul 6 19:11:04 bigboy pulseaudio[3086]: bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.ServiceUnknown
Jul 6 19:11:08 bigboy pulseaudio[3086]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
Jul 6 19:11:08 bigboy pulseaudio[3086]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Jul 6 19:11:08 bigboy pulseaudio[3086]: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
Jul 6 19:11:09 bigboy pulseaudio[3086]: ratelimit.c: 2 events suppressed
Jul 6 19:12:57 bigboy pulseaudio[3559]: alsa-source.c: Your kernel driver is broken: it reports a volume range from 18.00 dB to 18.00 dB which makes no sense.
Jul 6 19:12:57 bigboy pulseaudio[3559]: bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.ServiceUnknown
Jul 6 19:13:04 bigboy pulseaudio[3086]: reserve-wrap.c: Failed to acquire reservation lock on device 'Audio0': Input/output error
Jul 6 19:13:04 bigboy pulseaudio[3086]: reserve-wrap.c: Failed to acquire reservation lock on device 'Audio1': Input/output error
Jul 6 19:13:04 bigboy pulseaudio[3086]: reserve-wrap.c: Failed to acquire reservation lock on device 'Audio2': Input/output error
Jul 6 19:13:04 bigboy pulseaudio[3086]: reserve-wrap.c: Failed to acquire reservation lock on device 'Audio3': Input/output error
Jul 6 19:13:32 bigboy pulseaudio[3086]: reserve-wrap.c: Failed to acquire reservation lock on device 'Audio2': Input/output error
Jul 6 19:13:38 bigboy pulseaudio[3086]: ratelimit.c: 4 events suppressed
Jul 6 19:15:40 bigboy pulseaudio[3086]: reserve-wrap.c: Failed to acquire reservation lock on device 'Audio2': Input/output error

Something tells me this could not be anything good! ;-) :-! I can use audio if in (KDE) pulseaudio I "prefer" my speakers to pulseaudio [.. and believe that only works with amarok, but I need to reverify that ..], so at least I seem to have _something_ work ... as primative as it is.

Funny ... when I first installed F11 I got things working without too much trouble ... after a few updates and/or adding a USB turnable to my system, audio has been down for the count.

Thanks again for all your help in putting together your guide ... it is VERY, VERY much appreciated!!!
John C
Reply With Quote
  #13  
Old 7th July 2009, 02:45 AM
scur Offline
Registered User
 
Join Date: Feb 2009
Posts: 1
I was getting the same message as neighborlee, did everything you suggested, and even though it worked for him, on my computer it still happens. Any advice?
*EDIT* Know what? I unplugged my cam, and the sound came on. Great guide, though, it got everything set up right, thnx!

Last edited by scur; 7th July 2009 at 04:12 AM.
Reply With Quote
  #14  
Old 7th July 2009, 04:19 AM
StuartRothrock Offline
Registered User
 
Join Date: Jul 2009
Posts: 1
Thanks for the terrific information. I know how to get it back to a sane checkpoint. Yet with both VLC and Totem, if I accidentally start a 2nd instance, it plays no sound nor do any future instances with the same userid. If I switch userids, it works just fine. So obviously, pulseaudio or the gtk, snome, the app is setting the last used, which is nul when it cant access the source. I am guessing. Someone smarter than I am needs to shed light on a solution.

An obvious solution could be "then don't do that". It is VLC that is not behaving properly. I have it configured to not run more than one instance. Yet at times, he doesn't see himself and starts another instance which collides with the same something-something.

Thanks again for the help to get this far. I am running Fedora 11 - up to date - and pulseaudio as shown above.

Last edited by StuartRothrock; 7th July 2009 at 04:30 AM. Reason: added more info
Reply With Quote
  #15  
Old 7th July 2009, 04:32 AM
icanfly0307 Offline
Registered User
 
Join Date: Jan 2009
Posts: 145
Thank You, VERY VERY VERY VERY VERY VERY Much!!!! I use rhythmbox and the music used to stop randomly and freeze the application... and then I followed ur guide and now everything works! again, thanks for sharing your fixes...
Reply With Quote
Reply

Tags
audio, f11, pulse, video, vlc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to: Fix PulseAudio and primary audio issues with Fedora 10 (F10) Silpheed2K Guides & Solutions (No Questions) 160 2nd December 2010 04:46 AM
Media (DVD, web content, video & audio) playback in Fedora Firewing1 Guides & Solutions (No Questions) 240 16th July 2009 05:25 PM
video but no audio with VLC media player snazyevey Using Fedora 3 29th April 2008 05:01 AM
Linux video/audio players for popular file formats supported by Windows Media Player tech291083 Using Fedora 2 18th March 2007 10:41 PM


Current GMT-time: 14:21 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Chumphon Photos on Instagram - Ranot Instagram Photos - Lerum