Fedora Linux Support Community & Resources Center
  #1  
Old 30th July 2009, 05:51 AM
shocks Offline
Registered User
 
Join Date: Apr 2009
Posts: 18
linuxfedorafirefox
Blender isn't working properly.

I have installed Blender 2.49a. I am using F10 in Dell Inspiron 1525.


When I open Blender I will get blurred Blender window. Does anyone knows what is reason for it and how to fix this problem?

And one more thing Blender works fine in Vista.
Reply With Quote
  #2  
Old 30th July 2009, 08:55 AM
leadgolem Offline
Registered User
 
Join Date: Apr 2005
Location: Littleton, CO
Age: 29
Posts: 2,857
linuxfedorafirefox
I'm not sure what you mean by blurred, can you post a screenshot?
__________________
S.C.O.U.R.G.E. Heroes of lesser renown, contributor.
Reply With Quote
  #3  
Old 31st July 2009, 06:47 AM
shocks Offline
Registered User
 
Join Date: Apr 2009
Posts: 18
linuxfedorafirefox
Hey how to past screenshot. I don't have access to any image hosting site what to do.
Reply With Quote
  #4  
Old 31st July 2009, 07:04 AM
shocks Offline
Registered User
 
Join Date: Apr 2009
Posts: 18
linuxfedorafirefox
Finally I got some image hosting site for without sign up.

Below is image(s) of blender. See text in menu are blurred. I can't do anything with blurred menu like this.





Reply With Quote
  #5  
Old 31st July 2009, 08:18 AM
leadgolem Offline
Registered User
 
Join Date: Apr 2005
Location: Littleton, CO
Age: 29
Posts: 2,857
linuxfedorafirefox
Wow, that is messed up.

Ok, what video card and driver is the laptop using?
__________________
S.C.O.U.R.G.E. Heroes of lesser renown, contributor.
Reply With Quote
  #6  
Old 31st July 2009, 09:10 AM
pankajp Offline
Registered User
 
Join Date: Jul 2007
Location: Mumbai, India
Posts: 226
linuxfedorafirefox
Can you try if disabling kms fixes it. I think i've seen screenshots (and bug reports) like this before.
__________________
Fedora 14 Laughlin user on Dell Inspiron 1525
http://www.smolts.org/client/show/pu...0-71f71be44f7d :)
Reply With Quote
  #7  
Old 31st July 2009, 09:18 AM
shocks Offline
Registered User
 
Join Date: Apr 2009
Posts: 18
linuxfedorafirefox
Quote:
Wow, that is messed up.

Ok, what video card and driver is the laptop using?
It Intel inbuilt graphic I think its X3100. I haven't installed any extra graphic driver after F10 installation.

Quote:
Can you try if disabling kms fixes it. I think i've seen screenshots (and bug reports) like this before.
How to disable kms? And what is kms?
Reply With Quote
  #8  
Old 31st July 2009, 01:22 PM
pankajp Offline
Registered User
 
Join Date: Jul 2007
Location: Mumbai, India
Posts: 226
linuxfedorafirefox
Quote:
Originally Posted by shocks View Post
How to disable kms? And what is kms?
Oops, i'm extremely sorry i didn't elaborate. kms is kernel modesetting, which basically sets the video graphics mode in the kernel itself instead of xorg. Its a new feature available only in intel and radeon drivers currently. You dont actually need to know that. An overview is given at https://fedoraproject.org/wiki/Featu...nelModesetting .
Try the following to disable kms and see if it fixes ur problem:
Reboot your computer. While rebooting immediately after the bios screen press esc key, and enter the grub menu. There type 'c' to enter the command and in the second line (kernel ...) type 'e' to edit the command. Go to the end of the line and add 'nomodeset'. Then type 'b' to boot. Try to see if blender works properly. If yes u can make the change permanent by editing the same line in the file /boot/grub/grub.conf
__________________
Fedora 14 Laughlin user on Dell Inspiron 1525
http://www.smolts.org/client/show/pu...0-71f71be44f7d :)
Reply With Quote
  #9  
Old 31st July 2009, 01:44 PM
shocks Offline
Registered User
 
Join Date: Apr 2009
Posts: 18
linuxfedorafirefox
after pressing "c" what command I should enter?
Reply With Quote
  #10  
Old 31st July 2009, 01:46 PM
shocks Offline
Registered User
 
Join Date: Apr 2009
Posts: 18
linuxfedorafirefox
Ok i got it
Reply With Quote
  #11  
Old 31st July 2009, 01:51 PM
shocks Offline
Registered User
 
Join Date: Apr 2009
Posts: 18
linuxfedorafirefox
Hey It didn't worked. Blender blurs as usual.
Reply With Quote
  #12  
Old 31st July 2009, 04:40 PM
oldgold Offline
Registered User
 
Join Date: Jul 2009
Posts: 17
linuxfedorafirefox
You are not the only one having this problem, almost anything that uses animated graphics does it to me. I have attached a couple of examples, the first is the emacs sign-on screen and the second is a youtube video.


I am also using the Intel driver, I think this is a problem with tiling but I don't know what to do about it, nomodeset has no effect whatsoever.

This is only one of a plethora of problems I have had since installing fedora11. I have spent more than a week trying to resolve video and audio problems, it is the worst experience I have had with linux since trying to learn linux on my own using slackware more than 10 years ago.

I am about to back up my home directory and reinstall fc6.

here is my /proc/cpu file:

processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 2.00GHz
stepping : 4
cpu MHz : 2000.000
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm up pebs bts
bogomips : 3985.53
clflush size : 64
power management:
Attached Thumbnails
Click image for larger version

Name:	emacs.png
Views:	56
Size:	128.9 KB
ID:	17852   Click image for larger version

Name:	youtube.png
Views:	55
Size:	83.8 KB
ID:	17853  
Reply With Quote
  #13  
Old 31st July 2009, 07:05 PM
pankajp Offline
Registered User
 
Join Date: Jul 2007
Location: Mumbai, India
Posts: 226
linuxfedorafirefox
Which intel chipset are u having. I'm having 965M, and i have some other display problems ihttps://bugzilla.redhat.com/show_bug.cgi?id=507282 which go away on disabling modesetting. Also do you get the problem with compiz enabled or disabled?

EDIT: This bug seems to https://bugzilla.redhat.com/show_bug.cgi?id=505962
__________________
Fedora 14 Laughlin user on Dell Inspiron 1525
http://www.smolts.org/client/show/pu...0-71f71be44f7d :)

Last edited by pankajp; 31st July 2009 at 07:08 PM.
Reply With Quote
  #14  
Old 1st August 2009, 05:50 AM
shocks Offline
Registered User
 
Join Date: Apr 2009
Posts: 18
linuxfedorafirefox
I am not pretty sure of chipset. It may be 965 as I found in net. Same problem occurs even when compiz is enabled and also disabled.
Reply With Quote
  #15  
Old 1st August 2009, 02:52 PM
oldgold Offline
Registered User
 
Join Date: Jul 2009
Posts: 17
linuxfedorafirefox
Here is the answer.

If you don't have the file /etc/xorg.conf make it using system-config-display. If you don't have system-config-display go to a fedora mirror and get it. You will find it under development not releases.

Then turn off tiling as explained in this thread:

Bug 505962 - Fedora 11 Screen Garbage on machines using Intel 845 chipset
Reply With Quote
Reply

Tags
blender, properly, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
blender 3D not working after update kmod kernel mythcat Using Fedora 3 6th December 2009 11:58 PM
blender doesnt display properly? rixtr66 Using Fedora 3 3rd October 2009 04:06 AM
Blender 3d not working correctly Shane L Using Fedora 5 28th September 2009 07:30 PM
Blender not working. HELP STCninja Using Fedora 0 29th March 2006 08:50 PM


Current GMT-time: 11:07 (Wednesday, 27-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat