Fedora Linux Support Community & Resources Center
  #1  
Old 5th August 2009, 05:32 PM
homerun Offline
Registered User
 
Join Date: Jul 2009
Posts: 8
linuxfedorafirefox
Wireless at Run Level 3 using public Wifi with Lynx

Hi all.

I have been trying to test the use of X window forwarding over SSH in a cafe. The Cafe's WiFi requires login via a web browser. Using Fedora 11 with Gnome on a Dell Latitude D600 laptop, the wireless works just fine. I am able to use a virtual terminal to ssh to my server at home. NX client/server works also.

However, when I change to Run Level 3 on the Laptop in order to use X Window forwarding, wireless networking fails to function. Will wireless networking function at Run Level 3, and if so, how is that accomplished?

Also, if I get Wireless to work at Run Level 3, will I be able to login to the free public wifi using Lynx or some other text browser, as I can with IE and Firefox?

Thanks,

Homerun
Reply With Quote
  #2  
Old 5th August 2009, 07:31 PM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
windows_xp_2003firefox
Are you typing init 3 to change runlevel? I imagine that would log out out of gnome since the X server stops. The default networking is to use NetworkManager service which is controlled through a gnome nm-applet.

One solution would be to abandon NetworkManager service and switch to using the network service which loads sooner in the boot process. Search the forum there are lots of messages on how to do this.
Reply With Quote
  #3  
Old 5th August 2009, 10:35 PM
beaker_ Offline
Registered User
 
Join Date: Nov 2008
Location: Canada
Posts: 2,425
unknownunknown
system-config-network is what your looking for. Uncheck controlled by network manager and managed is what you want. You use to kick start it by assigning a static ip (dhcp use to fail) but it's been awhile for me. Scripts are an alternative.

Edit: chkconfig network on, check config network-manager off (?) To permanetly change things. If it flies for you i.e.,

Last edited by beaker_; 5th August 2009 at 10:37 PM.
Reply With Quote
  #4  
Old 7th August 2009, 12:02 AM
homerun Offline
Registered User
 
Join Date: Jul 2009
Posts: 8
linuxfedorafirefox
Thanks for the replies about wireless at runlevel 3. Knowing it could be done motivated me more to get it done. I am not sure if this post will take all this text.

I decided to reinstall Fedora 11 and try everything with a pristine system. Besides, it wouldn't reboot after I tweeked the network using system-config-network. I think I had a corrupt system. I had been adding and removing software for over a month and probably messed up some dependencies.

The new install went much better than the one last month. This time I did not have to mess with ipw2200 firmware, and WEP wireless functioned right away rather than days of messing with it and it suddenly made a connection, and I did not know why it started working. One day recently, I noticed two kernel options and have been using the most recent one. I appearently accepted the kernel update mixed in with other updates.

Anyway, after installing Fedora 11 (kernel 2.6.29.4-167.fc11.i586) without any additional software installation or updates, I easily got wireless networking operational with WEP. I then ran init 3 and the wireless worked just fine. I only worked with NetworkManager Applet 0.7.1 but checked system-config-network to see if the settings were getting passed to it. They were.

I made notes while installing Fedora 11 today on a Dell Latitude D600. I am pasting them below but don't expect anyone to actually read beyond here. In fact I don't recommend reading beyond here.

Many thanks,

Homerun

Installed Fedora on hard drive of a Dell Latitude D600 Laptop. sda2 had Windows XP Home and sda3 had XP Pro while sda1 was Dell Utilities. sda5 and sda6 were NTFS data partitions which used to be Windows 2003 and 2008.

Created a root and home partion for Fedora. During a previous install of Fedora 11 one month ago, I accepted all the default software. During the installation I was asked for ipw2200 firmware via a usb stick. I downloaded 3 files and copied them to a usb stick and continued with the installion, but got no indication they were used. This time I deselected firmware I didn't think I needed including ipw2100, but left ipw2200 selected. Also deselected games.

I did not select any additional repositories other than the default.
The kernel was 2.6.29.4-167.fc11.i586 from "uname -a" after the install.

After installation, Computer (the icon on the Gnome desktop) shows Windows Drive Labels, so it is handy to name them in Windows before installing Fedora. Don't know if changing drive labels in Windows will transfer to an already installed Fedora. Booted to windows, change one drive label and yes it does transfer.

Got a message "Your battery has very low capacity (29%), which means that it may be old or broken." This occurs during every startup including change to init 3 then back via startx. The gnome-power-manager 2.26.1 applet shows 100% charge. I believe this is a Gnome issue, as I got this message from installation of other distributions.

Commented #hiddenmenu in the Grub menu.lst, so I could could more easily boot Windows. Changed rootnoverify (hd0,0) to rootnoverify (hd0,1) as Fedora got this wrong and I couldn't boot windows.

Renaming document problem:
Created this document via right click desktop, Create Document, Empty File and changed the "new file" name while it is highlighted. I have often gotten "The item could not be renamed.There is no "new file" in this folder. Perhaps it was just moved or deleted?" Determined this occurs if the file is renamed and double clicked for opening before click away from the icon.


No network connectivity immediately after installation and startup!

I did not have network connectivity even though I had both an Ethernet connection and a wireless access point. Granted the access point was configured with WEP, so this would have had to be configured. I thought the Ethernet would have been immediately available.

Thus, the Network Icon (NetworkManager Applet 0.7.1) in the The GNOME Panel 2.26.1 between the Bluetooth Manager and gnome-power-manager 2.26.1 had a red x on it after the first startup. Hovering over this icon produced "no network connection". Right clicking this showed both check boxes were checked for Networking and Wireless. Left clicking did reveal a number of wireless access point SSID's, so the wireless adaptor was somewhat functioning. Eth0 is the Ethernet network and Eth1 is wireless network.

I decided to get eth0 working first knowing there were several ways to accomplish this but I planned to first just use the NetworkManager Applet. First thing I did was left click the NetworkManager Applet and selected the "System eth0" option button. This did give me network connectivity, and I used the Ethernet connection to access the wireless access point to obtain it's WEP key. I then rebooted to see if this would automatically connect to the network via eth0. It did not. I believe this was because, by default, eth0 was not configured to start automatically.

After the reboot,I toggled from "System eth0" to my wireless SSID "cisco" which asked for a WEP key. Left the "Wireless Security" drop down list at "WEP 40/128-bit Key". Then I pasted the WEP key into the first (not the other 3) "Key" text box with all lower case characters having selected the "Show key" check box. I left "Open System" in the Authentication drop down box. Then I clicked the Connect button. This worked and I now had wireless connectivity. I was surprised because I had a lot of problems with WEP wireless when I installed Fedora 11 on this laptop just one month ago.

So, I now knew both eth0 and eth1 would work. I restarted and Wireless WEP connected - very good. I think eth1 must have been set to start automatically by default, but I know eth0 was not set to start automatically. Now I wanted to get the wired network eth0 to function from startup. So I used the NetworkManager Applet to disable Wireless by unchecking "Enable Wireless". I then right clicked NetworkManager Applet and then selected "Edit Connections". This brought up a window titled "Network Connections", which can also be accessed via System|Preferences|Network Connections. This is not the same window that comes up via System menu, Administration, Network which is titled "Network Configuration" and its Help, About shows that it is system-config-network 1.5.97. The "Network Configuration" window occurs if system-config-network is run from the command line. Note the difference of these two window names: "Network Connections" which can be started from a terminal with nm-connection-editor, vs "Network Configuration" which is system-config-network.

Continuing, in Network Connections, as I said, I right clicked the NetworkManager Applet and selected Edit Connections. I then selected System eth0 in the Wired tab and checked the checkbox next to "Connect Automatically". In the IPv4 Settings tab, I left the Method: drop down box at "Automatic(DHCP). I also left the "Available to all users" check box checked.

Note: Before I applied the "Connect Automatically in Network Connections" in the NetworkManager Applet, I checked the settings in Network Configuration of system-config-network for both eth0/Ethernet and eth1/Wireless. Both only had the check box checked for "Controlled by NetworkManager" and "Automatically obtain DNS information from provider".

Now with Eth0 set to start automatically and Eth1 not to and Eth1 disabled in NetworkManager Applet, I changed to runlevel 3 and could ping the gateway which was via Ethernet, which was no surprise. Then I rebooted.

After rebooting, NetworkManager Applet showed "Wireless Enable" with a right mouse click. Left click showed System eth0 option selected and Connect Automatically was unchecked in Edit Connections of the eth1 in the Wireless tab/Edit.

I now want eth0 disabled/not connect automatically with eth1 enabled to connect automatically. It appears that eth0 cannot be disabled via NetworkManager Applet though it can be set to not start automatically.

Next I started system-config-network. Previously I had been there and had seen two devices in the "Devices" tab. Now there were three: eth0, eth1, and now Auto_cisco. "cisco" is my access point SSID. In the Hardware tab was a device pan0. I don't know if it was there before. If anyone reads this far, I would be interested in what caused this.

Both eth0 and eth1 have ip addresses because both are functioning. Rebooted with eth0 set to not start automatically.

Eth1 wireless with WEP started and connected. Now I want to use system-config-network to use wireless while in runlevel 3, but first I will check if wireless connectivity will work in runlevel 3 without using system-config-network. Ran "init 3" in terminal window as root. To might surprise, consternation, and delight, I could ping the default router.

During this time, I did not perform any additional software installations or updates. I may not update this system for a while while I work more with Fedora. Sweat!
Reply With Quote
  #5  
Old 7th August 2009, 12:20 AM
beaker_ Offline
Registered User
 
Join Date: Nov 2008
Location: Canada
Posts: 2,425
unixunknown
Glad you got it rolling. I suspect you were hungup on the services. Basically the network service has to run unless network manager is controlling it. A limitation you'll run into is; system-config-network doesn't support wpa. However I just discover cnetworkmanager, check it out.

yum install cnetworkmanager
cnetworkmanager --help
Reply With Quote
  #6  
Old 7th August 2009, 01:15 AM
homerun Offline
Registered User
 
Join Date: Jul 2009
Posts: 8
linuxfedorafirefox
Beaker,

Thanks for including the install command. I like the cnetworkmanager -n best.

Tomorrow I'll find out if a text browser such as lynx can be used to log into a public WiFi, so that I can test X11 over SSH, which by the way, I have yet accomplish via Ethernet or Wireless. There is something fundamental about remote X windowing I haven't yet configured properly. I think I'll install a new pristine Fedora server to connect with this new pristine Fedora system on the laptop.

By the way, I have Dell T300 with seven partitions and multiple linux distributions, and for some reason Fedora's installation partitioning software tells me I don't have enough disk space, even though there is plenty, and I was able to follow up with the installation of another distribution. I may partition with another partitioning tool and then try to install Fedora or just install Fedora over an earlier installed distribution's partition.
Reply With Quote
  #7  
Old 7th August 2009, 09:53 PM
zackf Offline
Registered User
 
Join Date: Nov 2006
Location: South Carolina
Posts: 798
windows_vistafirefox
Quote:
Originally Posted by homerun View Post

Got a message "Your battery has very low capacity (29%), which means that it may be old or broken." This occurs during every startup including change to init 3 then back via startx. The gnome-power-manager 2.26.1 applet shows 100% charge. I believe this is a Gnome issue, as I got this message from installation of other distributions.
It's not really saying you have 29% Battery Life remaining but your battery's total capacity is 29% of what it once was - this will happen over time with rechargeable batteries...I tried to make sense there
Reply With Quote
  #8  
Old 10th August 2009, 04:12 PM
homerun Offline
Registered User
 
Join Date: Jul 2009
Posts: 8
linuxfedorafirefox
Thanks zackf. After reading your reply, I swapped batteries and the problem went away. This is a cool capability that an OS can determine what a battery should be capable of doing. Your explanation was clear to me, and I hope mine is also understandable.

Concerning my Wifi issue at runlevel 3, my laptop now maintains network connectivity when I change to Runlevel 3 from a windowed console when at home with wireless router configured with WEP. However, at a public Wifi, I immediately loose network connnectivity when running init 3 from a windowed console. If anyone knows why this would occur at a public wifi, I would be very interested in the explanation.

I mentioned Fedora couldn't partition my hard drive, with Fedora indicating not enough drive space. Well, da, somehow during my first Linux installation on my system months ago, I didn't utilize the remainder of the hard drive in the extended partition, leaving some of it permanently unavailable. Yesterday I used GParted Live CD, discovered the problem, and used gparted to resize the extended partition to use the rest of the drive. The previously installed Linux distributions (most on the extended partition) and Windows 2008 on the first partition continue to work, though I haven't started all of them yet, and I was subsequently able to install Fedora.
Reply With Quote
Reply

Tags
level, lynx, public, run, wifi, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Level one WNC-0500 Wireless card driver deepaknag Hardware & Laptops 7 29th August 2009 09:28 AM
Can't connect to public wireless jamecl Servers & Networking 0 24th May 2008 06:01 AM
need tips on safely use public wifi access gold Using Fedora 1 9th March 2008 05:23 PM
wireless security with f7 in public access points marko Servers & Networking 3 10th June 2007 11:39 PM
How can I Snoop L3 level IGMP packet at L2 level(Bridging level). salil.mehta Servers & Networking 0 16th December 2006 08:29 PM


Current GMT-time: 22:04 (Monday, 22-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Chilis Travel Photos on Instagram - Century Cinema Photos on Instagram