Fedora Linux Support Community & Resources Center
  #1  
Old 20th August 2009, 03:36 PM
bizar Offline
Registered User
 
Join Date: Feb 2009
Posts: 66
linuxfedorafirefox
Virtual Machine Manager error when add a new virtual machine

Hi all
I try to install a new virtual machine and I get this error can some one help me please.

Here is the error title
Code:
Unable to complete install: 'internal error unable to start guest: qemu: could not open monitor device 'pty'
'
And here are the details
Code:
Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: qemu: could not open monitor device 'pty'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1501, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 974, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: qemu: could not open monitor device 'pty'
Thanks in advanced.
Best Regards.
Reply With Quote
  #2  
Old 1st November 2009, 10:30 PM
dtseiler Offline
Registered User
 
Join Date: Mar 2008
Posts: 15
linuxfedorafirefox
I have the same problem here.

Quote:
Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: qemu: could not open monitor device 'pty'

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/create.py", line 1497, in do_install
dom = guest.start_install(False, meter = meter)
File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 541, in start_install
return self._do_install(consolecb, meter, removeOld, wait)
File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 633, in _do_install
self.domain = self.conn.createLinux(install_xml, 0)
File "/usr/lib64/python2.6/site-packages/libvirt.py", line 974, in createLinux
if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: qemu: could not open monitor device 'pty'
Any fix?

FWIW, I'm on Fedora 11, dual-headed display on my desktop.
Reply With Quote
  #3  
Old 1st November 2009, 10:36 PM
dtseiler Offline
Registered User
 
Join Date: Mar 2008
Posts: 15
linuxfedorafirefox
Looks like the problem is SELinux. I noticed alerts about qemu trying to use terminal. Here are the two alerts that were genearted at the same time:


Quote:
Summary:

SELinux is preventing qemu-system-x86 (svirt_t) "setrlimit" svirt_t.

Detailed Description:

SELinux denied access requested by qemu-system-x86. It is not expected that this
access is required by qemu-system-x86 and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinu...fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.


Quote:
Summary:

SELinux prevented pt_chown from using the terminal 1.

Detailed Description:

SELinux prevented pt_chown from using the terminal 1. In most cases daemons do
not need to interact with the terminal, usually these avc messages can be
ignored. All of the confined daemons should have dontaudit rules around using
the terminal. Please file a bug report
(http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this selinux-policy.
If you would like to allow all daemons to interact with the terminal, you can
turn on the allow_daemons_use_tty boolean.

Allowing Access:

Changing the "allow_daemons_use_tty" boolean to true will allow this access:
"setsebool -P allow_daemons_use_tty=1."

Fix Command:

setsebool -P allow_daemons_use_tty=1
Reply With Quote
  #4  
Old 1st November 2009, 10:37 PM
dtseiler Offline
Registered User
 
Join Date: Mar 2008
Posts: 15
linuxfedorafirefox
Confirmed that I can disable SELinux and virt-manager is able to create the instance.
Reply With Quote
Reply

Tags
add, error, machine, manager, virtual

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Machine Manager dulsi Using Fedora 2 30th July 2009 03:34 PM
Virtual disk images (virtual box - virtual machine manager) beaker_ Using Fedora 0 2nd July 2009 01:19 PM
Problem with QEMU and Virtual Machine Manager after updates, guest machine slow otnateos Using Fedora 6 12th April 2008 03:29 PM
Need Help with Virtual Machine Manager Matt Bastin Using Fedora 2 15th March 2008 12:30 AM
problem creating a new virtual system with Virtual Machine Manager in Fedora 7 reboot Using Fedora 3 3rd June 2007 01:51 AM


Current GMT-time: 18:38 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat