Fedora Linux Support Community & Resources Center
  #1  
Old 3rd September 2009, 12:16 PM
suryakiran13 Offline
Registered User
 
Join Date: Sep 2009
Posts: 3
windows_xp_2003firefox
httpd services not starting in fedora 11

my problem is that httpd services not starting in fedora 11 and in i open firefox and type my localhost address then it is showing the fedora web server page but in terminal when i type start httpd it is not starting and displaying [FAILURE] message and also displaying that localhost:80 is in use cannot start httpd service. so please help me with this i'm very basic user.

thank you in advance and waiting for your kind reply.
Reply With Quote
  #2  
Old 3rd September 2009, 12:33 PM
valente.ro Offline
Registered User
 
Join Date: May 2008
Location: Romania - Europe
Posts: 38
linuxfedorafirefox
Wink

for starting the "httpd" service:
in a console as root run this command: setup
then, go to "System services", mark "httpd", press "ok", then "quit"
and that's all; next time when you boot your Fedora you will have "httpd" up and running.

now, regarding the other problem you've mentioned, i did not encountered. Please go though the above steps and see if the problem persists.

cheers


Quote:
Originally Posted by suryakiran13 View Post
my problem is that httpd services not starting in fedora 11 and in i open firefox and type my localhost address then it is showing the fedora web server page but in terminal when i type start httpd it is not starting and displaying [FAILURE] message and also displaying that localhost:80 is in use cannot start httpd service. so please help me with this i'm very basic user.

thank you in advance and waiting for your kind reply.
__________________
Fedora, the Linux I like ;)
Reply With Quote
  #3  
Old 3rd September 2009, 12:54 PM
suryakiran13 Offline
Registered User
 
Join Date: Sep 2009
Posts: 3
windows_xp_2003firefox
thanx dear but the problem still persists : (
Reply With Quote
  #4  
Old 3rd September 2009, 12:56 PM
valente.ro Offline
Registered User
 
Join Date: May 2008
Location: Romania - Europe
Posts: 38
linuxfedorafirefox
ok, please post here the exact error.
__________________
Fedora, the Linux I like ;)
Reply With Quote
  #5  
Old 5th September 2009, 05:41 AM
suryakiran13 Offline
Registered User
 
Join Date: Sep 2009
Posts: 3
windows_xp_2003firefox
here are the errors exact seen on the screen:
(1)
# /sbin/service httpd start
starting httpd: (98) Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
unable to open logs
[FAILED]

(2)
# /sbin/service httpd stop
Stopping httpd: [FAILED]
You have new mail in /val/spool/mail/root

(3)
# /sbin/service httpd restart
Stopping httpd: [FAILED]
starting httpd: (98) Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
unable to open logs
[FAILED]

These three are the errors which i'm getting on my screen while accessing httpd service.
But when i open firefox and in address bar type local host then the apache page is showing so that means it is running ... don't know what to do please help dear

thank you for helping : )
Reply With Quote
  #6  
Old 5th September 2009, 07:57 AM
Keldorn Offline
Registered User
 
Join Date: Jun 2008
Location: Russia
Age: 26
Posts: 517
linuxfedorafirefox
Try to run this commands, it seems to me that you have errors in your httpd.conf
httpd -S
httpd -t
Reply With Quote
  #7  
Old 7th September 2009, 08:08 AM
valente.ro Offline
Registered User
 
Join Date: May 2008
Location: Romania - Europe
Posts: 38
linuxfedorafirefox
and run the commands as ROOT !
__________________
Fedora, the Linux I like ;)
Reply With Quote
Reply

Tags
fedora, httpd, services, starting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
httpd services is dead julian5 Installation, Upgrades and Live Media 2 1st February 2009 12:11 PM
FC4 trouble starting services D@ Mick Servers & Networking 0 9th December 2005 10:47 AM
Apache (httpd) Services Startup Problem llbbl Servers & Networking 3 25th November 2005 01:52 PM
Starting and stopping services on Fedora? Compiling Kernel thiongo Guides & Solutions (No Questions) 3 2nd June 2005 04:23 PM
starting services in parallel paxromana Using Fedora 9 17th September 2004 12:09 AM


Current GMT-time: 04:14 (Wednesday, 16-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat