Fedora Linux Support Community & Resources Center
  #1  
Old 6th September 2009, 04:28 AM
marksolo Offline
Registered User
 
Join Date: Sep 2009
Posts: 2
linuxfedorafirefox
USB audio problems

I am currently using Bose companion 5 speakers (USB) on Fedora 11 and until the latest PulseAudio update they worked perfectly. Now they do not show up under the list of output devices. Does anyone know of a way of fixing this?
Reply With Quote
  #2  
Old 6th September 2009, 10:54 AM
southpole Offline
Registered User
 
Join Date: Nov 2006
Location: Rock Hill, SC, USA
Age: 61
Posts: 27
linuxfedorakonqueror
Bose Companion 5 failure

Just to add to MarkSolo's dilemma that I share, the Bose Companion 5 system shows up on KDE's Mixer. Typing the command, lsusb, in the terminal will list the system as a viable USB device.

The odd thing is that in the list of the latest update, I do not see any changes to the PulseAudio packages. There are a number of alsa changes, though.
Reply With Quote
  #3  
Old 6th September 2009, 06:18 PM
gaston82 Offline
Registered User
 
Join Date: Sep 2009
Posts: 2
linuxfedorafirefox
How can i install the uvc driver on Fedora11???
Reply With Quote
  #4  
Old 6th September 2009, 07:44 PM
theresonant Offline
Registered User
 
Join Date: Apr 2009
Posts: 32
windows_xp_2003opera
I don't really want to give PulseAudio a bad name, but everytime someone I know had a problem with sounds in Fedora, I told them to "yum remove pulseaudio". For some reason it was like a cure-all, suddenly everything worked and sounds came out of every orifice a computer can have.

If everything else fails, you could try this. It's rather a kludge, but I never found real use for PulseAudio anyway. For everyday, average things like music, IM and conversations, the default ALSA device works great. For hardcore stuff, like real-time effects, Ardour and all the like, there's JACK. Obviously, you could use JACK for average stuff too, but dunno... I don't.

I'm not trying to flame it, nor to be a troll. If I can be proven wrong, please do so - that would mean I should get PulseAudio back
Reply With Quote
  #5  
Old 7th September 2009, 06:00 AM
marksolo Offline
Registered User
 
Join Date: Sep 2009
Posts: 2
linuxfedorafirefox
The update I'm referring to was the last time the PulseAudio system was updated and was probably two updates ago, I'm kind of lazy when it comes to restarting my computer
Reply With Quote
  #6  
Old 7th September 2009, 06:10 PM
southpole Offline
Registered User
 
Join Date: Nov 2006
Location: Rock Hill, SC, USA
Age: 61
Posts: 27
linuxfedorafirefox
Baby, Baby, Where did my Bose go???

Hey theresonant! Point well taken and yes, I have had my Pulse issues in the past to the point Lennart and I were almost at a first name basis. However, with Fedora 11, I have been lucky with PA to this point.

With the last NOW 2 updates, PA has become selective with what devices are available for me. The command, lsusb, shows all of the USB devices:

$ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 046d:0a01 Logitech, Inc. USB Headset
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 005: ID 05a7:1020 Bose Corp.
Bus 003 Device 006: ID 046d:08ad Logitech, Inc. QuickCam Communicate STX
Bus 003 Device 004: ID 0557:2213 ATEN International Co., Ltd
Bus 003 Device 003: ID 0557:7000 ATEN International Co., Ltd Hub
Bus 003 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

ALSA clearly shows the Bose Companion 5 System, as well as my onboard sound card and the USB Logitech Headset:

# cat /proc/asound/cards
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfbcf4000 irq 16
1 [Headset ]: USB-Audio - Logitech USB Headset
Logitech Logitech USB Headset at usb-0000:00:13.1-3, full speed
2 [Audio ]: USB-Audio - Bose USB Audio
Bose Corporation Bose USB Audio at usb-0000:00:12.0-2.2, full speed
3 [U0x46d0x8ad ]: USB-Audio - USB Device 0x46d:0x8ad
USB Device 0x46d:0x8ad at usb-0000:00:12.0-2.3, full speed


So, why is it that suddenly Pulse becomes picky in not allowing the Bose system when it allows the USB Headset:

# pulseaudio
W: main.c: This program is not intended to be run as root (unless --system is specified).
E: alsa-sink.c: Unable to set switch: Operation not permitted
E: module-alsa-card.c: Failed to find a working profile.
E: module.c: Failed to load module "module-alsa-card" (argument: "device_id=2 name=usb_device_5a7_1020_noserial_if0_sound_card_0 card_name=alsa_card.usb_device_5a7_1020_noserial_i f0_sound_card_0 tsched=0"): initialization failed.
E: bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.DBus.Error.ServiceUnknown


However, in the above, I DID notice a failure to load module, "mudule-alsa-card" for device id=2. I imagine that it is the same id=2 that is listed for the Bose system in the output for the alsa cards. Any thoughts?

I will pursue this further.
Reply With Quote
  #7  
Old 7th September 2009, 07:35 PM
theresonant Offline
Registered User
 
Join Date: Apr 2009
Posts: 32
linuxopera
Well, as far as I can see, the "module-alsa-card" fails with your usb Bose sound card indeed. Hm... It might be very stupid to say it, but it could be a permission issue... Please post the output of

ls -R -l /dev/bus/usb

I think your device is either unreadable, or ALSA module fails while loading the driver. Can you killall pulseaudio and try to make some sounds using your USB card?

Oh yes, are you using GNOME or KDE? If it's KDE, it might be a bit more straightforward for you to figure it out, because there's a well made graphical interface for audio devices, which includes tests.
Reply With Quote
  #8  
Old 9th September 2009, 03:34 AM
southpole Offline
Registered User
 
Join Date: Nov 2006
Location: Rock Hill, SC, USA
Age: 61
Posts: 27
linuxfedorafirefox
Hey theresonant,

I did some more testing today and have become more confused. If the Bose system is the only USB audio device plugged in, it plays although the "Output" tab reports the system to suddenly be a 5.1 system instead of a 4.1. Once I connect the USB cam and/or the Logitech USB headset, the Bose card disappears from preferences. Disconnecting these devices can bring the Bose system back without anything but closing apps that require sound.

Here is the latest output of lsusb as the devices are in different locations after each boot:

# lsusb
Bus 006 Device 002: ID 046d:0a01 Logitech, Inc. USB Headset
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 006: ID 046d:08ad Logitech, Inc. QuickCam Communicate STX
Bus 003 Device 005: ID 05a7:1020 Bose Corp.
Bus 003 Device 004: ID 0557:2213 ATEN International Co., Ltd
Bus 003 Device 003: ID 0557:7000 ATEN International Co., Ltd Hub
Bus 003 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Here is the output of ls -R -l /dev/bus/usb:

# ls -R -l /dev/bus/usb
/dev/bus/usb:
total 0
drwxr-xr-x 2 root root 60 2009-09-08 11:02 001
drwxr-xr-x 2 root root 60 2009-09-08 11:02 002
drwxr-xr-x 2 root root 160 2009-09-08 11:02 003
drwxr-xr-x 2 root root 60 2009-09-08 11:02 004
drwxr-xr-x 2 root root 60 2009-09-08 11:02 005
drwxr-xr-x 2 root root 80 2009-09-08 11:02 006
drwxr-xr-x 2 root root 60 2009-09-08 11:02 007

/dev/bus/usb/001:
total 0
crw-rw-r-- 1 root root 189, 0 2009-09-08 11:02 001

/dev/bus/usb/002:
total 0
crw-rw-r-- 1 root root 189, 128 2009-09-08 11:02 001

/dev/bus/usb/003:
total 0
crw-rw-r-- 1 root root 189, 256 2009-09-08 11:02 001
crw-rw-r-- 1 root root 189, 257 2009-09-08 11:02 002
crw-rw-r-- 1 root root 189, 258 2009-09-08 11:02 003
crw-rw-r-- 1 root root 189, 259 2009-09-08 11:02 004
crw-rw-r-- 1 root root 189, 260 2009-09-08 11:02 005
crw-rw-r-- 1 root root 189, 261 2009-09-08 11:02 006

/dev/bus/usb/004:
total 0
crw-rw-r-- 1 root root 189, 384 2009-09-08 11:02 001

/dev/bus/usb/005:
total 0
crw-rw-r-- 1 root root 189, 512 2009-09-08 11:02 001

/dev/bus/usb/006:
total 0
crw-rw-r-- 1 root root 189, 640 2009-09-08 11:02 001
crw-rw-r-- 1 root root 189, 641 2009-09-08 11:02 002

/dev/bus/usb/007:
total 0
crw-rw-r-- 1 root root 189, 768 2009-09-08 11:02 001

I am not sure where to make my next move. It seems all of this started after the following packages were updated:

alsa-utils
alsa-lib
alsa-lib-devel

As for your question of whether I use Gnome or KDE, the answer is "yes." Each has its advantage for me and I use both. The behaviour is the same in both.
Reply With Quote
  #9  
Old 9th September 2009, 07:03 AM
theresonant Offline
Registered User
 
Join Date: Apr 2009
Posts: 32
linuxopera
Try to go to KDE, to System Settings > Multimedia. It has the "show advanced devices" option, and enabling it might make your card show up. Also, if you're using the Xine backend for Phonon, have a go at the GStreamer backend: "yum install phonon-backend-gstreamer", and select it. Xine and GStreamer provide different devices on my rudimentary Intel HDA card, and it might just make yours show up. I think it would be a good idea to kill the pulseaudio server before you go to the multimedia settings, just in case.

In conclusion, try the GStreamer backend for Phonon in KDE, and test things out with the multimedia settings.

Tell us how it went.
Reply With Quote
  #10  
Old 9th September 2009, 05:48 PM
southpole Offline
Registered User
 
Join Date: Nov 2006
Location: Rock Hill, SC, USA
Age: 61
Posts: 27
linuxfedorafirefox
I have tried to isolate whether it is PulseAudio. The system works the same with or without PulseAudio. I have installed the GStreamer backend for Phonon and switched to it. Again, no difference in my dilemma.

If I have the Webcam and the USB Headset disconnected, the Bose System works fine. Once I connect any USB audio device, the PCM driver of the Bose goes grey in the advanced settings in KDE. The advantage is that here I get some visual of what is going on in the background. Thank you for bringing this to my attention.

I have included a set of screen captures for the different scenarios to show you what I am experiencing. Interestingly, when the Bose PCM driver is greyed out, I can select the "analog" Bose driver and the "Test" will give me the KDE theme tune.

I have also included the capture of the update log when this problem occurred. Previous to this, there was never an issue with these devices.

Oddly enough, I also have another system running Fedora 12 Alpha that is doing the same thing since the similar update.

Thoughts? I have been thinking of somehow scrubbing out all sound devices from the system and having it discover them as new devices. I cannot seem to find out any information on how to safely do this.
Attached Thumbnails
Click image for larger version

Name:	USB_Audio_w_Bose_Webcam.png
Views:	102
Size:	198.3 KB
ID:	18039   Click image for larger version

Name:	USB_Audio_w_Bose_Webcam_Headset.png
Views:	92
Size:	198.6 KB
ID:	18040   Click image for larger version

Name:	USB_Audio_w_only_Bose.png
Views:	79
Size:	199.0 KB
ID:	18041   Click image for larger version

Name:	Communication_w_Bose_Webcam_Headset.png
Views:	87
Size:	193.7 KB
ID:	18042   Click image for larger version

Name:	Software_Log_Viewer.png
Views:	105
Size:	174.2 KB
ID:	18043  

Reply With Quote
  #11  
Old 9th September 2009, 07:58 PM
theresonant Offline
Registered User
 
Join Date: Apr 2009
Posts: 32
linuxopera
This is beginning to go beyond my experience... The only thing I can think of is that, for some reason, only one audio device is supported over USB. But that doesn't really make any sense, does it?

Try this. Open the JACK control panel with your Bose system connected. Then go to "Config", and on the right side there should be a drop-box labeled "Driver". Can you see your system there?
Reply With Quote
  #12  
Old 9th September 2009, 11:50 PM
southpole Offline
Registered User
 
Join Date: Nov 2006
Location: Rock Hill, SC, USA
Age: 61
Posts: 27
linuxfedorakonqueror
In days of old, I would say there's an Interrupt conflict going on amongst the USB devices...only the audio USB devices. There are a number of other USB devices on here: keyboard, mouse, UPS and KVM switch. It is only the Audio USB devices doing this. This is why I would like to flush all the system's knowledge of these devices and one by one have it start to "learn" about them again.

I feel that when the Sept. 3rd update happened, ALSA is seeing things differently and the devices are conflicting...somewhere. I cannot find any instructions on flushing the current devices and having the system do a "self-discovery" of the devices as I plug the devices back in.
Reply With Quote
  #13  
Old 10th September 2009, 09:13 AM
theresonant Offline
Registered User
 
Join Date: Apr 2009
Posts: 32
linuxopera
I have two more suggestions, but they're almost guesses, rather:

1. remove all packages that are related to alsa. But please be careful not to remove some important packages, like software that DEPENDS on ALSA. This might give you the cleanup, though I don't know if a cleanup will help.

2. Install a different audio package. This is also called "shotgun debugging" I know there are multiple audio systems, aside from pulseaudio. Maybe ESD, or Arts? Normally, this shouldn't really do anything good, but messing your audio systems up even more might just fix it. This is silly, yet I'd try it when there's nowhere else to go.
Reply With Quote
  #14  
Old 10th September 2009, 11:00 AM
NeverwherE Offline
Registered User
 
Join Date: Aug 2009
Posts: 10
windows_xp_2003ie
Unhappy latest updates to pulseaudio

I have a similar problem with pulseaudio. After the latest updates for pulseaudio, I no longer hear some sounds initially. The gnome login sound is only heard a little at the end. Skype doesn't make its sound at start up. Only when I do a sound test do I hear the skype startup sound. And when I shutdown, I no longer hear a beep as it goes to the plymouth screen. Any one else experience this? Everything else seems to work and I just updated 9/9/2009.
Reply With Quote
  #15  
Old 10th September 2009, 08:43 PM
southpole Offline
Registered User
 
Join Date: Nov 2006
Location: Rock Hill, SC, USA
Age: 61
Posts: 27
linuxfedorafirefox
Talking

Hey, theresonant! Today's ALSA update couldn't be more timely!!! All is well and the disaster that prevailed from September 3rd's update has been fixed. I was planning to follow your recommendation today. I had already been thinking about that from the beginning, but the PackageKit Manager wanted to take too many dependant packages out along with ALSA, so I hesitated.

Then I saw the Fedora Update emails that I subscribe to and saw ALSA. I gave it one more chance and am glad I did.

Thanks for all your help!


Hey, NeverwherE! As for your issues, it could be PulseAudio. The problem I had was not PA's doing. With the symptoms I had the the back-tracking troubleshooting I did, PA was taken out of the equation early in the game. It just delivered what it received...which, when I attached multiple USB audio devices, was nothing...silence.

** "The gnome login sound is only heard a little at the end."

As for this issue, I am not sure this is PulseAudio. There is a lot going on at this point of the O/S load. Mine used to stutter...all versions used to do this because of all the services loading. Windoze XP did it also. It is the PC and the timing of the "tune" at the time of delivery. That could be ALSA.

** "Skype doesn't make its sound at start up. Only when I do a sound test do I hear the skype startup sound."

Skype does not seem to get along with PulseAudio well, never has. I circumvent PA and select the actual device I want for Skype. That works for my Skype noises and the headset I use. Skype has not seen any rebuilding of consequence since Fedora Core 6, and here we are moving towards Fedora 12. What's up with that? Maybe it is time to push Ekiga! It comes with ANY distribution of Linux, is not proprietary and it WORKS!

** "And when I shutdown, I no longer hear a beep as it goes to the plymouth screen."

Me neither! Notice the Xorg updates? I think they changed things on us...just my thoughts. It seemed they went away when those packages came up on the updates.

Food for thought...hope it instills some thought in a constructive direction.
Reply With Quote
Reply

Tags
audio, problems, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio problems. rapt0rjezuz Using Fedora 9 2nd August 2009 05:55 PM
Audio Problems Lockstar Using Fedora 3 2nd April 2009 06:13 AM
Audio CD problems Kabel Hardware & Laptops 0 30th November 2008 01:51 AM
Audio problems m000oooo Hardware & Laptops 0 28th December 2007 07:22 PM
Having some audio problems Anakin Using Fedora 3 3rd November 2005 02:42 PM


Current GMT-time: 16:04 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Slers Ham and Cafe - Ludhiana