Fedora Linux Support Community & Resources Center
  #1  
Old 5th October 2009, 11:15 PM
Mr tim esquire Offline
Registered User
 
Join Date: Mar 2008
Posts: 101
linuxfedorafirefox
Problem mounting NFS drive: "mount.nfs: mount system call failed"

These are the settings on my server, which has a static ip:

Code:
[tim@computim ~]$ cat /etc/exports
/media/cavern                  192.168.1.*(rw,sync)
Code:
[tim@computim ~]$ cat /etc/hosts.deny
portmap:ALL
mountd:ALL
rquotad:ALL
statd:ALL
lockd:ALL
Code:
[tim@computim ~]$ cat /etc/hosts.allow    

portmap: 192.168.1.2/100
lockd: 192.168.1.2/100
rquotad: 192.168.1.2/100
mountd: 192.168.1.2/100
statd: 192.168.1.2/100
When i try to mount the disk from my client machine i get the error:

Code:
[tim@localhost ~]$ sudo mount -t nfs 192.168.1.10:/media/cavern /media/cavern
mount.nfs mount system call failed
Thinking the problem might be due to iptables i tried the foowing command as recomended by a book i found on google

Code:
sudo iptables -A INPUT -i wlan0 -f -j ACCEPT
didn't help so tried disabling the firewall - still getting the error

Both machines are running FC11 - should i be using nfs4?

thanks
t

Last edited by Mr tim esquire; 5th October 2009 at 11:19 PM. Reason: spotted keyword all was acidently lowercase in hosts.deny, corrected
Reply With Quote
  #2  
Old 6th October 2009, 06:56 PM
robertmaessen Offline
Registered User
 
Join Date: Sep 2009
Posts: 31
linuxfedorafirefox
If you do "service nfs status"
it is telling you that:
rpc.mountd (pid ) is running...
nfsd (pid ) is running...
rpc.rquotad (pid ) is running...
Reply With Quote
  #3  
Old 6th October 2009, 07:47 PM
Mr tim esquire Offline
Registered User
 
Join Date: Mar 2008
Posts: 101
linuxfedorafirefox
services running OK,
If i turn off both firewalls and comment out everything in hosts.allow and hosts.deny I can mount NFS OK. It will stay like this for now..
Reply With Quote
  #4  
Old 6th October 2009, 07:56 PM
robertmaessen Offline
Registered User
 
Join Date: Sep 2009
Posts: 31
linuxfedorafirefox
Looking at the syntax of host allow "portmap: 192.168.1.2/100" after the / it suspects a netmask something like this.
IP Network with Subnet Mask: 192.168.1.0/255.255.255.0
Reply With Quote
  #5  
Old 6th October 2009, 08:04 PM
robertmaessen Offline
Registered User
 
Join Date: Sep 2009
Posts: 31
linuxfedorafirefox
If you need to secure it better with hosts.allow use this
portmap: 192.168.1. allow
portmap : 192.168.1.1 deny

Last edited by robertmaessen; 6th October 2009 at 08:20 PM.
Reply With Quote
  #6  
Old 6th October 2009, 08:22 PM
Mr tim esquire Offline
Registered User
 
Join Date: Mar 2008
Posts: 101
linuxfedorafirefox
It seems nfs4 is the way forward here. I scrapped the above, turned the firewalls back on and allowed nfs4 with the firewall manager. works a charm!

Last edited by Mr tim esquire; 6th October 2009 at 08:22 PM. Reason: punctuation!
Reply With Quote
  #7  
Old 6th October 2009, 08:27 PM
robertmaessen Offline
Registered User
 
Join Date: Sep 2009
Posts: 31
linuxfedorafirefox
Yep, NFS4 is the better way these days, since most directory's are just linked into the NFS4 repository you don't have nasty things like "you can not run this or that on a fileshare directory on the fileshare server itself"
Reply With Quote
  #8  
Old 6th October 2009, 11:43 PM
Mr tim esquire Offline
Registered User
 
Join Date: Mar 2008
Posts: 101
linuxfedorafirefox
Currently using the below line in my /etc/fstab on the client machine to load the exports from the server. Unfortunately this only loads the first share on the exports list.
Code:
#nfs4
192.168.1.10:/ /media/computim/ nfs4 _netdev,auto 0 0
If your setting up a networked fileserver or shared disk just take a look at nfs4 howTos youll get there in the end (and i hope I will too)

peas!
Reply With Quote
Reply

Tags
drive, mounting, nfs, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
After hot power-off => "mount: error mounting /dev/root on /sysroot as ext3:" ceric Using Fedora 0 30th July 2009 10:27 PM
Mount a network hard drive in an easy way without gnome menu "Connect to server" Perty Servers & Networking 0 16th December 2008 09:34 PM
Getting "Mount Failed" Error Divit11 Installation, Upgrades and Live Media 3 15th November 2007 09:48 AM
HOW TO MOUNT "C" "D" "E" LOCAL HARDDISK PARTITION ketan_hk Using Fedora 6 6th September 2007 01:10 AM
FC2: "mount error 6 mounting ext3" boot failure pointym5 EOL (End Of Life) Versions 1 26th January 2005 02:40 PM


Current GMT-time: 14:24 (Monday, 28-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat