Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 22nd November 2009, 02:33 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfedorafirefox
How to install the nvidia driver in F16, F15, F14 using the run method

(Note added on 5/31/2010: As of x86_64 F13, the i686 libraries are no longer required in step 9. The x86_64 libs are sufficient. I have tried it with and without i686 and could not detect any difference.)

Before F12, it was easy to install the nvidia driver using the "run" method posted at http://www.nvidia.org. Now it is no longer straightforward. After a lot of trial and error, I got the run method to work on a Compaq Presario notebook with a 7000M nvidia GPU. The following method works for both factory and custom kernels, or if you have multiple kernels, e.g., a factory and a custom kernel. I have both the factory kernel and a custom kernel, and driver works fine on both. I am using 64-bit F15. For 32-bit, omit x86_64. All commands except 15 are run as root.

(Note: As Dies points out below, you can also use the akmod method for custom kernels. The so-called "run" method is universal, however, and usually just requires two steps (telinit and sh). You don't even have to reboot..)

(It goes without saying that if you are installing Fedora several months after it has been released, the packages on the installation media will be several months out of date with respect to the repository. Therefore, before even proceeding to step 1, you should execute "yum update" and reboot.)

1. Download the driver from http://www.nvidia.org.

2. $ setsebool -P allow_execstack on
This is now the default setting in F15, so it is ok to skip step 2. Also, skip step 2 if not using SElinux.

3. $ yum remove xorg-x11-drv-nouveau

4. $ echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

5. $ yum --enablerepo=rp*g remove kmod-nvidia xorg-x11-drv-nvidia-libs.{i686,x86_64}
If you had previously installed kmod-nvidia, it has to be removed, otherwise there is a conflict. Skip if you didn't.

6. $ cd /boot

7. $ mv initramfs-$(uname -r).img initramfs-$(uname -r).img.backup

8. $ dracut initramfs-$(uname -r).img $(uname -r)

9. $ yum install gcc kernel-devel-$(uname -r) mesa-libGL-devel.{i686,x86_64} mesa-libGLU

10. reboot into run level 3 as follows:
From the GRUB boot screen, press "e" (for edit). Highlight the kernel line and press "e" again. Move the cursor to the end of the kernel line and enter "3" without the quotes.
Press enter to accept the changes. Press "b" (for boot). This will boot the kernel into level 3.

11. $ sh NVIDIA-Linux-x86_64-190.42-pkg2.run
Towards the end, the nvidia script will ask if you want it to modify xorg.conf. Answer "yes".
If you have multiple kernels, including custom, all you have to do once the current setup is finished is to boot
into each of the other kernels in turn following step 10, and re-run step 11 with a "-K" switch at the end.

(Note added on 4/22/2011: In recent versions of Fedora, it is safe to skip step 12. I tried commenting these lines out in F15, F14 and it worked. It is possible that a certain version of the X server at that time could not find those modules for x86_64 and needed to be explicitly told where to find them. Such bugs have been fixed in more recent version of Fedora. Try skipping step 12.)

12. $ cd /etc/X11 && vi xorg.conf
Add the following lines to the "Files" section:
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules/drivers"
ModulePath "/usr/lib64/xorg/modules"

13. $ cd /boot/grub && vi grub.conf
Add "rhgb vga=791 quiet" without the quotes to the kernel line.
Replace 791 with 794 if you want 1280x1024 instead of 1024x768.

F16 uses GRUB2 by default. Add the above string to the GRUB_CMDLINE_LINUX variable in /etc/default/grub. Then update the configuration using grub2-mkconfig -o /boot/grub2/grub.cfg.

14. reboot

15. $ glxinfo | grep -i opengl
It should not give errors.

(Note added on 12/15/2011: For anyone curious about a bootup message in newer kernels that the nvidia module "taints" the kernel, this is not an error, or a sign of potential problems. It is a licensing issue. Nvidia releases its "run" driver under a non-GPL license. Nouveau is GPL.)

Last edited by plasmonics; 15th December 2011 at 03:37 PM. Reason: new version of Fedora
Reply With Quote
  #2  
Old 22nd November 2009, 03:35 PM
khaytsus Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
linuxfedorafirefox
http://fedorasolved.org/video-solutions/nvidia-yum-kmod

Done.

Minor caveat; until kwizart is around the driver is only in the testing repo, so add --enablerepo=rpmfusion\*testing\*

Installing from the .run file is just stupid.
Reply With Quote
  #3  
Old 22nd November 2009, 03:55 PM
Dies Offline
Registered User
 
Join Date: Oct 2006
Posts: 4,754
linuxfedorafirefox
Quote:
Originally Posted by khaytsus View Post
http://fedorasolved.org/video-solutions/nvidia-yum-kmod

Done.

Minor caveat; until kwizart is around the driver is only in the testing repo, so add --enablerepo=rpmfusion\*testing\*

Installing from the .run file is just stupid.
I guess you missed the part where he said he was using a custom kernel, huh? Or the part where he mentioned leigh's sticky?

How stupid is that?



@ plasmonics

I'm sure someone will appreciate your post. There are good reasons to install the Nvidia driver manually. Or maybe you want to avoid installing a bunch of *-config-display's

In any case, you might want to also mention that akmods is another option.
Reply With Quote
  #4  
Old 22nd November 2009, 04:16 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfedorafirefox
Right. There is also the akmod method. However I am not sure it will work for a custom kernel.
The kmod method is good if you are using factory. But some people, incl. myself, sometimes
recompile for one reason or another. Others may experiment with pre-release kernels. The run
method is very flexible and works for all distros and all kernels. Unfortunately, as you can see,
it is no longer straightforward in F12.

Edit:
Quote:
Originally Posted by khaytsus View Post
http://fedorasolved.org/video-solutions/nvidia-yum-kmod

Done.

Minor caveat; until kwizart is around the driver is only in the testing repo, so add --enablerepo=rpmfusion\*testing\*

Installing from the .run file is just stupid.
It is stupid that you did not read the part about custom kernel. Leigh123linux's method does not work for that case.
Reply With Quote
  #5  
Old 22nd November 2009, 04:26 PM
khaytsus Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
linuxfedorafirefox
F12 adds an selinux command because the execstack protection has been enabled by default now... That's it, nothing else has changed since F11. You've had to blacklist nouvaeu since F11, but don't worry about that because I let the rpmfusion packages take care of that for me. There is still the step of manually rebuilding the initrd the first time regardless, only dfference is the method but the step was always there.
Reply With Quote
  #6  
Old 22nd November 2009, 04:41 PM
Dies Offline
Registered User
 
Join Date: Oct 2006
Posts: 4,754
linuxfedorafirefox
Quote:
Originally Posted by plasmonics View Post
Right. There is also the akmod method. However I am not sure it will work for a custom kernel.
It should, it re-compiles the module on the fly whenever one isn't available for the running kernel. At least I thought that was the advantage, but to be honest I haven't compiled my own kernel on Fedora in a couple of releases.

Quote:
Originally Posted by khaytsus View Post
F12 adds an selinux command because the execstack protection has been enabled by default now... That's it, nothing else has changed since F11. You've had to blacklist nouvaeu since F11, but don't worry about that because I let the rpmfusion packages take care of that for me. There is still the step of manually rebuilding the initrd the first time regardless, only dfference is the method but the step was always there.

Custom kernel
. It will NOT work with pre-compiled modules. Are you really that dense?
Reply With Quote
  #7  
Old 22nd November 2009, 04:51 PM
khaytsus Offline
Registered User
 
Join Date: Jan 2008
Posts: 17
linuxfedorafirefox
Quote:
Originally Posted by Dies View Post
It should, it re-compiles the module on the fly whenever one isn't available for the running kernel. At least I thought that was the advantage, but to be honest I haven't compiled my own kernel on Fedora in a couple of releases.



Custom kernel
. It will NOT work with pre-compiled modules. Are you really that dense?
No, should I have also added "oh, I see, custom kernel, my bad" in the second post? I was responding to it no longer being "straightforward" in F12 when in reality it has one added step.
Reply With Quote
  #8  
Old 22nd November 2009, 04:59 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfedorafirefox
[QUOTE=Dies;1294445]It should, it re-compiles the module on the fly whenever one isn't available for the running kernel. At least I thought that was the advantage, but to be honest I haven't compiled my own kernel on Fedora in a couple of releases.

I have used kmod before, but not akmod.
I will give akmod a try on a custom kernel on my test machine and see what happens.
Reply With Quote
  #9  
Old 23rd November 2009, 06:20 PM
GTrip Offline
Registered User
 
Join Date: Aug 2009
Location: Virginia / Pennsylvania
Posts: 33
linuxfedorafirefox
Step 12 - NVIDIA run fails

Steps 1-11 were completed. Step 12 fails with the attached nvidia-installer.log.txt (nvidia-installer.log)

I have since done the following (as step 12 and as the final step) with success as described by leigh123linux in http://forums.fedoraforum.org/showth...ghlight=nvidia :

yum --enablerepo=rp*g install akmod-nvidia xorg-x11-drv-nvidia-libs.i686 xorg-x11-drv-nvidia-libs (WITHOUT the .x86_64)
Attached Files
File Type: txt nvidia-installer.log.txt (25.7 KB, 227 views)

Last edited by GTrip; 23rd November 2009 at 08:38 PM. Reason: Update progress through to a positive resolution
Reply With Quote
  #10  
Old 23rd November 2009, 09:22 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfedorafirefox
Quote:
Originally Posted by GTrip View Post
Steps 1-11 were completed. Step 12 fails with the attached nvidia-installer.log.txt (nvidia-installer.log)

I have since done the following (as step 12 and as the final step) with success as described by leigh123linux in http://forums.fedoraforum.org/showth...ghlight=nvidia :

yum --enablerepo=rp*g install akmod-nvidia xorg-x11-drv-nvidia-libs.i686 xorg-x11-drv-nvidia-libs (WITHOUT the .x86_64)
The reason it did not work is because you used an obsolete driver. According to your log file,
you used 185.18.14. The failure had nothing to do with step 12 but with compatibility. This driver
does not work with kernel 2.6.31.5. As a test, I downloaded 185.18.14, attempted to compile it,
and was able to replicate your log file exactly. The current driver is 190.42 and works fine with step 12.

I am willing to bet that when you ran the akmod command, it pulled down 190.42 and not 185.xx. akmod is just a wrapper for the compilation that you were attempting to do manually. Had it pulled down the wrong driver, it would have failed too.

If you want to use an older driver because your GPU works better with it, you might want to try
180.60. There is a free patch for it that brings it up to speed with the newer kernels.
Reply With Quote
  #11  
Old 30th November 2009, 12:12 PM
jnfbatista Offline
Registered User
 
Join Date: Nov 2009
Posts: 3
windows_vistasafari
Thanks for the guide, I was having some troubles installing the nvidia binaries and your guide helped a lot
Reply With Quote
  #12  
Old 6th December 2009, 06:37 PM
Etherus Offline
Registered User
 
Join Date: Jan 2009
Location: Stockholm, Sweden
Posts: 34
linuxfedorafirefox
Hello I did use your awesome guide, and it did install the nvidia drivers without any problem the only problem I have now is somehow it does not detect my monitor anymore, it shows as "Unknown" with the nouvou driver it showed correctly my Samsung monitor and I could choose like 60 Hz etc.

Do you know what I can do to get it back?
Reply With Quote
  #13  
Old 6th December 2009, 06:54 PM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Quote:
Originally Posted by plasmonics View Post
Right. There is also the akmod method. However I am not sure it will work for a custom kernel.
The kmod method is good if you are using factory. But some people, incl. myself, sometimes
recompile for one reason or another. Others may experiment with pre-release kernels. The run
method is very flexible and works for all distros and all kernels. Unfortunately, as you can see,
it is no longer straightforward in F12.

Edit:

It is stupid that you did not read the part about custom kernel. Leigh123linux's method does not work for that case.
Want to put money on that ?

Code:
[leigh@localhost Desktop]$ rpm -qa |grep nvidia
kmod-nvidia-2.6.31.6-153.fc12.x86_64-190.42-1.fc12.4.x86_64
xorg-x11-drv-nvidia-190.42-5.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.i686
akmod-nvidia-190.42-1.fc12.4.x86_64
nvidia-settings-1.0-3.2.fc12.x86_64
nvidia-xconfig-1.0-1.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.x86_64
kmod-nvidia-2.6.31.6-160.fc12.x86_64-190.42-1.fc12.4.x86_64
kmod-nvidia-2.6.32-1.fc12.x86_64-190.42-1.fc12.4.x86_64
[leigh@localhost Desktop]$ uname -r
2.6.32-1.fc12.x86_64
[leigh@localhost Desktop]$
Reply With Quote
  #14  
Old 7th December 2009, 01:41 PM
plasmonics Offline
Registered User
 
Join Date: Feb 2009
Posts: 69
linuxfedorafirefox
Quote:
Originally Posted by Etherus View Post
Hello I did use your awesome guide, and it did install the nvidia drivers without any problem the only problem I have now is somehow it does not detect my monitor anymore, it shows as "Unknown" with the nouvou driver it showed correctly my Samsung monitor and I could choose like 60 Hz etc.

Do you know what I can do to get it back?
Sometimes I have had this problem myself. The driver extracts this info from the EDID of the monitor. My Sony monitor has a minor bug in the EDID. I don't worry about it. It is a string in /etc/X11/xorg.conf in the section "Monitor". You can set this string yourself.

As root, you should be able to run
$ nvidia-settings
and set the screen resolution, color depth, sync freq, overclocking, etc., and save the results in /etc/X11/xorg.conf.

---------- Post added at 08:41 AM CST ---------- Previous post was at 08:19 AM CST ----------

Quote:
Originally Posted by leigh123linux View Post
Want to put money on that ?

Code:
[leigh@localhost Desktop]$ rpm -qa |grep nvidia
kmod-nvidia-2.6.31.6-153.fc12.x86_64-190.42-1.fc12.4.x86_64
xorg-x11-drv-nvidia-190.42-5.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.i686
akmod-nvidia-190.42-1.fc12.4.x86_64
nvidia-settings-1.0-3.2.fc12.x86_64
nvidia-xconfig-1.0-1.fc12.x86_64
xorg-x11-drv-nvidia-libs-190.42-5.fc12.x86_64
kmod-nvidia-2.6.31.6-160.fc12.x86_64-190.42-1.fc12.4.x86_64
kmod-nvidia-2.6.32-1.fc12.x86_64-190.42-1.fc12.4.x86_64
[leigh@localhost Desktop]$ uname -r
2.6.32-1.fc12.x86_64
[leigh@localhost Desktop]$
If you read my original post, you will see that I mentioned the akmod method.

My main point is that the run method is long established and works for all distros with just one command. Some distros may not have the equivalent of a pre-packaged system like kmod/akmod.

In addition, the current driver may not be suitable for some hardware. For certain GPUs, e.g., 7000M, it overworks the GPU fan, increasing the chance of a bearing failure. This is a well known problem that has been discussed in depth at the nvidia web site. So I use an older driver to which I have to apply a patch developed by some Gentoo users. I don't see how anything other than the run method would work here.
Reply With Quote
  #15  
Old 8th December 2009, 11:10 AM
Etherus Offline
Registered User
 
Join Date: Jan 2009
Location: Stockholm, Sweden
Posts: 34
linuxfedorafirefox
Hey plasmonics, Thanks for the great post and the help with monitor I got it perfectly working now, it is actually pretty easy once you know the steps !
Reply With Quote
Reply

Tags
driver, f12, install, method, nvidia, run

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install nvidia driver??? stelyo pipis Hardware & Laptops 3 14th August 2009 06:20 PM
can not install NVIdia driver .?? demuytree Hardware & Laptops 4 27th March 2008 07:41 PM
About install nvidia driver maengyi Using Fedora 11 27th October 2007 06:24 AM
No X after nvidia driver install :( kang0o Installation, Upgrades and Live Media 65 2nd August 2007 12:08 PM
nvidia driver install FireRun Hardware & Laptops 12 31st July 2005 08:22 PM


Current GMT-time: 22:49 (Monday, 20-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Herne Bay Instagram Photos - Abergele Travel Photos on Instagram - Tekari Instagram Photos