Fedora Linux Support Community & Resources Center
  #1  
Old 22nd December 2009, 07:30 PM
jflesher Offline
Registered User
 
Join Date: May 2007
Location: USA
Age: 53
Posts: 258
linuxfedorafirefox
Need to downgrade PHP 5.3 on F12

PHP 5.3 is nice to have available, but its crashing my Joomla 1.5.x site on my Development machine (no chance of Joomla fixing it any time soon, its not ready for 5.3, maybe 1.6.x when its ready), I need to downgrade to 5.2; but when I do a yum list php, it only shows 5.3, so yum downgrade php fails.

Is it possible to have you make 5.2 available for downgrade, or is it a mater of having a repo enabled just to downgrade, if so what repo?
__________________
A Binary Bit lost in Binary Bit LAN
Vets Help Center
My Smolt Profile
Reply With Quote
  #2  
Old 22nd December 2009, 07:59 PM
marvin_ita Offline
Registered User
 
Join Date: Jun 2007
Location: Como - Italy
Posts: 259
linuxfedorafirefox
I think you have to install a plugin for yum to allow downgrade packages

Code:
yum install yum-plugin-allowdowngrade
never tried, but I think after that a "yum list php" should show you the older versions.
Reply With Quote
  #3  
Old 22nd December 2009, 08:19 PM
jflesher Offline
Registered User
 
Join Date: May 2007
Location: USA
Age: 53
Posts: 258
linuxfedorafirefox
yum-plugin-allowdowngrade has been integrated into yum for many versions of Fedora now.

All I see is 5.3, I wouldn't have asked if I seen 5.2; the "yum downgrade php" seems to fail due to nothing to downgrade too.
__________________
A Binary Bit lost in Binary Bit LAN
Vets Help Center
My Smolt Profile
Reply With Quote
  #4  
Old 20th December 2010, 08:55 PM
alexthegreat Offline
Registered User
 
Join Date: Dec 2010
Posts: 2
windows_7chrome
Re: Need to downgrade PHP 5.3 on F12

this link helped me a lot:

http://mirror.alva.ge/pub/other/php5.2fc12/

it contains all the packages needed. and i have installed them on Fedora 14 without any problem or any dependencies.

just delete your PHP 5.3 and install these ones one by one (it will tell you, if you're in wrong order).

wow! enjoy!
Reply With Quote
Reply

Tags
downgrade, f12, php

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
downgrade g++ wahaha Using Fedora 15 2nd August 2006 04:14 PM
Downgrade PHP 5 > 4 Robbie_ Installation, Upgrades and Live Media 3 22nd September 2005 02:43 PM
gcc downgrade LinuxHippy Using Fedora 10 5th August 2005 10:03 AM


Current GMT-time: 03:30 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Sterling - Cacapava do Sul - Sokolka