Fedora Linux Support Community & Resources Center
  #1  
Old 9th January 2010, 07:35 AM
chepioq Offline
Registered User
 
Join Date: Jun 2007
Location: Aubagne France
Age: 59
Posts: 501
linuxfirefox
kernel-2.6.32.2-18.fc13.x86_64 and akmod-nvidia-190.53-1.fc13.x86_64

I use akmod-nvidia for building kmod-nvidia for my rawhide and that work.
But with the latest kernel-2.6.32.2-18.fc13.x86_64 that don't work...
I have with vesa in 800x600,
Have you same problems?

==EDIT==
Here my boot.log
Code:
%G		Welcome to [0;34mFedora[0;39m 
		Press 'I' to enter interactive startup.
Démarrage de udev*: %G[60G[[0;32m  OK  [0;39m]

Configuration du nom d'hôte localhost.localdomain:  [60G[[0;32m  OK  [0;39m]

mdadm: No arrays found in config file or automatically
Configuration du gestionnaire de volume logique*:  [60G[[0;32m  OK  [0;39m]

Vérification des systèmes de fichiers
/dev/sda9*: propre, 286575/615296 fichiers, 2161183/2458464 blocs
/dev/sda8*: propre, 45/128016 fichiers, 82244/511996 blocs
/dev/sda7*: propre, 19614/903984 fichiers, 508022/3614617 blocs
[60G[[0;32m  OK  [0;39m]

Remontage du système de fichiers racine en mode lecture-écriture*:  [60G[[0;32m  OK  [0;39m]

Montage des systèmes de fichiers locaux*:  [60G[[0;32m  OK  [0;39m]

Activation des quotas des systèmes de fichiers locaux*:  [60G[[0;32m  OK  [0;39m]

Activation des /etc/fstab swaps*:  [60G[[0;32m  OK  [0;39m]

Début du démarrage non-interactif
Application de la mise à jour Microcode Intel CPU*: Application de la mise à jour Microcode Intel CPU*: Running DKMS auto installation service for kernel 2.6.32.2-18.fc13.x86_64
.Checking kmods exist for 2.6.32.2-18.fc13.x86_64[60G[[0;32m  OK  [0;39m]

Ignoring nvidia-kmod as it failed earlier[60G[[0;33mAVERTISSEMENT[0;39m]


Hint: Some kmods were ignored or failed to build or install.
You can try to rebuild and install them by by calling
'/usr/sbin/akmods --force' as root.

iptables*: Application des règles du pare-feu*: [60G[[0;32m  OK  [0;39m]

Checking for module nvidia.ko: [60G[[0;31mÉCHOUÉ[0;39m]

nvidia.ko for kernel 2.6.32.2-18.fc13.x86_64 was not found.[60G[[0;33mAVERTISSEMENT[0;39m]

The nvidia driver will not be enabled until one is found.[60G[[0;33mAVERTISSEMENT[0;39m]

Démarrage de portreserve*: [60G[[0;32m  OK  [0;39m]

Démarrage de l'enregistreur de journaux du système*: [60G[[0;32m  OK  [0;39m]

Enabling ondemand cpu frequency scaling: [60G[[0;32m  OK  [0;39m]

Démarrage de irqbalance*: [60G[[0;32m  OK  [0;39m]

Démarrage de rpcbind*: [60G[[0;32m  OK  [0;39m]

Démarrage du bus de messages du système*: [60G[[0;32m  OK  [0;39m]

Démarrage du démon Avahi... [60G[[0;32m  OK  [0;39m]

Démarrage de cups*: [60G[[0;32m  OK  [0;39m]

Démarrage du démon acpi*: [60G[[0;32m  OK  [0;39m]

Démarrage du démon HAL*: [60G[[0;32m  OK  [0;39m]

Starting lm_sensors: loading module coretemp [60G[[0;32m  OK  [0;39m]

Configuration des paramètres réseau...[60G[[0;32m  OK  [0;39m]

Démarrage du démon NetworkManager*: [60G[[0;32m  OK  [0;39m]

Démarrage du démon abrt*: [60G[[0;32m  OK  [0;39m]

Démarrage des services de souris pour la console*: [60G[[0;32m  OK  [0;39m]

Démarrage de crond*: [60G[[0;32m  OK  [0;39m]
[60G[[0;32m  OK  [0;39m]

Démarrage de atd*: [60G[[0;32m  OK  [0;39m]
[60G[[0;32m  OK  [0;39m]

Enregistrement du gestionnaire de binaire pour les applications Windows*: [60G[[0;32m  OK  [0;39m]

Last edited by chepioq; 9th January 2010 at 07:44 AM.
  #2  
Old 9th January 2010, 07:50 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Quote:
Originally Posted by chepioq View Post
I use akmod-nvidia for building kmod-nvidia for my rawhide and that work.
But with the latest kernel-2.6.32.2-18.fc13.x86_64 that don't work...
I have with vesa in 800x600,
Have you same problems?

==EDIT==
Here my boot.log
Code:
%G        Welcome to [0;34mFedora[0;39m 
        Press 'I' to enter interactive startup.
Démarrage de udev*: %G[60G[[0;32m  OK  [0;39m]

Configuration du nom d'hôte localhost.localdomain:  [60G[[0;32m  OK  [0;39m]

mdadm: No arrays found in config file or automatically
Configuration du gestionnaire de volume logique*:  [60G[[0;32m  OK  [0;39m]

Vérification des systèmes de fichiers
/dev/sda9*: propre, 286575/615296 fichiers, 2161183/2458464 blocs
/dev/sda8*: propre, 45/128016 fichiers, 82244/511996 blocs
/dev/sda7*: propre, 19614/903984 fichiers, 508022/3614617 blocs
[60G[[0;32m  OK  [0;39m]

Remontage du système de fichiers racine en mode lecture-écriture*:  [60G[[0;32m  OK  [0;39m]

Montage des systèmes de fichiers locaux*:  [60G[[0;32m  OK  [0;39m]

Activation des quotas des systèmes de fichiers locaux*:  [60G[[0;32m  OK  [0;39m]

Activation des /etc/fstab swaps*:  [60G[[0;32m  OK  [0;39m]

Début du démarrage non-interactif
Application de la mise à jour Microcode Intel CPU*: Application de la mise à jour Microcode Intel CPU*: Running DKMS auto installation service for kernel 2.6.32.2-18.fc13.x86_64
.Checking kmods exist for 2.6.32.2-18.fc13.x86_64[60G[[0;32m  OK  [0;39m]

Ignoring nvidia-kmod as it failed earlier[60G[[0;33mAVERTISSEMENT[0;39m]


Hint: Some kmods were ignored or failed to build or install.
You can try to rebuild and install them by by calling
'/usr/sbin/akmods --force' as root.

iptables*: Application des règles du pare-feu*: [60G[[0;32m  OK  [0;39m]

Checking for module nvidia.ko: [60G[[0;31mÉCHOUÉ[0;39m]

nvidia.ko for kernel 2.6.32.2-18.fc13.x86_64 was not found.[60G[[0;33mAVERTISSEMENT[0;39m]

The nvidia driver will not be enabled until one is found.[60G[[0;33mAVERTISSEMENT[0;39m]

Démarrage de portreserve*: [60G[[0;32m  OK  [0;39m]

Démarrage de l'enregistreur de journaux du système*: [60G[[0;32m  OK  [0;39m]

Enabling ondemand cpu frequency scaling: [60G[[0;32m  OK  [0;39m]

Démarrage de irqbalance*: [60G[[0;32m  OK  [0;39m]

Démarrage de rpcbind*: [60G[[0;32m  OK  [0;39m]

Démarrage du bus de messages du système*: [60G[[0;32m  OK  [0;39m]

Démarrage du démon Avahi... [60G[[0;32m  OK  [0;39m]

Démarrage de cups*: [60G[[0;32m  OK  [0;39m]

Démarrage du démon acpi*: [60G[[0;32m  OK  [0;39m]

Démarrage du démon HAL*: [60G[[0;32m  OK  [0;39m]

Starting lm_sensors: loading module coretemp [60G[[0;32m  OK  [0;39m]

Configuration des paramètres réseau...[60G[[0;32m  OK  [0;39m]

Démarrage du démon NetworkManager*: [60G[[0;32m  OK  [0;39m]

Démarrage du démon abrt*: [60G[[0;32m  OK  [0;39m]

Démarrage des services de souris pour la console*: [60G[[0;32m  OK  [0;39m]

Démarrage de crond*: [60G[[0;32m  OK  [0;39m]
[60G[[0;32m  OK  [0;39m]

Démarrage de atd*: [60G[[0;32m  OK  [0;39m]
[60G[[0;32m  OK  [0;39m]

Enregistrement du gestionnaire de binaire pour les applications Windows*: [60G[[0;32m  OK  [0;39m]

It work's with 2.6.26.3


Code:
[leigh@localhost ~]$ rpm -qa |grep -e Xorg -e nvidia |sort
kmod-nvidia-2.6.32.2-1.fc12.x86_64-195.30-1.fc12.x86_64
kmod-nvidia-2.6.32.3-10.fc12.x86_64-195.30-1.fc12.x86_64
nvidia-settings-1.0-3.2.fc12.x86_64
nvidia-xconfig-1.0-1.fc12.x86_64
xorg-x11-drv-nvidia-195.30-2.fc12.x86_64
xorg-x11-drv-nvidia-libs-195.30-2.fc12.i686
xorg-x11-drv-nvidia-libs-195.30-2.fc12.x86_64
xorg-x11-server-Xorg-1.7.4-1.fc12.x86_64
[leigh@localhost ~]$ uname  -r
2.6.32.3-10.fc12.x86_64
[leigh@localhost ~]$
I don't use akmod as I prefer DIY


Code:
rpmbuild --rebuild /home/leigh/development/rpmbuild/SRPMS/nvidia-kmod-195.30-1.fc12.src.rpm --define "kernels 2.6.32.3-10.fc12.x86_64" --target $(uname -m)
  #3  
Old 9th January 2010, 07:56 AM
chepioq Offline
Registered User
 
Join Date: Jun 2007
Location: Aubagne France
Age: 59
Posts: 501
linuxfirefox
I look on koji and there is no kernel-2.6.32.3-10 for fc13...
  #4  
Old 9th January 2010, 07:59 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Quote:
Originally Posted by chepioq View Post
I look on koji and there is no kernel-2.6.32.3-10 for fc13...

It works OK here with 2.6.32.2 as well.


Code:
[leigh@localhost ~]$ rpm -qa |grep -e Xorg -e nvidia |sort
kmod-nvidia-2.6.32.1-10.fc13.x86_64-190.53-1.fc13.x86_64
kmod-nvidia-2.6.32.2-14.fc13.x86_64-190.53-1.fc13.x86_64
kmod-nvidia-2.6.32.2-15.fc13.x86_64-190.53-1.fc13.x86_64
nvidia-settings-1.0-3.2.fc13.x86_64
nvidia-xconfig-1.0-1.fc13.x86_64
xorg-x11-drv-nvidia-190.53-1.fc13.x86_64
xorg-x11-drv-nvidia-libs-190.53-1.fc13.i686
xorg-x11-drv-nvidia-libs-190.53-1.fc13.x86_64
xorg-x11-server-Xorg-1.7.3-3.fc12.x86_64
[leigh@localhost ~]$ uname  -r
2.6.32.2-15.fc13.x86_64
[leigh@localhost ~]$ glxinfo |grep direct
direct rendering: Yes
    GL_EXT_direct_state_access, GL_EXT_draw_range_elements, GL_EXT_fog_coord, 
[leigh@localhost ~]$
  #5  
Old 9th January 2010, 08:20 AM
chepioq Offline
Registered User
 
Join Date: Jun 2007
Location: Aubagne France
Age: 59
Posts: 501
linuxfirefox
OK...
I download and install kernel-2.6.32.3-10 for fc12 and akmod-nvidia work...
Thank Leigh...
  #6  
Old 9th January 2010, 08:34 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedoramozilla
Quote:
Originally Posted by chepioq View Post
OK...
I download and install kernel-2.6.32.3-10 for fc12 and akmod-nvidia work...
Thank Leigh...

Just built myself a update.


Code:
[leigh@localhost ~]$ rpm -qa |grep -e Xorg -e nvidia |sort
kmod-nvidia-2.6.32.2-15.fc13.x86_64-195.30-1.fc13.x86_64
nvidia-settings-1.0-3.2.fc13.x86_64
nvidia-xconfig-1.0-1.fc13.x86_64
xorg-x11-drv-nvidia-195.30-2.fc13.x86_64
xorg-x11-drv-nvidia-libs-195.30-2.fc13.i686
xorg-x11-drv-nvidia-libs-195.30-2.fc13.x86_64
xorg-x11-server-Xorg-1.7.3-3.fc12.x86_64
[leigh@localhost ~]$
  #7  
Old 9th January 2010, 08:42 AM
chepioq Offline
Registered User
 
Join Date: Jun 2007
Location: Aubagne France
Age: 59
Posts: 501
linuxfirefox
Where did you find driver nvidia 195.30-1 ?
  #8  
Old 9th January 2010, 08:47 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedoramozilla
Quote:
Originally Posted by chepioq View Post
Where did you find driver nvidia 195.30-1 ?
DIY



http://forums.fedoraforum.org/showthread.php?t=237118
  #9  
Old 9th January 2010, 09:34 AM
chepioq Offline
Registered User
 
Join Date: Jun 2007
Location: Aubagne France
Age: 59
Posts: 501
linuxfirefox
OK leigh but that don't build akmod-nvidia...
  #10  
Old 9th January 2010, 09:40 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedoramozilla
Quote:
Originally Posted by chepioq View Post
OK leigh but that don't build akmod-nvidia...

Why do you need akmod ?, you DIY the kmod again before rebooting after the kernel update.


i.e I just installed 2.6.32.2-18.fc13.x86_64 , so I run this before rebooting.


Code:
rpmbuild -ba /home/leigh/rpmbuild/SPECS/nvidia-kmod.spec --define "kernels 2.6.32.2-18.fc13.x86_64" --target $(uname -m)
su
rpm -ivh /home/leigh/rpmbuild/RPMS/x86_64/kmod-nvidia-2.6.32.2-18.fc13.x86_64-195.30-1.fc13.x86_64.rpm
reboot
  #11  
Old 9th January 2010, 12:46 PM
chepioq Offline
Registered User
 
Join Date: Jun 2007
Location: Aubagne France
Age: 59
Posts: 501
linuxfirefox
Ok
I install the 195.30 version on my rawhide and that work...
But I don't see if it is better than 190.53, for me result are same...
  #12  
Old 9th January 2010, 12:56 PM
leigh123linux
Guest
 
Posts: n/a
linuxfedoramozilla
Quote:
Originally Posted by chepioq View Post
Ok
I install the 195.30 version on my rawhide and that work...
But I don't see if it is better than 190.53, for me result are same...

It's supposed to be quicker with KDE
  #13  
Old 9th January 2010, 04:45 PM
chepioq Offline
Registered User
 
Join Date: Jun 2007
Location: Aubagne France
Age: 59
Posts: 501
linuxfirefox
Quote:
Originally Posted by leigh123linux View Post
It's supposed to be quicker with KDE
I don't note that it is most quicker than the 190.53 with Kde...
I have an 8700M GT on my laptop, and Kde work fine (very fast.. ), with 190.53 and 195.30.
May be it is most quicker with the latest Nvidia cards....

==EDIT==
I just note one thing:
When I see a video on youtube, with 190.53 there is a little artifact, and with 195.30 video are very fluid, without artifact....

Last edited by chepioq; 9th January 2010 at 06:45 PM.
 

Tags
akmodnvidia1fc13x8664, kernel215fc13x8664

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC13 font problem? grothendieck Fedora 13 Development Branch 1 28th December 2009 04:48 PM
Question About Installing oprofile-0.9.6-1.fc13.x86_64.rpm on F12 dd_wizard Using Fedora 0 10th December 2009 07:28 PM
kernel 2.6.27.5-37 x86_64 and NVIDIA 177.73 CUDA Drivers - Xen? skamansam Using Fedora 2 15th November 2008 05:16 AM
Installing latest kernel-smp-2.6.15-1.1830_FC4.x86_64.rpm on FC3 x86_64 kmkale EOL (End Of Life) Versions 0 4th February 2006 08:56 AM


Current GMT-time: 11:59 (Saturday, 20-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat