Fedora Linux Support Community & Resources Center
  #1  
Old 16th January 2010, 02:29 AM
sej7278 Offline
Registered User
 
Join Date: Sep 2004
Posts: 2,008
linuxfedorafirefox
Sound is coming via headset AND speakers

Just installed F12 and noticed that the volume control applet is now all Pulseaudio rubbish, not Alsa like gmixer used to be.

So now I don't seem to be able to mute my speakers when I'm using my headset, which in F10 I could do by just muting LFE/Center.

Note I don't want the speakers to be disabled when I have the headphones plugged in (like Jack does) I just want to be able to control volume of the mixer channels individually - as sometimes I'll be playing music through the speakers and will receive a Skype call and want to mute the music, but also don't want the Skype sound coming out of the speakers - just the headphones.

I've tried setting up 4.1+input, 5.1+input, 4.0+input etc; but for some reason, even though the PulseAudio mixer thing has 5 individual sliders, they do nothing as they "jump" back to 100% when you slide them - even with the channels unlocked.

gmixer and alsamixer do the job, but pulseaudio is the applet and only seems to control the master volume, not the individual channels.

Any ideas - or perhaps a way to make gnome-volume-control revert back to actually being gmixer?
Reply With Quote
  #2  
Old 2nd May 2010, 12:48 AM
TheHammer Offline
Registered User
 
Join Date: Jan 2007
Posts: 24
linuxfedorafirefox
Re: Sound is coming via headset AND speakers

Try installing pavucontrol. That should allow you to control each application separately, although I have issues with it sometimes.
Reply With Quote
  #3  
Old 2nd May 2010, 02:32 AM
sej7278 Offline
Registered User
 
Join Date: Sep 2004
Posts: 2,008
linuxfedorafirefox
Re: Sound is coming via headset AND speakers

nothing regarding pulseaudio seems to work properly - its all nice ideas, but they just don't work in practice - i mean what use is muting one program when you have ten running?

the only way i can get sound to come from my headphones and not my speakers is by running this command:

amixer -c1 -q set Surround 0%

or of course using alsamixer, and then set it back to 100% when i'm done.
Reply With Quote
  #4  
Old 15th June 2010, 10:38 AM
naqviabbas Offline
Registered User
 
Join Date: Jul 2008
Posts: 1
linuxfedorafirefox
Re: Sound is coming via headset AND speakers

With fedora everything is at the surface. Most of us ignorantly neglect this fact.
Here is the solution :

Under gnome

System>preferences>sound

choose the "Output" tab

select the connector you want the audio to be routed to.
Reply With Quote
  #5  
Old 15th June 2010, 03:17 PM
BugRocks1 Offline
Registered User
 
Join Date: Jan 2010
Posts: 894
linuxfedorafirefox
Re: Sound is coming via headset AND speakers

To open gnome-volume-control on the output tab directly one can use this:
Quote:
gnome-volume-control -p output
If you only have one option in that tab and can't change anything you might want to see if your card model is being recognized correctly.

e.g.
Code:
echo 'options snd-hda-intel model=7stack' > /etc/modprobe.d/sound.conf
This creates a file named "sound.conf" in /etc/modprobe.d wiith a single line "options snd-hda-intel model=7stack"

You can also try the "model=auto" first it works sometimes if not you need to find the model.

To find out the model for your equipment you can try.

Quote:
Getting the driver's codec name:

cat /proc/asound/Intel/codec#0 | grep -i codec
or
cat /proc/asound/*/codec#0 | grep -i codec

• 1 - The path used in cat depends on your sound card, one can look inside /proc/asound to find out the exact path.

‣ Find the model list on http://git.alsa-project.org/ -> alsa-kmirror.git(tree) -> Documentation(tree) -> HD-Audio-Models.txt and check what model your codec is compatible with.
Reply With Quote
  #6  
Old 27th June 2010, 11:05 AM
guirgis Offline
Registered User
 
Join Date: Jun 2010
Posts: 9
linuxfirefox
Re: Sound is coming via headset AND speakers

Quote:
Originally Posted by BugRocks1 View Post
To open gnome-volume-control on the output tab directly one can use this:


If you only have one option in that tab and can't change anything you might want to see if your card model is being recognized correctly.

e.g.
Code:
echo 'options snd-hda-intel model=7stack' > /etc/modprobe.d/sound.conf
This creates a file named "sound.conf" in /etc/modprobe.d wiith a single line "options snd-hda-intel model=7stack"

You can also try the "model=auto" first it works sometimes if not you need to find the model.

To find out the model for your equipment you can try.
I have the same problem and i did what you said exactly, but i didn't find a compatible model with my codec:
Conexant ID 5067.
The only way i found to mute the speakers sound while the headset is plugged is to move the slider on the output tab of the sound manger to the maximum left but the problem is that the sound become mono as if the speakers are right and the headset are left which is the not as supposed to be?
So Any suggestions? Thanks in advance.
Reply With Quote
Reply

Tags
coming, headset, sound, speakers

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
weird sound card issue: sound out in rear speakers only lovemov Hardware & Laptops 0 27th April 2009 08:25 PM
Intel 82801I sound: speakers OK but no headphone sound wneumann Hardware & Laptops 2 13th January 2009 04:00 AM
Sound outputs OK, but inserting headphones does not mute speakers nor gives any sound sardaukar_siet Hardware & Laptops 1 2nd December 2008 08:35 AM
Getting sound to work through my headset instead of my speakers reddem0n Hardware & Laptops 10 16th April 2008 04:19 PM
Sound coming out both Speakers and Headphones shortchar Hardware & Laptops 0 19th July 2007 07:33 PM


Current GMT-time: 02:49 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Porto De Nacala - Perangin Mall Penang Photos