Fedora Linux Support Community & Resources Center
  #1  
Old 23rd January 2010, 07:06 PM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
linuxfedorafirefox
Annoying Radeon bug... still present.

Any one here using the Open Source ati driver for Xorg?

Well, I do. And I really like the drivers, except for one fact: They still have an annoying bug that prevent my two laptopts with ATI graphics chips to properly resume from hybernation. Basically what happens is that the screen is all messed up and while I can still do things, it is totally impossible to actually read anything as fonts are all messed. See the attachment...

I'd thought I had reported this back when I first saw this, but I guess I didn't so I just did report this to the two project sites, The Free Desktop and Red Hat and Fedora's Bugzilla:

FreeDesktop bug report
Red Hat and Fedora Bugzilla bug report
Attached Thumbnails
Click image for larger version

Name:	Pantallazo.png
Views:	104
Size:	65.7 KB
ID:	18951  
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
  #2  
Old 25th January 2010, 12:18 AM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
I don't see any problem here with Hibernation using the open source driver. This is on an ATI Mobility Radeon 9600 w/64MB VRAM. I have a 2MB swap file. I use nomodeset to disable KMS in /boot/grub/menu.lst.
Code:
title Fedora (2.6.31.9-174.fc12.i686)
	root (hd0,4)
	kernel /vmlinuz-2.6.31.9-174.fc12.i686 ro root=UUID=5aa7eb85-7489-4d14-ba56-d9b7212d43d4  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet nomodeset
	initrd /initramfs-2.6.31.9-174.fc12.i686.img
Here is my xorg.conf file:
Code:
$ cat /etc/X11/xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by system-config-display
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105+inet"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
        Option      "AccelMethod" "XAA"
	Option	    "AGPMode" "4"
	Option	    "GARTSize" "64"
	Option	    "EnablePageFlip" "on"
	Option	    "ColorTiling" "on"
	Option	    "DPMS" "on"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #3  
Old 25th January 2010, 04:48 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
linuxfedorafirefox
Yes, I know that this only happens with KMS, and that the problem actually lies within the DRM code. This doesn't make it any less annoying, and apparently there is already beta code to address this.
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
  #4  
Old 25th January 2010, 04:59 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
There may be a good reason for KMS, but all I can see that it does is provide a nicer boot up screen.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #5  
Old 26th January 2010, 03:12 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
linuxfedorafirefox
And seamless transition, and native resolution system virtual terminals, and a few other things I *do* use. Also for some reason KMS makes sure X is set right without the need of manually configuring xorg.conf (I've done it for the longest time, it is nice, for once, not to have to)
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
Reply

Tags
annoying, bug, present, radeon

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
aannoying,annoying and annoying java phrgarek Using Fedora 6 29th August 2007 02:28 PM
Mobility Radeon X1400 not accepting the RADEON driver keeler1 Hardware & Laptops 0 24th November 2006 01:22 AM
nother dual head: Radeon 9200 + Radeon 7500 ZeuS572 Hardware & Laptops 2 15th June 2005 05:03 PM
ATI 3.12.0 driver issuesATI Radeon Mobility U1, aka ATI Radeon IGP 320M drivers? jroysdon Hardware & Laptops 1 12th September 2004 08:31 AM


Current GMT-time: 11:45 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Jintur Instagram Photos - Nowogard Travel Photos - Democratic Republic of the Congo Instagram Photos