Fedora Linux Support Community & Resources Center
  #1  
Old 16th February 2010, 12:28 PM
96th Offline
Registered User
 
Join Date: Jun 2009
Location: Morecambe/UK
Posts: 42
linuxfedorafirefox
nVidia GeForce FX 5500 KMOD problem

Hello. I have installed kmod-nvidia-173xx and done everything your guide says (http://www.mjmwired.net/resources/mj...a-nvidia.html#), but after reboot I get a flashing _ . What can I do? nVidia has always been a pain to me on my obsolete graphics card.
Reply With Quote
  #2  
Old 16th February 2010, 02:26 PM
macemoneta Offline
Registered User
 
Join Date: May 2004
Location: NJ
Posts: 913
linuxsafari
- Switch to a tty session: ctrl-alt-f2
- Login as root
- Edit your /etc/grub.conf, and replace 'rhgb' with 'nomodeset'
Reply With Quote
  #3  
Old 16th February 2010, 02:35 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,121
linuxfedorafirefox
Here's an excellent Guide: http://forums.fedoraforum.org/showthread.php?t=204752
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #4  
Old 16th February 2010, 02:40 PM
macemoneta Offline
Registered User
 
Join Date: May 2004
Location: NJ
Posts: 913
linuxsafari
@bob It's an excellent guide, but I find using nomodeset instead of rdblacklist=nouveau easier. You have to edit grub.conf anyway, and with nomodeset you don't need to rerun dracut. It's easily reversed too, if you want to check something with the nouveau driver.
Reply With Quote
  #5  
Old 16th February 2010, 02:44 PM
96th Offline
Registered User
 
Join Date: Jun 2009
Location: Morecambe/UK
Posts: 42
linuxfedorafirefox
I have managed to log in, but the drivers are still not working. nvidia-settings says:
Quote:
Unable to load X Server Display Configuration page:
Failed to query NoScanout for screen 0.
Livna doesn't change the resolution and system-settings-display and the "Screen/Display" thing in Menu->Preferences only allow 640x480 (Ill just connect my mobile as a screen, maybe?-joke).

@bob: I'm trying your guide now.
Reply With Quote
  #6  
Old 16th February 2010, 02:49 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
linuxfedorafirefox
Quote:
Originally Posted by bob View Post
I have the same video card FX5500 and using the above guide worked for me. All i had to to was to edit xorg.conf to set my monitor's screen resolution.
Reply With Quote
  #7  
Old 16th February 2010, 02:55 PM
96th Offline
Registered User
 
Join Date: Jun 2009
Location: Morecambe/UK
Posts: 42
linuxfedorafirefox
@errorxp: I feel so sorry for you

I've done the guide but it didn't change my resolution. I also edited xorg.conf to add my resolution but still no luck. I provide it below here: http://pastebin.com/m650c484d
Reply With Quote
  #8  
Old 16th February 2010, 03:45 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
linuxfedorafirefox
my xorg.conf is rather simple since i can't run nvidia display configuration tool to create one (Failed to query NoScanout for screen 0.)

so i've just added Section "Screen" to the default xorg.conf file. it looks like this

Code:
# Xorg configuration created by livna-config-display

Section "Files"
	ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection

Section "Screen"
Identifier "screen0"
Device "Videocard0"
Monitor "monitor0"
DefaultColorDepth 24

Subsection "Display"
Depth 24
Modes "1024x768" "1280x800"
EndSubsection
EndSection
maybe if you changed Identifier "Default Screen" to "screen0" in your configuration...just a thought.

Last edited by errorxp; 16th February 2010 at 03:51 PM.
Reply With Quote
  #9  
Old 16th February 2010, 03:57 PM
96th Offline
Registered User
 
Join Date: Jun 2009
Location: Morecambe/UK
Posts: 42
linuxfedorafirefox
I am now using your xorg.conf, but I still get 640x480... I cannot change it either... It worked on OpenSuSE with even higher resolutions.
Reply With Quote
  #10  
Old 16th February 2010, 04:08 PM
errorxp Offline
Registered User
 
Join Date: Jul 2007
Posts: 371
linuxfedorafirefox
did you get higher resolutions than 640x480 with the nouveau driver?
Reply With Quote
  #11  
Old 16th February 2010, 04:10 PM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Quote:
Originally Posted by macemoneta View Post
@bob It's an excellent guide, but I find using nomodeset instead of rdblacklist=nouveau easier. You have to edit grub.conf anyway, and with nomodeset you don't need to rerun dracut. It's easily reversed too, if you want to check something with the nouveau driver.

FYI the rdblacklist=nouveau option does work without rerunning dracut (it does for me anyway)
Reply With Quote
  #12  
Old 16th February 2010, 04:24 PM
96th Offline
Registered User
 
Join Date: Jun 2009
Location: Morecambe/UK
Posts: 42
linuxfedorafirefox
@errorxp: It doesn't work at all...

//Me: vesa works fine in 1024x760...

//Edit: I had enough. Vesa with 1024x760 will be enough for a server.

Last edited by 96th; 18th February 2010 at 08:22 PM.
Reply With Quote
  #13  
Old 10th March 2010, 12:44 AM
daytooner Offline
Registered User
 
Join Date: Apr 2009
Posts: 210
linuxfedorafirefox
Re: nVidia GeForce FX 5500 KMOD problem

I just ran the nvidia guide for getting rid of nouveau and using the nvidia drivers.

But now I can only get 1024x768 resolution. Before, I was using the nv driver, but with an earlier kernel. I just ran an upgrade that loaded a new kernel (2.6.32.9-67.fc12.i686) and then ran the howto guide in the sticky forum.

What do I do now?

TIA

ken
Reply With Quote
  #14  
Old 11th March 2010, 07:46 PM
daytooner Offline
Registered User
 
Join Date: Apr 2009
Posts: 210
linuxfedorafirefox
Re: nVidia GeForce FX 5500 KMOD problem

Well I solved my problem (screen resolution limits).

All I had to do was to put this line in xorg.conf:

Modes "1600x1200"

and voila, I had 1600x1200. I guess I could even try higher resolutions this way. Seems that the nVidia driver could'nt detect my monitor capabilities. as previous drivers had.

I also downloaded and tried the latest software from nVidia. But for some reason, it wanted my fedora source tree, which I don't have on that box. This is working fine - for now - so I'll just wait till the next kernel update with those drivers comes out.

ken
Reply With Quote
  #15  
Old 13th March 2010, 05:42 PM
daytooner Offline
Registered User
 
Join Date: Apr 2009
Posts: 210
linuxfedorafirefox
Re: nVidia GeForce FX 5500 KMOD problem

Quote:
Originally Posted by daytooner View Post
Well I solved my problem (screen resolution limits).

All I had to do was to put this line in xorg.conf:

Modes "1600x1200"
So, now my next logical question is: what modes are available? I have a large LCD display that I would like a better resolution, but I can't find a list of valid defiined modes. Is there one?

TIA

ken
Reply With Quote
Reply

Tags
5500, geforce, kmod, nvidia, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I fix my Nvidia Geforce FX 5500? Jamanne Wibble 4 2nd February 2010 11:08 PM
nvidia geforce 5500 fx, s-video not working leftoflexo Hardware & Laptops 1 3rd January 2010 03:37 AM
Problem with nVidia GeForce FX 5500 goxi Using Fedora 6 2nd September 2009 10:22 PM
NVIDIA GeForce 5500 PCI Died... LatinHacker Hardware & Laptops 14 19th December 2008 02:54 AM
NVidia Geforce FX 5500 on FC3 Sr Ramitas Hardware & Laptops 5 17th July 2005 03:36 PM


Current GMT-time: 16:28 (Saturday, 30-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat