Fedora Linux Support Community & Resources Center
  #1  
Old 17th February 2010, 07:51 AM
crasypantz Offline
Registered User
 
Join Date: Jun 2009
Posts: 18
windows_xp_2003firefox
Trouble upgrading to FC12 due to conflicts and dependency problems

Greetings. I've been trying to upgrade my installation for some time now and just can't quite get it right. I would upgrade from the DVD but the installer hangs when it says "Looking for installation images on CD device /dev/sr0". However, that's not really my question. I've resorted to the upgrade instructions as found at http://fedoraproject.org/wiki/YumUpgradeFaq. If I don't use the '--skip-broken' option it complains about the following:

abrt-gui-0.0.11-1.fc12.x86_64 from fedora
abrt-libs-1.0.6-1.fc12.x86_64 from updates
samba-3.4.5-55.fc12.x86_64 from updates
samba-client-3.4.5-55.fc12.x86_64 from updates
samba-common-3.4.5-55.fc12.x86_64 from updates
samba-winbind-3.4.5-55.fc12.x86_64 from updates
samba-winbind-clients-3.4.5-55.fc12.x86_64 from updates

If I use the skip broken option, it then complains about:

Transaction Check Error:
file /usr/share/locale/de/LC_MESSAGES/cryptsetup.mo from install of cryptsetup-luks-1.1.0-0.4.fc12.x86_64 conflicts with file from package cryptsetup-luks-1.0.6-7.fc11.i586
file /usr/share/locale/sv/LC_MESSAGES/cryptsetup.mo from install of cryptsetup-luks-1.1.0-0.4.fc12.x86_64 conflicts with file from package cryptsetup-luks-1.0.6-7.fc11.i586
file /usr/share/man/man8/cryptsetup.8.gz from install of cryptsetup-luks-1.1.0-0.4.fc12.x86_64 conflicts with file from package cryptsetup-luks-1.0.6-7.fc11.i586

I can't seem to remedy this problem. There were other conflicts but I just removed those packages. When I attempt to remove 'cryptsetup-luks' it then tells me it's going to remove something like 200 others which did not sound like a good idea.

If someone can point me in the correct direction I will definitely appreciate it. Thanks. Jerry.
Reply With Quote
  #2  
Old 17th February 2010, 09:15 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,623
linuxfedorafirefox
When you say "it complains about the following", how so? What is the error output?
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #3  
Old 17th February 2010, 06:12 PM
crasypantz Offline
Registered User
 
Join Date: Jun 2009
Posts: 18
windows_xp_2003firefox
The complete output appears to be way too large for this post so I'll try to note the points of interest. I simply used "yum upgrade" for the following:

Quote:
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.us.unixeria.com
* livna: rpm.livna.org
* rpmfusion-free: lordmorgul.net
* rpmfusion-free-updates: lordmorgul.net
* rpmfusion-nonfree: lordmorgul.net
* rpmfusion-nonfree-updates: lordmorgul.net
* updates: ftp.us.unixeria.com
atrpms | 3.0 kB 00:00
Setting up Upgrade Process
Resolving Dependencies

...
---> Package baekmuk-ttf-fonts-common.noarch 0:2.2-22.fc12 set to be updated
---> Package baekmuk-ttf-fonts-ghostscript.noarch 0:2.2-22.fc12 set to be updated
/usr/lib/python2.6/site-packages/yum/packages.py:413: UnicodeWarning: Unicode unequal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
if reqn != n:
---> Package baekmuk-ttf-gulim-fonts.noarch 0:2.2-22.fc12 set to be updated
---> Package baekmuk-ttf-hline-fonts.noarch 0:2.2-22.fc12 set to be updated
...

--> Processing Dependency: samba-common = 3.4.2-0.42.fc11 for package: samba-winbind-3.4.2-0.42.fc11.i586
---> Package samba-winbind-clients.x86_64 0:3.4.5-55.fc12 set to be updated
---> Package setools-libs-python.x86_64 0:3.3.6-4.fc12 set to be updated
---> Package slf4j.noarch 0:1.5.8-5.fc12 set to be updated
---> Package system-config-firewall-base.noarch 0:1.2.21-1.fc12 set to be updated
---> Package telepathy-glib.x86_64 0:0.9.0-1.fc12 set to be updated
---> Package transmission-common.x86_64 0:1.83-2.fc12 set to be updated
---> Package unicap.i686 0:0.9.5-3.fc12 set to be updated
---> Package unicap.x86_64 0:0.9.5-3.fc12 set to be updated
---> Package unique.i686 0:1.1.6-1.fc12 set to be updated
---> Package xcb-util.i686 0:0.3.6-1.fc12 set to be updated
---> Package xcb-util.x86_64 0:0.3.6-1.fc12 set to be updated
---> Package xmlrpc.x86_64 0:2.0.1-6.5.fc12 set to be updated
---> Package xmlunit.x86_64 0:1.0-8.2.fc12 set to be updated
---> Package xsane-common.x86_64 0:0.997-3.fc12 set to be updated
--> Running transaction check
---> Package abrt-gui.x86_64 0:0.0.11-1.fc12 set to be updated
--> Processing Dependency: abrt = 0.0.11-1.fc12 for package: abrt-gui-0.0.11-1.fc12.x86_64
---> Package constantine-backgrounds-single.noarch 0:12.1.1-2.fc12 set to be updated
---> Package dash.x86_64 0:0.5.5.1-3.fc12 set to be updated
---> Package eclipse-emf.noarch 0:2.5.0-4.fc12 set to be updated
---> Package foomatic-db-filesystem.noarch 0:4.0-8.20091126.fc12 set to be updated
---> Package foomatic-db-ppds.noarch 0:4.0-8.20091126.fc12 set to be updated
---> Package freemarker.noarch 0:2.3.13-6.fc12 set to be updated
---> Package ini4j.noarch 0:0.4.1-2.fc12 set to be updated
---> Package libmcpp.x86_64 0:2.7.2-4.fc12 set to be updated
---> Package libudev.i686 0:145-15.fc12 set to be updated
---> Package lm_sensors-libs.x86_64 0:3.1.2-1.fc12 set to be updated
---> Package maven-shared-monitor.noarch 0:1.0-3.fc12 set to be updated
---> Package netbeans-resolver.noarch 0:6.7.1-1.fc12 set to be updated
---> Package netbeans-svnclientadapter.noarch 0:6.7.1-2.fc12 set to be updated
---> Package perl-Geography-Countries.noarch 0:1.4-5.fc12 set to be updated
---> Package perl-Heap.noarch 0:0.80-4.fc12 set to be updated
---> Package perl-Socket-GetAddrInfo.x86_64 0:0.12-1.fc12 set to be updated
---> Package python-bugzilla.noarch 0:0.5.1-3.fc12 set to be updated
---> Package python-logilab-astng.noarch 0:0.19.1-1.fc12 set to be updated
--> Processing Dependency: python-logilab-common for package: python-logilab-astng-0.19.1-1.fc12.noarch
---> Package report.x86_64 0:0.7-1.fc12 set to be updated
---> Package report-plugin-bugzilla.x86_64 0:0.7-1.fc12 set to be updated
--> Processing Dependency: samba-common = 3.4.2-0.42.fc11 for package: samba-winbind-3.4.2-0.42.fc11.i586
---> Package sgpio.x86_64 0:1.2.0.10-4.fc12 set to be updated
---> Package xmlrpc-c.x86_64 0:1.16.6-3.1582.fc12 set to be updated
---> Package xmlrpc-c-client.x86_64 0:1.16.6-3.1582.fc12 set to be updated
--> Running transaction check
---> Package abrt-gui.x86_64 0:0.0.11-1.fc12 set to be updated
--> Processing Dependency: abrt = 0.0.11-1.fc12 for package: abrt-gui-0.0.11-1.fc12.x86_64
---> Package python-logilab-common.noarch 0:0.45.0-1.fc12 set to be updated
--> Processing Dependency: samba-common = 3.4.2-0.42.fc11 for package: samba-winbind-3.4.2-0.42.fc11.i586
--> Finished Dependency Resolution
samba-winbind-3.4.2-0.42.fc11.i586 from installed has depsolving problems
--> Missing Dependency: samba-common = 3.4.2-0.42.fc11 is needed by package samba-winbind-3.4.2-0.42.fc11.i586 (installed)
abrt-gui-0.0.11-1.fc12.x86_64 from fedora has depsolving problems
--> Missing Dependency: abrt = 0.0.11-1.fc12 is needed by package abrt-gui-0.0.11-1.fc12.x86_64 (fedora)
--> Running transaction check
---> Package abrt-gui.x86_64 0:0.0.11-1.fc12 set to be updated
--> Processing Dependency: abrt = 0.0.11-1.fc12 for package: abrt-gui-0.0.11-1.fc12.x86_64
---> Package kernel.x86_64 0:2.6.30.8-64.fc11 set to be erased
--> Processing Dependency: kernel-uname-r = 2.6.30.8-64.fc11.x86_64 for package: kmod-nvidia-2.6.30.8-64.fc11.x86_64-190.42-1.fc11.x86_64
---> Package kernel-devel.x86_64 0:2.6.30.8-64.fc11 set to be erased
--> Processing Dependency: samba-common = 3.4.2-0.42.fc11 for package: samba-winbind-3.4.2-0.42.fc11.i586
--> Running transaction check
---> Package abrt-gui.x86_64 0:0.0.11-1.fc12 set to be updated
--> Processing Dependency: abrt = 0.0.11-1.fc12 for package: abrt-gui-0.0.11-1.fc12.x86_64
---> Package kmod-nvidia-2.6.30.8-64.fc11.x86_64.x86_64 0:190.42-1.fc11 set to be erased
--> Processing Dependency: samba-common = 3.4.2-0.42.fc11 for package: samba-winbind-3.4.2-0.42.fc11.i586
--> Finished Dependency Resolution
samba-winbind-3.4.2-0.42.fc11.i586 from installed has depsolving problems
--> Missing Dependency: samba-common = 3.4.2-0.42.fc11 is needed by package samba-winbind-3.4.2-0.42.fc11.i586 (installed)
abrt-gui-0.0.11-1.fc12.x86_64 from fedora has depsolving problems
--> Missing Dependency: abrt = 0.0.11-1.fc12 is needed by package abrt-gui-0.0.11-1.fc12.x86_64 (fedora)
Error: Missing Dependency: abrt = 0.0.11-1.fc12 is needed by package abrt-gui-0.0.11-1.fc12.x86_64 (fedora)
Error: Missing Dependency: samba-common = 3.4.2-0.42.fc11 is needed by package samba-winbind-3.4.2-0.42.fc11.i586 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
Reply With Quote
  #4  
Old 17th February 2010, 07:52 PM
Dies Offline
Registered User
 
Join Date: Oct 2006
Posts: 4,754
linuxubuntufirefox
Are you really trying to upgrade from i586 to x86_64?

Or is that just a bunch of "multilib" going on?
Reply With Quote
  #5  
Old 17th February 2010, 08:52 PM
crasypantz Offline
Registered User
 
Join Date: Jun 2009
Posts: 18
windows_xp_2003firefox
Upgrading from i586 to x86_64... Just kidding. It's an x86_64 installation. As you said- the i586's must be from multilibs.
Reply With Quote
  #6  
Old 18th February 2010, 12:53 AM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
as none of those packages is actually vital to the functioning of the system, I'd just remove them, do the upgrade, then reinstall them afterwards.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #7  
Old 18th February 2010, 02:51 AM
crasypantz Offline
Registered User
 
Join Date: Jun 2009
Posts: 18
windows_xp_2003firefox
I don't know if I'm closer or farther but I uninstalled 'samba-common' and that in turn uninstalled several things. Running yum upgrade after this yielded the tailing output:

--> Finished Dependency Resolution
abrt-gui-0.0.11-1.fc12.x86_64 from fedora has depsolving problems
--> Missing Dependency: abrt = 0.0.11-1.fc12 is needed by package abrt-gui-0.0.11-1.fc12.x86_64 (fedora)
--> Running transaction check
---> Package abrt-gui.x86_64 0:0.0.11-1.fc12 set to be updated
--> Processing Dependency: abrt = 0.0.11-1.fc12 for package: abrt-gui-0.0.11-1.fc12.x86_64
---> Package kernel.x86_64 0:2.6.30.8-64.fc11 set to be erased
--> Processing Dependency: kernel-uname-r = 2.6.30.8-64.fc11.x86_64 for package: kmod-nvidia-2.6.30.8-64.fc11.x86_64-190.42-1.fc11.x86_64
---> Package kernel-devel.x86_64 0:2.6.30.8-64.fc11 set to be erased
--> Running transaction check
---> Package abrt-gui.x86_64 0:0.0.11-1.fc12 set to be updated
--> Processing Dependency: abrt = 0.0.11-1.fc12 for package: abrt-gui-0.0.11-1.fc12.x86_64
---> Package kmod-nvidia-2.6.30.8-64.fc11.x86_64.x86_64 0:190.42-1.fc11 set to be erased
--> Finished Dependency Resolution
abrt-gui-0.0.11-1.fc12.x86_64 from fedora has depsolving problems
--> Missing Dependency: abrt = 0.0.11-1.fc12 is needed by package abrt-gui-0.0.11-1.fc12.x86_64 (fedora)
Error: Missing Dependency: abrt = 0.0.11-1.fc12 is needed by package abrt-gui-0.0.11-1.fc12.x86_64 (fedora)

If I then attempt to install abrt I get:

Transaction Check Error:
file /usr/share/man/man5/dhcp-eval.5.gz from install of dhcp-12:4.1.1-5.fc12.x86_64 conflicts with file from package dhclient-12:4.1.0p1-5.fc11.x86_64
file /usr/share/man/man5/dhcp-options.5.gz from install of dhcp-12:4.1.1-5.fc12.x86_64 conflicts with file from package dhclient-12:4.1.0p1-5.fc11.x86_64

I think we're getting there but I'm still lost in what to do.
Reply With Quote
  #8  
Old 18th February 2010, 09:30 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
remove abrt and abrt-gui. Then do the update, and reinstall samba-common and abrt and abrt-gui, and anything else that got pulled out along with them.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #9  
Old 19th February 2010, 12:17 AM
crasypantz Offline
Registered User
 
Join Date: Jun 2009
Posts: 18
windows_xp_2003firefox
yum tells me i don't have either installed:

[root@tequila patron]# yum remove abrt
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Setting up Remove Process
No Match for argument: abrt
Loading mirror speeds from cached hostfile
* fedora: ftp.us.unixeria.com
* livna: rpm.livna.org
* rpmfusion-free: mirror.web-ster.com
* rpmfusion-free-updates: mirror.web-ster.com
* rpmfusion-nonfree: lordmorgul.net
* rpmfusion-nonfree-updates: lordmorgul.net
* updates: ftp.us.unixeria.com
Package(s) abrt available, but not installed.
No Packages marked for removal
[root@tequila patron]# yum remove abrt-gui
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Setting up Remove Process
No Match for argument: abrt-gui
Loading mirror speeds from cached hostfile
* fedora: ftp.us.unixeria.com
* livna: rpm.livna.org
* rpmfusion-free: mirror.web-ster.com
* rpmfusion-free-updates: mirror.web-ster.com
* rpmfusion-nonfree: lordmorgul.net
* rpmfusion-nonfree-updates: lordmorgul.net
* updates: ftp.us.unixeria.com
Package(s) abrt-gui available, but not installed.
No Packages marked for removal
[root@tequila patron]#
Reply With Quote
  #10  
Old 19th February 2010, 08:14 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
huh. so the update wants to install abrt-gui but, for some reason, can't find abrt. that's odd. what does 'yum search abrt' return?
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #11  
Old 24th February 2010, 01:16 AM
crasypantz Offline
Registered User
 
Join Date: Jun 2009
Posts: 18
windows_xp_2003firefox
'yum search abrt' gets me the following:

Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.us.unixeria.com
* livna: rpm.livna.org
* rpmfusion-free: mirror.web-ster.com
* rpmfusion-free-updates: mirror.web-ster.com
* rpmfusion-nonfree: mirror.web-ster.com
* rpmfusion-nonfree-updates: mirror.web-ster.com
* updates: mirrors.pavlovmedia.net
================================================== ================================================== =========== Matched: abrt ================================================== ================================================== ===========
abrt.x86_64 : Automatic bug detection and reporting tool
abrt-addon-ccpp.x86_64 : abrt's C/C++ addon
abrt-addon-kerneloops.x86_64 : abrt's kerneloops addon
abrt-addon-python.x86_64 : abrt's addon for catching and analyzing Python exceptions
abrt-cli.x86_64 : abrt's command line interface
abrt-desktop.x86_64 : Virtual package to install all necessary packages for usage from desktop environment
abrt-devel.i686 : Development libraries for abrt
abrt-devel.x86_64 : Development libraries for abrt
abrt-gui.x86_64 : abrt's gui
abrt-libs.i686 : Libraries for abrt
abrt-libs.x86_64 : Libraries for abrt
abrt-plugin-bugzilla.x86_64 : abrt's bugzilla plugin
abrt-plugin-catcut.x86_64 : abrt's catcut plugin
abrt-plugin-filetransfer.x86_64 : abrt's File Transfer plugin
abrt-plugin-kerneloopsreporter.x86_64 : abrt's kerneloops reporter plugin
abrt-plugin-logger.x86_64 : abrt's logger reporter plugin
abrt-plugin-mailx.x86_64 : abrt's mailx reporter plugin
abrt-plugin-runapp.x86_64 : abrt's runapp plugin
abrt-plugin-sosreport.x86_64 : abrt's sosreport plugin
abrt-plugin-sqlite3.x86_64 : abrt's SQLite3 database plugin
abrt-plugin-ticketuploader.x86_64 : abrt's ticketuploader plugin
Reply With Quote
  #12  
Old 2nd March 2010, 07:19 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
linuxfedorafirefox
grrrmph. um. what does 'yum update dhclient' give?
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #13  
Old 2nd March 2010, 07:48 PM
alexuk Offline
Registered User
 
Join Date: Aug 2008
Location: London, UK
Posts: 69
linuxfedorafirefox
Similar case here.
Did today an upgrade fc11-> fc12 on another machine and at the first update I found lots of remaining fc11 packages? Not sure I remember seeing this before? Any solution other than removing/reinstalling by hand?

Quote:
$ sudo yum update
Loaded plugins: dellsysidplugin2, refresh-packagekit
adobe-linux-i386 | 951 B 00:00
updates/metalink | 21 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package boinc-client.x86_64 0:6.10.33-1.r20470svn.fc11 set to be updated
--> Processing Dependency: libssl.so.8()(64bit) for package: boinc-client-6.10.33-1.r20470svn.fc11.x86_64
--> Processing Dependency: libcrypto.so.8()(64bit) for package: boinc-client-6.10.33-1.r20470svn.fc11.x86_64
---> Package boinc-manager.x86_64 0:6.10.33-1.r20470svn.fc11 set to be updated
--> Processing Dependency: libssl.so.8()(64bit) for package: boinc-manager-6.10.33-1.r20470svn.fc11.x86_64
--> Processing Dependency: libcrypto.so.8()(64bit) for package: boinc-manager-6.10.33-1.r20470svn.fc11.x86_64
---> Package kdebase.x86_64 6:4.4.0-5.fc11 set to be updated
---> Package kdebase-libs.x86_64 6:4.4.0-5.fc11 set to be updated
---> Package kdebase-workspace.x86_64 0:4.4.0-8.fc11 set to be updated
--> Processing Dependency: libxklavier.so.12()(64bit) for package: kdebase-workspace-4.4.0-8.fc11.x86_64
---> Package kdebase-workspace-libs.x86_64 0:4.4.0-8.fc11 set to be updated
---> Package kdm.x86_64 0:4.4.0-8.fc11 set to be updated
---> Package ksysguardd.x86_64 0:4.4.0-8.fc11 set to be updated
---> Package mc.x86_64 1:4.7.1-1.fc11 set to be updated
---> Package qt.i586 1:4.6.2-3.fc11 set to be updated
--> Processing Dependency: libssl.so.8 for package: 1:qt-4.6.2-3.fc11.i586
--> Processing Dependency: libcrypto.so.8 for package: 1:qt-4.6.2-3.fc11.i586
---> Package qt.x86_64 1:4.6.2-3.fc11 set to be updated
--> Processing Dependency: libssl.so.8()(64bit) for package: 1:qt-4.6.2-3.fc11.x86_64
--> Processing Dependency: libcrypto.so.8()(64bit) for package: 1:qt-4.6.2-3.fc11.x86_64
---> Package qt-mysql.x86_64 1:4.6.2-3.fc11 set to be updated
--> Processing Dependency: libssl.so.8()(64bit) for package: 1:qt-mysql-4.6.2-3.fc11.x86_64
--> Processing Dependency: libcrypto.so.8()(64bit) for package: 1:qt-mysql-4.6.2-3.fc11.x86_64
---> Package qt-sqlite.i586 1:4.6.2-3.fc11 set to be updated
---> Package qt-sqlite.x86_64 1:4.6.2-3.fc11 set to be updated
---> Package qt-x11.i586 1:4.6.2-3.fc11 set to be updated
---> Package qt-x11.x86_64 1:4.6.2-3.fc11 set to be updated
---> Package thunderbird.x86_64 0:3.0.2-1.fc11 set to be updated
---> Package transmission-common.x86_64 0:1.91-1.fc11 set to be updated
--> Processing Dependency: libssl.so.8()(64bit) for package: transmission-common-1.91-1.fc11.x86_64
--> Processing Dependency: libcrypto.so.8()(64bit) for package: transmission-common-1.91-1.fc11.x86_64
---> Package transmission-gtk.x86_64 0:1.91-1.fc11 set to be updated
--> Processing Dependency: libssl.so.8()(64bit) for package: transmission-gtk-1.91-1.fc11.x86_64
--> Processing Dependency: libcrypto.so.8()(64bit) for package: transmission-gtk-1.91-1.fc11.x86_64
---> Package vlgothic-fonts.noarch 0:20100126-1.fc11 set to be updated
---> Package vlgothic-fonts-common.noarch 0:20100126-1.fc11 set to be updated
--> Finished Dependency Resolution
transmission-common-1.91-1.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libssl.so.8()(64bit) is needed by package transmission-common-1.91-1.fc11.x86_64 (updates)
1:qt-4.6.2-3.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libssl.so.8()(64bit) is needed by package 1:qt-4.6.2-3.fc11.x86_64 (updates)
boinc-client-6.10.33-1.r20470svn.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libcrypto.so.8()(64bit) is needed by package boinc-client-6.10.33-1.r20470svn.fc11.x86_64 (updates)
boinc-manager-6.10.33-1.r20470svn.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libcrypto.so.8()(64bit) is needed by package boinc-manager-6.10.33-1.r20470svn.fc11.x86_64 (updates)
transmission-gtk-1.91-1.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libcrypto.so.8()(64bit) is needed by package transmission-gtk-1.91-1.fc11.x86_64 (updates)
kdebase-workspace-4.4.0-8.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libxklavier.so.12()(64bit) is needed by package kdebase-workspace-4.4.0-8.fc11.x86_64 (updates)
boinc-manager-6.10.33-1.r20470svn.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libssl.so.8()(64bit) is needed by package boinc-manager-6.10.33-1.r20470svn.fc11.x86_64 (updates)
boinc-client-6.10.33-1.r20470svn.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libssl.so.8()(64bit) is needed by package boinc-client-6.10.33-1.r20470svn.fc11.x86_64 (updates)
1:qt-mysql-4.6.2-3.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libssl.so.8()(64bit) is needed by package 1:qt-mysql-4.6.2-3.fc11.x86_64 (updates)
1:qt-4.6.2-3.fc11.i586 from updates has depsolving problems
--> Missing Dependency: libcrypto.so.8 is needed by package 1:qt-4.6.2-3.fc11.i586 (updates)
transmission-gtk-1.91-1.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libssl.so.8()(64bit) is needed by package transmission-gtk-1.91-1.fc11.x86_64 (updates)
1:qt-4.6.2-3.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libcrypto.so.8()(64bit) is needed by package 1:qt-4.6.2-3.fc11.x86_64 (updates)
1:qt-mysql-4.6.2-3.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libcrypto.so.8()(64bit) is needed by package 1:qt-mysql-4.6.2-3.fc11.x86_64 (updates)
transmission-common-1.91-1.fc11.x86_64 from updates has depsolving problems
--> Missing Dependency: libcrypto.so.8()(64bit) is needed by package transmission-common-1.91-1.fc11.x86_64 (updates)
1:qt-4.6.2-3.fc11.i586 from updates has depsolving problems
--> Missing Dependency: libssl.so.8 is needed by package 1:qt-4.6.2-3.fc11.i586 (updates)
Error: Missing Dependency: libssl.so.8()(64bit) is needed by package 1:qt-mysql-4.6.2-3.fc11.x86_64 (updates)
Error: Missing Dependency: libssl.so.8 is needed by package 1:qt-4.6.2-3.fc11.i586 (updates)
Error: Missing Dependency: libxklavier.so.12()(64bit) is needed by package kdebase-workspace-4.4.0-8.fc11.x86_64 (updates)
Error: Missing Dependency: libcrypto.so.8()(64bit) is needed by package boinc-client-6.10.33-1.r20470svn.fc11.x86_64 (updates)
Error: Missing Dependency: libcrypto.so.8()(64bit) is needed by package transmission-gtk-1.91-1.fc11.x86_64 (updates)
Error: Missing Dependency: libssl.so.8()(64bit) is needed by package 1:qt-4.6.2-3.fc11.x86_64 (updates)
Error: Missing Dependency: libcrypto.so.8 is needed by package 1:qt-4.6.2-3.fc11.i586 (updates)
Error: Missing Dependency: libcrypto.so.8()(64bit) is needed by package 1:qt-4.6.2-3.fc11.x86_64 (updates)
Error: Missing Dependency: libssl.so.8()(64bit) is needed by package transmission-common-1.91-1.fc11.x86_64 (updates)
Error: Missing Dependency: libcrypto.so.8()(64bit) is needed by package boinc-manager-6.10.33-1.r20470svn.fc11.x86_64 (updates)
Error: Missing Dependency: libssl.so.8()(64bit) is needed by package transmission-gtk-1.91-1.fc11.x86_64 (updates)
Error: Missing Dependency: libcrypto.so.8()(64bit) is needed by package transmission-common-1.91-1.fc11.x86_64 (updates)
Error: Missing Dependency: libcrypto.so.8()(64bit) is needed by package 1:qt-mysql-4.6.2-3.fc11.x86_64 (updates)
Error: Missing Dependency: libssl.so.8()(64bit) is needed by package boinc-client-6.10.33-1.r20470svn.fc11.x86_64 (updates)
Error: Missing Dependency: libssl.so.8()(64bit) is needed by package boinc-manager-6.10.33-1.r20470svn.fc11.x86_64 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
Reply With Quote
  #14  
Old 3rd March 2010, 01:11 AM
crasypantz Offline
Registered User
 
Join Date: Jun 2009
Posts: 18
windows_xp_2003firefox
Updating dhclient gets me:

Quote:
[root@tequila patron]# yum update dhclient
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: mirrors.pavlovmedia.net
* livna: rpm.livna.org
* rpmfusion-free: mirrors.tummy.com
* rpmfusion-free-updates: mirrors.tummy.com
* rpmfusion-nonfree: mirrors.tummy.com
* rpmfusion-nonfree-updates: mirrors.tummy.com
* updates: mirrors.pavlovmedia.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package dhclient.x86_64 12:4.1.1-5.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ================================================== ================================================== ================================================== =====================================
Package Arch Version Repository Size
================================================== ================================================== ================================================== ================================================== =====================================
Installing:
dhclient x86_64 12:4.1.1-5.fc12 updates 330 k
replacing dhcpv6-client.x86_64 1.2.0-2.fc11


Transaction Summary
================================================== ================================================== ================================================== ================================================== =====================================
Install 1 Package(s)
Upgrade 0 Package(s)

Total download size: 330 k
Is this ok [y/N]: y
Downloading Packages:
dhclient-4.1.1-5.fc12.x86_64.rpm | 330 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/share/man/man5/dhcp-eval.5.gz from install of dhclient-12:4.1.1-5.fc12.x86_64 conflicts with file from package dhcp-12:4.1.0p1-5.fc11.x86_64
file /usr/share/man/man5/dhcp-options.5.gz from install of dhclient-12:4.1.1-5.fc12.x86_64 conflicts with file from package dhcp-12:4.1.0p1-5.fc11.x86_64

Error Summary
-------------

Booooooo. I can't seem to win this one.
Reply With Quote
  #15  
Old 9th March 2010, 06:08 PM
crasypantz Offline
Registered User
 
Join Date: Jun 2009
Posts: 18
windows_xp_2003firefox
Re: Troubling upgrading to FC12 due to conflicts and dependcy problems

Well, I decided to bite the bullet and erase cryptsetup-luks. And whadda ya know- with 'yum upgrade --skip-broken' i was able to upgrade! So now we're cookin'. After the upgrade i did a 'startx' and much to my surprise it took me straight to the desktop. (And now the creepy music starts in...) I noticed my mouse and keyboard inputs didn't seem to do anything. Oh well- maybe a quick reboot would fix that (I'm a Windows zombie). I initiated a restart through a remote terminal and it kicked off. I walked away, came back- kernal panic jibberish was on the screen. Seemed to complain about some USB stuff. The only devices attached were the my mouse and keyboard so naturally I unplugged them and restarted again, this time via power button. Second attempt was not even as lucky as the first. Fedora started booting and said 'dracut: Starting plymouth daemon'. Then, if memory serves me correctly, it said the 'tsc' clock was way off followed by 'Switching to clocksource hpet'. This lead to no more activity I could see. Finally, I've reset twice and now it only gets as far as 'dracut: ...'. I'm not even offered an interactive startup. So- am I goat f'ed? Start from scratch? Install Ubuntu? Any further help is, of course, appreciated.
Reply With Quote
Reply

Tags
conflicts, dependency, fc12, problems, trouble, upgrading

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading to FC12 may have been a mistake MSich Installation, Upgrades and Live Media 3 9th February 2010 08:59 PM
Problems on resume from suspend to ram with cq60-420us since upgrading to fc12 tedtlogan Hardware & Laptops 2 28th December 2009 09:12 AM
package conflicts: assemble dependency lists? Nick Levinson Installation, Upgrades and Live Media 2 12th June 2009 09:59 AM
dependency conflicts after fresh install (core6) vettehap Installation, Upgrades and Live Media 4 16th May 2007 05:40 AM
Dependency problems upgrading from FC5 to FC6 with yum nigel_b EOL (End Of Life) Versions 5 8th April 2007 09:38 AM


Current GMT-time: 13:23 (Tuesday, 22-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat