Fedora Linux Support Community & Resources Center
  #1  
Old 26th February 2010, 01:53 AM
pukas Offline
Registered User
 
Join Date: Feb 2010
Posts: 9
linuxfedorafirefox
Unhappy KPackageKit: Failed to initialize packaging backend.

I have error in KPackageKit when i try to install anything or check for updates:

Failed to initialize packaging backend.
This may occur if other packaging tools are being used simultaneously.


Details:
There are unfinished transactions remaining. Please run yum-complete-transaction as root.

I don't know anything about other packaging tools - I think I don't using any.
Yum works fine in terminal. Reinstall PackageKit and KPackageKit files doesn't helped me. I also try to rebuilt rpm db:

rm -f /var/lib/rpm/__db*
rpm -vv --rebuilddb
yum clean all


Also with no luck.
I'm using Fedora 12 x86_64.
Could you help me, please?
Reply With Quote
  #2  
Old 26th February 2010, 02:49 AM
Demz
Guest
 
Posts: n/a
windows_7firefox
try this installing yum-complete-transaction in Terminal then Run it
Reply With Quote
  #3  
Old 26th February 2010, 02:50 AM
steelaworkn Offline
Registered User
 
Join Date: Dec 2008
Location: Pacific Northwest
Age: 47
Posts: 1,140
linuxfedorafirefox
Sorry you are having trouble with the package kit. A lot of people just use yum for updates and ignore the package kit alerts or even turn off automatic updates. But, that said, for me, F12 is the first edition that I have actually been able to use the KPackage program for all updates and upgrades and it works flawlessly.

Amazing isn't it? One guy's system works and another guy's doesn't. It's the same OS, but for some reason, there seems to be no two builds that are alike.
__________________
My setup:

Intel DP35DP MB; Nvidia 440 2 gig Video Card; 8 gigs of ram; Intel Core Duo 2.20 gig; Hp Officejet Pro L7580; LVM F20 64bit using 3 320g HDs and dual monitors.
Reply With Quote
  #4  
Old 26th February 2010, 04:15 PM
pukas Offline
Registered User
 
Join Date: Feb 2010
Posts: 9
linuxfedorafirefox
Yep..

Unfortunately it isn't work at all. It strange, because it's new installation of Fedora, not upgrade from older version (after upgrade from F10 i had so many troubles, that i decided to install fresh system) so it should work perfectly.
Who knows, maybe with some update problem will solve by itself?

---------- Post added at 05:15 PM CST ---------- Previous post was at 05:06 PM CST ----------

Quote:
Originally Posted by Demz View Post
try this installing yum-complete-transaction in Terminal then Run it
I can't do this, because it will erase half of all my packages
Problem with KPackageKit started just after installation of Fedora, before i broke this transaction...
Reply With Quote
  #5  
Old 26th February 2010, 09:46 PM
Demz
Guest
 
Posts: n/a
windows_7firefox
Quote:
Originally Posted by pukas View Post
Unfortunately it isn't work at all. It strange, because it's new installation of Fedora, not upgrade from older version (after upgrade from F10 i had so many troubles, that i decided to install fresh system) so it should work perfectly.
Who knows, maybe with some update problem will solve by itself?

---------- Post added at 05:15 PM CST ---------- Previous post was at 05:06 PM CST ----------



I can't do this, because it will erase half of all my packages
Problem with KPackageKit started just after installation of Fedora, before i broke this transaction...
reinstall F12 or manually use that command i suggested above , i dont see any other fix for you
Reply With Quote
  #6  
Old 27th February 2010, 12:15 AM
pukas Offline
Registered User
 
Join Date: Feb 2010
Posts: 9
linuxfedorafirefox
Thumbs up Solved

I took the risk and run yum-complete-transaction. After erase many many packages I installed some again from DVD and rest updated from repo (when I was able to connect) and after few hours fight with ny desktop KPackageKit finally get alive!
yeah!

Thanks you all for helping me. I didn't expect that yum-complete-transaction will help in this case.
Reply With Quote
  #7  
Old 9th March 2010, 01:38 PM
1qaz2wsx Offline
Registered User
 
Join Date: Mar 2010
Posts: 1
linuxfedorafirefox
Re: KPackageKit: Failed to initialize packaging backend.

I had the same problem and I solved it doing the yum-complete-transaction several times. Note that you often must to do it several times because in each run it only completes one transaction!
Reply With Quote
  #8  
Old 7th April 2010, 03:20 AM
N4ck0 Offline
Registered User
 
Join Date: Jan 2010
Posts: 10
linuxfedorafirefox
Re: KPackageKit: Failed to initialize packaging backend.

i have problem like that

when i run yum-complete-transaction i got on my terminal like this

0 packages excluded due to repository protections
Checking for new repos for mirrors
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 0 elements left to run
Nothing in the unfinished transaction to cleanup.
Cleaning up completed transaction file
Reply With Quote
  #9  
Old 15th April 2010, 03:42 AM
Vukovi Offline
Registered User
 
Join Date: Feb 2010
Posts: 3
linuxfedorafirefox
Re: KPackageKit: Failed to initialize packaging backend.

Ran Yum-update-transaction after I got the same error message that began this thread...

Transaction Summary
================================================== ===============================================
Install 9 Package(s)
Upgrade 121 Package(s)
Remove 471 Package(s)
Reinstall 0 Package(s)
Downgrade 0 Package(s)

Total size: 113 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
im-chooser >= 1.2.5 is needed by ibus-1.2.1-1.fc12.i686
gnome-session is needed by desktop-effects-0.8.5-1.fc12.i686
gnome-session-xsession is needed by gnome-panel-2.28.0-16.fc12.i686
gnome-session is needed by gdm-1:2.28.2-3.fc12.i686
libgstfarsight-0.10.so.0 is needed by libpurple-2.6.6-2.fc12.i686
libempathy-gtk.so.28 is needed by nautilus-sendto-2.28.2-2.fc12.i686
libempathy.so.30 is needed by nautilus-sendto-2.28.2-2.fc12.i686
empathy-libs = 2.28.2-2.fc12 is needed by empathy-2.28.2-2.fc12.i686
libempathy-gtk.so.28 is needed by empathy-2.28.2-2.fc12.i686
libempathy.so.30 is needed by empathy-2.28.2-2.fc12.i686
libgstfarsight-0.10.so.0 is needed by empathy-2.28.2-2.fc12.i686
libtelepathy-farsight.so.0 is needed by empathy-2.28.2-2.fc12.i686
Not removing old transaction files

Now running it again I get basically the same information

/usr/lib/python2.6/site-packages/ABRTUtils.so: undefined symbol: _ZN10CDebugDump6CreateERKSsx
Loaded plugins: presto, refresh-packagekit
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 616 elements left to run

Can I fix this or do I just have to reinstall?
Reply With Quote
  #10  
Old 23rd February 2011, 12:03 PM
murenti Offline
Registered User
 
Join Date: Jan 2011
Location: Adelaide, South Australia
Posts: 49
linuxchrome
Re: KPackageKit: Failed to initialize packaging backend.

I have the same problem with kpackage kit failing to install but when I run yum-complete-transaction it says "Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
No unfinished transactions left."
But the kpackage kit error still remains, can anyone suggest anything else, please. Also my install is a fresh Fedora 14 64 bit
Reply With Quote
  #11  
Old 23rd February 2011, 12:19 PM
jakebpg Offline
Registered User
 
Join Date: Feb 2009
Location: Northeast
Posts: 292
linuxfedorafirefox
Re: KPackageKit: Failed to initialize packaging backend.

Quote:
Originally Posted by dmurphy787 View Post
I have the same problem with kpackage kit failing to install but when I run yum-complete-transaction it says "Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
No unfinished transactions left."
But the kpackage kit error still remains, can anyone suggest anything else, please. Also my install is a fresh Fedora 14 64 bit
try yum clean all
Reply With Quote
  #12  
Old 23rd February 2011, 12:45 PM
murenti Offline
Registered User
 
Join Date: Jan 2011
Location: Adelaide, South Australia
Posts: 49
linuxchrome
Re: KPackageKit: Failed to initialize packaging backend.

Nothing still see result below
"Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Cleaning repos: Dropbox fedora flash google-chrome google-earth rpmfusion-free
: rpmfusion-free-updates rpmfusion-nonfree
: rpmfusion-nonfree-updates updates
Cleaning up Everything
0 delta-package files removed, by presto"
Reply With Quote
  #13  
Old 1st March 2011, 05:28 PM
jakebpg Offline
Registered User
 
Join Date: Feb 2009
Location: Northeast
Posts: 292
linuxfedorafirefox
Re: KPackageKit: Failed to initialize packaging backend.

Quote:
Originally Posted by dmurphy787 View Post
Nothing still see result below
"Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Cleaning repos: Dropbox fedora flash google-chrome google-earth rpmfusion-free
: rpmfusion-free-updates rpmfusion-nonfree
: rpmfusion-nonfree-updates updates
Cleaning up Everything
0 delta-package files removed, by presto"
Try reinstalling kpackagekit with the following

yum reinstall kpackagekit
Reply With Quote
  #14  
Old 27th July 2012, 12:45 PM
ddgross Offline
Registered User
 
Join Date: Jul 2012
Location: TN
Posts: 1
linuxfirefox
Re: KPackageKit: Failed to initialize packaging backend.

I had the same issue and tried most of the proposed solutions. What finally did it for me was

# yum-complete-transaction --skip-broken --cleanup-only

This was Fedora 16
Reply With Quote
Reply

Tags
backend, failed, initialize, kpackagekit, packaging

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GLX failed to initialize Pioden Using Fedora 5 3rd February 2010 10:13 PM
F11: /usr/lib/cups/backend/hp failed archimede Using Fedora 5 3rd September 2009 12:37 PM
KPackageKit authentication failed message CollieJim Using Fedora 1 25th April 2009 06:04 AM
xine failed to initialize audio drivers sanjay_ankur Using Fedora 4 25th September 2008 09:05 AM
Failed to initialize TTM buffer manager Consequence_9 Using Fedora 5 24th May 2008 01:52 AM


Current GMT-time: 07:07 (Wednesday, 03-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat