Fedora Linux Support Community & Resources Center
  #1  
Old 9th May 2010, 09:36 PM
dustfinger1 Offline
Registered User
 
Join Date: Jan 2009
Posts: 31
linuxfedorafirefox
Squid not sending out requests

Related info:
Code:
[dustfinger@thebad ~]$ uname -rso
Linux 2.6.32.11-99.fc12.x86_64 GNU/Linux

[dustfinger@thebad ~]$ sudo yum list squid
Loaded plugins: presto, refresh-packagekit
Installed Packages
squid.x86_64                       7:3.1.1-1.fc12                       @updates
I installed squid through yum. The config file is basically the same as the default (if not the same). Here's what I have, sans comments:

Code:
acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl localhost src ::1/128
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32
acl to_localhost dst ::1/128

acl localnet src 10.0.0.0/8	# RFC1918 possible internal network
acl localnet src 172.16.0.0/12	# RFC1918 possible internal network
acl localnet src 192.168.0.0/16	# RFC1918 possible internal network
acl localnet src fc00::/7   # RFC 4193 local private network range
acl localnet src fe80::/10  # RFC 4291 link-local (directly plugged) machines

acl SSL_ports port 443
acl Safe_ports port 80		# http
acl Safe_ports port 21		# ftp
acl Safe_ports port 443		# https
acl Safe_ports port 70		# gopher
acl Safe_ports port 210		# wais
acl Safe_ports port 1025-65535	# unregistered ports
acl Safe_ports port 280		# http-mgmt
acl Safe_ports port 488		# gss-http
acl Safe_ports port 591		# filemaker
acl Safe_ports port 777		# multiling http
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager

http_access deny !Safe_ports

http_access deny CONNECT !SSL_ports

http_access deny to_localhost

http_access allow localnet
http_access allow localhost

http_access deny all

http_port 3128

hierarchy_stoplist cgi-bin ?

coredump_dir /var/spool/squid

refresh_pattern ^ftp:		1440	20%	10080
refresh_pattern ^gopher:	1440	0%	1440
refresh_pattern -i (/cgi-bin/|\?) 0	0%	0
refresh_pattern .		0	20%	4320
Squid starts up fine, but when I run something like "curl --socks5 localhost:3128 www.google.com" in bash, it just sits there and nothing happens. Looking on wireshark, curl connects to squid (syn, syn-ack, and ack), then curl sends about 4 bytes of data which is ack'd by squid, and then nothing. I have no idea what the problem may be, curl can access www.google.com fine on its own, as can firefox (which also timesout when trying to use squid).
Reply With Quote
  #2  
Old 10th May 2010, 12:52 PM
kaushalpatel198 Offline
Registered User
 
Join Date: Nov 2009
Location: Ahmedabad
Posts: 7
linuxfedorafirefox
Re: Squid not sending out requests

I hope you have enabled IP forwarding in sysctl.conf. If you have not done it, Please do it first. open sysctl.conf. change "net.ipv4.ip_forward = 0" to "net.ipv4.ip_forward = 1". then run command from console "sysctl -p" after saving the ip forwarding in sysctl.conf. then check squid again.
Reply With Quote
  #3  
Old 10th May 2010, 05:51 PM
dustfinger1 Offline
Registered User
 
Join Date: Jan 2009
Posts: 31
linuxfedorafirefox
Re: Squid not sending out requests

I did not, but I don't remember having to do that the last time I set squid up on this machine (way back with fedora 10). In any case, here's the output after I changed the value:
Code:
[dustfinger@thebad ~]$ sudo sysctl -p
net.ipv4.ip_forward = 1
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.accept_source_route = 0
kernel.sysrq = 0
kernel.core_uses_pid = 1
error: "net.bridge.bridge-nf-call-ip6tables" is an unknown key
error: "net.bridge.bridge-nf-call-iptables" is an unknown key
error: "net.bridge.bridge-nf-call-arptables" is an unknown key
No change in squid's not working though
Reply With Quote
Reply

Tags
requests, sending, squid

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LCP: timeout sending Config-Requests wprauchholz Servers & Networking 1 5th February 2006 02:59 PM


Current GMT-time: 15:53 (Tuesday, 30-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat