Fedora Linux Support Community & Resources Center
  #1  
Old 2nd August 2010, 06:42 PM
boardstretcher Offline
Registered User
 
Join Date: Aug 2010
Posts: 25
linuxfedorafirefox
Angry Intel Wifi 5300 AGN freezes Dell XPS when pressing wifi button

I have a Dell XPS 1640 with an Intel Corp. PRO/Wireless 5300 AGN wifi card. When i press the radio on/off button, fedora goes to a screen with the fedora logo, starts blinking the caps lock and becomes completely non-responsive to keypresses or mouse. I have to shut it down after.

So, how do I make the radion on/off button work correctly?

# lspci | grep Intel
04:00.0 Network controller: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] Network Connection

# iwconfig | grep wlan

wlan0 IEEE 802.11abgn Mode:Managed Access Point: Not-Associated
Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

# lsmod|grep wmi
dell_wmi 1561 0
wmi 5620 1 dell_wmi

Last edited by boardstretcher; 3rd August 2010 at 04:30 PM.
Reply With Quote
  #2  
Old 3rd August 2010, 02:16 PM
boardstretcher Offline
Registered User
 
Join Date: Aug 2010
Posts: 25
linuxfedorafirefox
Angry Re: Intel Wifi 5300 AGN freezes Dell XPS when pressing wifi button

Any pointers?
Reply With Quote
  #3  
Old 4th August 2010, 03:59 PM
boardstretcher Offline
Registered User
 
Join Date: Aug 2010
Posts: 25
linuxfedorafirefox
Angry Re: Intel Wifi 5300 AGN freezes Dell XPS when pressing wifi button

Any ideas?
Reply With Quote
  #4  
Old 5th August 2010, 03:11 PM
boardstretcher Offline
Registered User
 
Join Date: Aug 2010
Posts: 25
linuxfedorafirefox
Re: Intel Wifi 5300 AGN freezes Dell XPS when pressing wifi button

Come on, three days and not a single idea?
Reply With Quote
  #5  
Old 12th August 2010, 02:29 PM
boardstretcher Offline
Registered User
 
Join Date: Aug 2010
Posts: 25
linuxfedorafirefox
Thumbs down Re: Intel Wifi 5300 AGN freezes Dell XPS when pressing wifi button

Well, if anyone runs into this thread, looking for help with this issue -- I'm sorry to report that there is none. No one has any help to give on the issue.

I do have a solution for you that worked for me.

Uninstall Fedora and install Ubuntu. For the XPS 1640 all the drivers are already there, unlike Fedora.
Reply With Quote
Reply

Tags
wifi xps

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WiFi detects networks but will not connect properly (Wifi Link 5300) Mikademus Servers & Networking 44 12th December 2011 07:42 PM
F13 WIFI Intel 5300 crash with kernel tridc Hardware & Laptops 5 2nd June 2010 11:29 PM
can't enabl wifi button on conpaq presario v2000 laptop soloban Servers & Networking 1 9th December 2006 05:30 PM
Intel Wifi in Dell XPS m170 mordex Hardware & Laptops 1 6th November 2006 07:08 PM
wifi problem: sleep on lid close vs. button event? mightymouse Hardware & Laptops 1 7th August 2006 06:16 PM


Current GMT-time: 12:45 (Tuesday, 29-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat