Fedora Linux Support Community & Resources Center
  #1  
Old 18th August 2010, 06:58 AM
987my Offline
Registered User
 
Join Date: Aug 2010
Posts: 11
linuxfedorafirefox
Problem with Grub for other distro, set time and date

Hello, I'm totally new to fedora but not Linux (uses Ubuntu). Here's my problem after installing:
  1. I've just installed Fedora 13 on my computer for the very first time which before this has Ubuntu 10.04 and Windows XP already installed. I installed the fedora 13 boot loader during the installation and I noticed that it replaced the Ubuntu version. It works fine for Fedora and Windows but not for Ubuntu. Ubuntu is not listed in the boot menu. I try to run update-grub, but there's no such command! What is the command to do the same job as update-grub in F13?
  2. During the installation I did not choose get time and date from network. Now I had to manually change the time and date to fit my current location. Is there any way I can change my settings so that the time follows time and date on some server or something?

Thanks in advance.
Reply With Quote
  #2  
Old 18th August 2010, 10:18 AM
glennzo Offline
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,873
linuxfedorafirefox
Re: Problem with Grub for other distro, set time and date

For the system time you can use the ntpd service. Open a terminal and type
Code:
su -c 'chkconfig --level 35 ntpd on'
su -c 'service ntpd start'
Or use the services gui found under System > Administration > Services

For the grub question, personally I would just reinstall Ubuntu's bootloader and use sudo update-grub from within Ubuntu. Might be the best option if you intend to continue using Ubuntu along side Fedora.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #3  
Old 18th August 2010, 11:59 AM
987my Offline
Registered User
 
Join Date: Aug 2010
Posts: 11
linuxfedorafirefox
Re: Problem with Grub for other distro, set time and date

Quote:
Originally Posted by glennzo View Post
For the system time you can use the ntpd service. Open a terminal and type
Code:
su -c 'chkconfig --level 35 ntpd on'
su -c 'service ntpd start'
Or use the services gui found under System > Administration > Services

For the grub question, personally I would just reinstall Ubuntu's bootloader and use sudo update-grub from within Ubuntu. Might be the best option if you intend to continue using Ubuntu along side Fedora.
Thank you, that solves the problem.

About the grub, I initially can't login to Ubuntu since it's not listed in the grub menu. After some research, I found that Fedora13 uses grub not grub-pc and it uses the grub.conf file. So I editted that file and add Ubuntu to the grub menu and solved that problem.

Thanks again!
Reply With Quote
  #4  
Old 18th August 2010, 01:19 PM
glennzo Offline
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,873
windows_xp_2003firefox
Re: Problem with Grub for other distro, set time and date

Glad that all worked for you. I learned something here too. I wasn't aware that you could successfully boot Ubuntu using Fedora's grub.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #5  
Old 18th August 2010, 01:42 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,564
linuxopera
Re: Problem with Grub for other distro, set time and date

You can--I remember Bob and I having a discussion about it, wasn't working for me, worked for him.

What I've found is that Ubuntu puts a symlink to their vmlinuz and init files in /. So you can bypass its grub by doing, after specifying the partition

kernel=vmlinuz
initrd=initrd.img

WIthout pointing to its grub. (I might be wrong on the path, the symlinks might be /boot/vmlinuz and /boot/initrd.img.

On the other hand, when Bob and I had this discussion, some time ago, for him, the usual chainloader +1 worked perfectly--might have been a typo on my part, it was awhile ago.
Reply With Quote
Reply

Tags
date, distro, grub, problem, set, time

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The system date and time is changing automatically, even after I set the correct time siva Using Fedora 8 31st July 2010 03:07 PM
Problem with Date/Time in Mozilla Software: FC10 riddleshadow Using Fedora 0 16th March 2009 08:30 PM
What is/was your favorite Linux Distro? (to date) Dan Linux Chat 39 21st December 2008 07:04 AM
Broke Time/Date applet (can't change time) ZystemsK Using Fedora 8 3rd October 2008 01:42 AM
Time Date ? fedorabobblue Using Fedora 3 14th March 2006 12:29 PM


Current GMT-time: 07:59 (Friday, 26-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Via Roma, Fossano Photos on Instagram - Ningbo City, China Photos - Mama Pizza - Be Free Instagram Photos