Fedora Linux Support Community & Resources Center
  #1  
Old 5th September 2010, 08:12 AM
borispr Offline
Registered User
 
Join Date: Sep 2010
Posts: 21
linuxfedorafirefox
SOLVED F13: gnome-mplayer does not start in fullscreen

gnome-mplayer --fullscreen file.avi
opens file in the window, manually I can switch it to fullscreen but I need to start in fullscreen from command line

mplayer -f file.avi opens in fullscreen from the beginning but if to play a list it shows desktop between files

Does anybody know how to fix the problem with gnome-mplayer?

Last edited by borispr; 6th September 2010 at 04:49 PM.
Reply With Quote
  #2  
Old 5th September 2010, 08:39 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Re: F13: gnome-mplayer does not start in fullscreen

Try this as non-root
Code:
gconftool-2 --type boolean --set /apps/gnome-mplayer/preferences/fullscreen true
Reply With Quote
  #3  
Old 5th September 2010, 08:43 AM
borispr Offline
Registered User
 
Join Date: Sep 2010
Posts: 21
linuxfedorafirefox
Re: F13: gnome-mplayer does not start in fullscreen

Quote:
Originally Posted by leigh123linux View Post
Try this as non-root
Code:
gconftool-2 --type boolean --set /apps/gnome-mplayer/preferences/fullscreen true
Same result, starts in window
Reply With Quote
  #4  
Old 5th September 2010, 09:39 AM
bonedome Offline
Registered User
 
Join Date: Apr 2010
Location: uk
Posts: 727
linuxfirefox
Re: F13: gnome-mplayer does not start in fullscreen

Hello
try adding -zoom -fs to the commandline
Code:
mplayer -zoom -fs ~/tv/Bikes_-_2010_Ulster_Grand_Prix_-_Part_1.mp4
this is for mplayer but gnome-mplayer is just a front for mplayer so should work ok
or you could add these lines to your ~/.mplayer/config (unless there's a separate config for gnome-mplayer)
Code:
zoom=yes
fs=yes
__________________
fedora 14 fluxbox and gnome2 hp compaq nx9030 laptop 2Gb ram, helicopter landing pad, jacuzzi, mini fridge, gateway to alternative dimension
Reply With Quote
  #5  
Old 5th September 2010, 10:12 AM
borispr Offline
Registered User
 
Join Date: Sep 2010
Posts: 21
linuxfedorafirefox
Re: F13: gnome-mplayer does not start in fullscreen

Quote:
Originally Posted by bonedome View Post
gnome-mplayer is just a front for mplayer
yep but seems it does not pass -fs parameter to mplayer at the start

Quote:
Originally Posted by bonedome View Post
or you could add these lines to your ~/.mplayer/config
Have tried already did not help.
The file is correct mplayer starts in fullscreen without -fs option but via gnome-player all the same

vlc starts in fullscreen but switches to desktop between files
totem starts in fullsreen and do not shows desktop BUT it does not perform required frame rate at VIA C7 mb

no luck

Last edited by borispr; 5th September 2010 at 10:16 AM.
Reply With Quote
  #6  
Old 5th September 2010, 06:32 PM
bonedome Offline
Registered User
 
Join Date: Apr 2010
Location: uk
Posts: 727
windows_xp_2003firefox
Re: F13: gnome-mplayer does not start in fullscreen

Hello
sorry I don't use gnome-mplayer so can't be any more help, do you really need the gui ?
I think mplayer is the business, it's the only player that will play 720p on my laptop with no problems
__________________
fedora 14 fluxbox and gnome2 hp compaq nx9030 laptop 2Gb ram, helicopter landing pad, jacuzzi, mini fridge, gateway to alternative dimension
Reply With Quote
  #7  
Old 6th September 2010, 04:38 PM
borispr Offline
Registered User
 
Join Date: Sep 2010
Posts: 21
linuxfedorafirefox
Re: F13: gnome-mplayer does not start in fullscreen

Quote:
Originally Posted by bonedome View Post
do you really need the gui ? I think mplayer is the business
Yes but if play a list it switches to desktop between files while gnome-mplayer plays without breaks

---------- Post added at 07:38 PM CDT ---------- Previous post was at 11:26 AM CDT ----------

The bug was fixed
http://code.google.com/p/gnome-mplay.../detail?id=434
Reply With Quote
  #8  
Old 6th September 2010, 05:04 PM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Re: F13: gnome-mplayer does not start in fullscreen

Quote:
Originally Posted by borispr View Post
Yes but if play a list it switches to desktop between files while gnome-mplayer plays without breaks

---------- Post added at 07:38 PM CDT ---------- Previous post was at 11:26 AM CDT ----------

The bug was fixed
http://code.google.com/p/gnome-mplay.../detail?id=434
Here's a fixed srpm (source package)


http://dl.dropbox.com/u/6907158/gnom...2.fc13.src.rpm
Reply With Quote
Reply

Tags
f13, fullscreen, gnomemplayer, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer -vo xv won't do antialias in fullscreen mod ildg Using Fedora 10 27th November 2007 03:04 AM
Cannot run MPlayer fullscreen riksweeney Using Fedora 4 25th November 2007 07:04 PM
mplayer fullscreen problem jafar Using Fedora 1 6th January 2006 10:46 AM
Mplayer hide mouse cursor in fullscreen? madiyaan Using Fedora 0 20th September 2005 10:49 PM


Current GMT-time: 17:10 (Wednesday, 27-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat