Fedora Linux Support Community & Resources Center
  #1  
Old 24th September 2010, 08:52 PM
deadcella Offline
Registered User
 
Join Date: Sep 2010
Posts: 11
linuxfedorafirefox
Angry F13 - NIS GUI login problem

Hi all,

I have a problem concerning about NIS.
I have set-up a NIS client, but I am not able to login as NIS-user by using GNOME or KDE login GUI.
However, I was able to login as NIS-user by using a terminal that's open from a local account or root. Also the NFS seems working as well.

This problem only occur on my new FC13 pc, and I don't have this problem on my FC10 pc. Both of my FC13 and FC10 PC have the same NFS and NIS setting.

Does anyone has an idea about how to fix this?
Any help would be appreciate! Thanks in advanced!

Regards,

Last edited by deadcella; 24th September 2010 at 10:33 PM.
  #2  
Old 24th September 2010, 10:25 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,772
linuxfedorafirefox
Re: F13 - NIS GUI login problem

you might check the file /etc/pam.d/gdm and make sure the NIS module is included.

You can compair it (visually) with the /etc/pam.d/login file - they should be nearly
identical as far as the NIS library modules go.
  #3  
Old 25th September 2010, 06:57 PM
deadcella Offline
Registered User
 
Join Date: Sep 2010
Posts: 11
linuxfedorafirefox
Re: F13 - NIS GUI login problem

Thank you very much for your reply.

My /etc/pam.d/gdm, looks like the following

Quote:
#%PAM-1.0
auth [success=done ignore=ignore default=bad] pam_selinux_permit.so
#auth required pam_succeed_if.so user != root quiet
auth required pam_env.so
auth substack system-auth
auth optional pam_gnome_keyring.so
account required pam_nologin.so
account include system-auth
password include system-auth
session required pam_selinux.so close
session required pam_loginuid.so
session optional pam_console.so
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
session optional pam_gnome_keyring.so auto_start
session include system-auth
And my /etc/pam.d/login looks like this:

Quote:
#%PAM-1.0
auth [user_unknown=ignore success=ok ignore=ignore default=bad] pam_securetty.so
auth include system-auth
account required pam_nologin.so
account include system-auth
password include system-auth
# pam_selinux.so close should be the first session rule
session required pam_selinux.so close
session required pam_loginuid.so
session optional pam_console.so
# pam_selinux.so open should only be followed by sessions to be executed in the user context
session required pam_selinux.so open
session required pam_namespace.so
session optional pam_keyinit.so force revoke
session include system-auth
session optional pam_ck_connector.so

I have compared these two files with the one that I have on my FC10 pc, and they are identical. The question is why I am able to login as NIS-user from GUI login on my FC10 pc, but not on the FC13 pc?

Please let me know if you have any idea to fix the problem.
Thank you again for your time and help.

Regards,
  #4  
Old 25th September 2010, 07:30 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,772
linuxfedorafirefox
Re: F13 - NIS GUI login problem

Check the /etc/nsswitch.conf configuration. Mine has:

passwd: files

But for NIS to work it must have "nis" on the line as well. The /etc/nsswitch.conf
file should have an example (commented out) that shows the other options.

You also get to select what is checked first - usually the order is "files nis" meaning
that if the user has local entries in the passwd/shadow/group files, then it will be
used instead of NIS. This is reasonable, because you don't want NIS used for
the root account. NIS can be spoofed (though you can try nisplus instead, but that
is not using the basic NIS protocol).
  #5  
Old 25th September 2010, 07:51 PM
deadcella Offline
Registered User
 
Join Date: Sep 2010
Posts: 11
linuxfedorafirefox
Re: F13 - NIS GUI login problem

Thank you for your quick reply.

The nis has already included in the nsswitch.conf file, but I still can't login as NIS-user using the GUI login
My /etc/nsswitch.conf looks like this:


Quote:

# /etc/nsswitch.conf
#
# An example Name Service Switch config file. This file should be
# sorted with the most-used services at the beginning.
#
# The entry '[NOTFOUND=return]' means that the search for an
# entry should stop if the search in the previous entry turned
# up nothing. Note that if the search failed due to some other reason
# (like no NIS server responding) then the search continues with the
# next entry.
#
# Valid entries include:
#
# nisplus Use NIS+ (NIS version 3)
# nis Use NIS (NIS version 2), also called YP
# dns Use DNS (Domain Name Service)
# files Use the local files
# db Use the local database (.db) files
# compat Use NIS on compat mode
# hesiod Use Hesiod for user lookups
# [NOTFOUND=return] Stop searching if not found so far
#

# To use db, put the "db" in front of "files" for entries you want to be
# looked up first in the databases
#
# Example:
#passwd: db files nisplus nis
#shadow: db files nisplus nis
#group: db files nisplus nis

passwd: files nis
shadow: files nis
group: files nis

#hosts: db files nisplus nis dns
hosts: files nis dns

# Example - obey only what nisplus tells us...
#services: nisplus [NOTFOUND=return] files
#networks: nisplus [NOTFOUND=return] files
#protocols: nisplus [NOTFOUND=return] files
#rpc: nisplus [NOTFOUND=return] files
#ethers: nisplus [NOTFOUND=return] files
#netmasks: nisplus [NOTFOUND=return] files

bootparams: nisplus [NOTFOUND=return] files

ethers: files
netmasks: files
networks: files
protocols: files
rpc: files
services: files

netgroup: files nis

publickey: nisplus

automount: files nis
aliases: files nisplus

I really don't know why I am able to login as NIS-user from a local account terminal (using command line), but not from the login GUI.

I would appreciate any help you can give me to solve the problem. Thanks


Regards,
  #6  
Old 25th September 2010, 10:01 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,772
linuxfedorafirefox
Re: F13 - NIS GUI login problem

You might try setting

VerboseAuth=1

in the file /etc/gdm/custom.conf under the section "[security]" and restart gdm
(the command sequence telinit 3, followed by telinit 5 is the easiest).

This may give some error log information related to the problem.

There is a decent amount of documentation on /etc/gdm/custom.conf at:
http://www.ibiblio.org/oswg/oswg-nig...ence/x135.html

There may be some other reasons gdm refuses to log in - there is mention of
refusing when home directories are group/world writeable. See the part about
"RelaxPermissions".
  #7  
Old 27th September 2010, 08:00 PM
deadcella Offline
Registered User
 
Join Date: Sep 2010
Posts: 11
linuxfedorafirefox
Re: F13 - NIS GUI login problem

Thank you again for your reply.

I have tried the setting VerboseAuth=1, and then restart my computer. While I tried to login as NIS-user, the login window didn't give me an error log information, it only shown "Authentication Failure".

As per you suggested, I have also tried to set RelaxPermissions to 0, 1, or 2. But I still not able to login as NIS-user from the login screen.

Beside the steps I have tried above, I have also tried the following:

Case 1
Quote:
1: Login as root (or local user) from the login screen
2: Open a terminal
3: From the terminal, I have successfully login in as NIS-user
Case 2
Quote:
1: Login as root (or local user) from the login screen
2: Enter to virtual terminal (Ctrl + Alt + F2)
3: From the virtual terminal, I have successfully login in as NIS-user
Case 3
Quote:
1: Before go through the login screen, I entered to virtual terminal
2: From the virtual terminal, I WAS NOT able to login in as NIS-user
Case 4
Quote:
1: From the login screen, I WAS NOT able to login in as NIS-user using the login window
It seems that the NIS and NFS won't function correctly before I go through the login screen.
Do you have any idea what could be wrong?

I am greatly appreciate for your help.


Regards,
  #8  
Old 28th September 2010, 12:42 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,772
linuxfedorafirefox
Re: F13 - NIS GUI login problem

That cleared up some backgound - I didn't realize you couldn't login using the
virtual terminal with NIS (case 3).

Is it possible to ping the target system when no one is logged in? If not, then this
may point to the network being disabled when no one is logged in, this would
imply that network manager does not have the network up (which would
prevent NIS...). There are several other threads on this problem with network
manager (there is an option):

Quote:
I was able to make it available to all users by opening the terminal, and switching to su, and running the "nm-connection-editor" command. That open the connections window as root.
With this you should be able to select "allow all users".

Now if you want you could also disable networkmanager (chkconfig NetworkManager off)
and enable network (chkconfig network on). If you do
this without a reboot you can use "service NetworkManager stop" and
"service network start" to start the networks.

This should make the network available at all times (to me, this would seem
to be the normal situation, but It is possible to get the network manager module
to work properly, though it isn't as well documented).
  #9  
Old 29th September 2010, 04:31 PM
deadcella Offline
Registered User
 
Join Date: Sep 2010
Posts: 11
linuxfedorafirefox
Re: F13 - NIS GUI login problem

Problem solved by selecting "allow all users" in Network Configuration.
Thank you so much for your help!
  #10  
Old 25th July 2012, 06:20 AM
younis Offline
Registered User
 
Join Date: Jul 2012
Location: Hyderabad pakistan
Posts: 1
windows_7chrome
Re: F13 - NIS GUI login problem

hi i hav esame problem with fedora 12 can you help me out
  #11  
Old 25th July 2012, 02:35 PM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
linuxfirefox
Re: F13 - NIS GUI login problem

Thread closed because it is old. There often is not much point in joining a discussion that ended two years ago. And almost nobody is going to read through all that old stuff before looking at what you want now.

Thread moved to EOL (End-of-LIfe) Versions because that is what Fedora 13 is now and since your post bumped the thread back to the first page.

I recommend that you start a new thread in the EOL Versions sub-forum for your Fedora 12 issue. Describe your problem in detail. Refer to this thread if you like, but continue on in your new thread. Help will come. I'm sure.
Closed Thread

Tags
f13, gui, login, nis, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
f13-login problem green-cat-fed Installation, Upgrades and Live Media 11 24th June 2010 12:16 PM
Login Problem anchorschmidt Using Fedora 1 22nd August 2009 07:25 AM
after upgrade to F8 only X-login, but failing to login, returns to login screen angro Installation, Upgrades and Live Media 1 26th November 2007 08:12 PM
FC4 Login problem hydenicc Using Fedora 6 9th March 2006 05:16 PM
Login Problem Lookie Using Fedora 2 31st July 2004 08:33 AM


Current GMT-time: 14:36 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat